Download it now!
Bug 41174 - EPS images in documents get corrupt when exporting to PDF
Summary: EPS images in documents get corrupt when exporting to PDF
Status: RESOLVED DUPLICATE of bug 34836
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-24 09:01 UTC by Milan Bouchet-Valat
Modified: 2012-08-31 10:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT file that gets corrupt on export (32.62 KB, application/vnd.oasis.opendocument.text)
2011-09-24 09:01 UTC, Milan Bouchet-Valat
Details
Wrong PDF exported from LO on Mac OS C 10.5 (17.76 KB, application/download)
2011-09-24 09:02 UTC, Milan Bouchet-Valat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Bouchet-Valat 2011-09-24 09:01:31 UTC
Created attachment 51575 [details]
ODT file that gets corrupt on export

The attached testcase ODT isn't exported properly to PDF on Mac OS X 10.5. The .eps image included in it doesn't appear: it's replaced by a large text in red:
> Creator:Sun Microsystems, Inc.
> LanguageLevel:2

See attached PDF to see the result.

(This works fine on Linux.)
Comment 1 Milan Bouchet-Valat 2011-09-24 09:02:07 UTC
Created attachment 51576 [details]
Wrong PDF exported from LO on Mac OS C 10.5
Comment 2 Björn Michaelsen 2011-12-23 12:34:58 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Florian Reisinger 2012-08-14 13:58:09 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 13:59:26 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:04:02 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:06:15 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Milan Bouchet-Valat 2012-08-19 09:35:21 UTC
Confirmed with attached testcase and LO 3.5.6 on Mac OS X 10.5.
Comment 8 Rainer Bielefeld Retired 2012-08-20 08:51:18 UTC
I even can't see the EPS in the .odt (only placeholder box), so difficult to reproduce with "LibreOffice 3.6.1.1  German UI/Locale [Build-ID:  4db6344] on German WIN7 Home Premium (64bit) 
Same problem with 3.4.5

@Roman:
What do you think, DUP pf "Bug 34836 - PDF export does not export EPS images "?
Comment 9 Milan Bouchet-Valat 2012-08-20 09:58:17 UTC
(In reply to comment #8)
> I even can't see the EPS in the .odt (only placeholder box), so difficult to
> reproduce with "LibreOffice 3.6.1.1  German UI/Locale [Build-ID:  4db6344] on
> German WIN7 Home Premium (64bit) 
> Same problem with 3.4.5
Weird. On both Linux (Fedora 17) and OS X 10.5, with LO 3.5.6.2 I'm able to see the thumbnail of the EPS. Export to PDF works right on Linux (except that the image is not scaled correctly, but that's another Ghostcript bug). I guess you've uncovered another bug, or a missing EPS support on Windows?
Comment 10 Roman Eisele 2012-08-20 10:40:53 UTC
REPRODUCIBLE with
* LibreOffice 3.4.0,
* LibreOffice 3.4.6,
* LibreOffice 3.5.6.2,
* LibreOffice 3.6.1.1 (Build ID: 4db6344),
all with German langpack installed, on MacOS X 10.6.8 (Intel).

When I open the file and try to export it as a PDF file, I get exactly the same results as the original reporter:

The .eps image doesn't appear: it's replaced by a red placeholder box
with red text, reading
> Creator:Sun Microsystems, Inc.
> LanguageLevel:2


(in reply to comment #8)
> I even can't see the EPS in the .odt (only placeholder box), so difficult to
> reproduce with "LibreOffice 3.6.1.1  German UI/Locale [Build-ID:  4db6344] on
> German WIN7 Home Premium (64bit)

I would say this is another bug, this times probably specific to Windows, because the .odt file seems to work fine for me. Maybe the EPS preview is in Mac PICT format, which is rather unknown on Windows; but LibreOffice (being cross-platform) should nevertheless be able to display the preview.

@Rainer:
Could you please file another bug report especially for this "missing preview" problem? Thank you!
Comment 11 Roman Eisele 2012-08-20 10:47:02 UTC
(In reply to comment #8)
> What do you think, DUP pf "Bug 34836 - PDF export does not export EPS images "?

Yes, it’s an exact duplicate -- the placeholder box and the comments (in red) are exactly the same. The amount of comments depends on the EPS file used, the comments just come from the header of the EPS file.

Therefore I mark this report as a duplicate of bug 34836. Please continue the generall discussion there.

*** This bug has been marked as a duplicate of bug 34836 ***