Bug Hunting Session
Bug 41241 - spell check is broken for templates on 3.4.x
Summary: spell check is broken for templates on 3.4.x
Status: RESOLVED DUPLICATE of bug 37195
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-09-26 13:23 UTC by mike.hall
Modified: 2011-09-27 04:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mike.hall 2011-09-26 13:23:02 UTC
There is plenty of chat in the forums about this, but oddly I can't find a bug report.

To create, open or create a new document with a user template. Spell check does not work. 

I have this on two different Windows PCs. Revert to 3.3.x and everything works perfectly, as it always has before.

I've marked this as a blocker because the product is useless without.
Comment 1 Rainer Bielefeld Retired 2011-09-26 23:31:36 UTC
Not reproducible  with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" and an own letter template i tested.

An unconfirmed problem with an obsolete version is not a blocker.

@mike.hall@onepoyle.net:
Please attach a sample document (if possible in English language and info how it has been created)) and a detailed instruction (step by step instruction) how to reproduce the problem.
Additionally please contribute information concerning
- Your Operating System
- Your LibO localization
- installed dictionaries
Comment 2 mike.hall 2011-09-27 01:24:54 UTC
The two systems where the problem occurred are:
Vista Ultimate 32 - all patches applied with LO 3.4.3 and resolved with 3.3.4
Win 7 professional 64 - all patches applied with LO 3.4.3, have not attempted to install 3.3.4 yet. 
I installed 3.4.2 followed by the English help pack in each case. The Win 7 installation was clean at 3.4.1 with 3.4.2 installed later (new PC), the Vista one was on a PC with many earlier versions.

AFAIK the dictionaries now installed are those that come with the distribution, ie various English, French, DE etc. The error is solid with every language I've tried, in fact it was when using German (Germany) that I discovered the problem.

My setup for years has been with my own templates, including the default. The path to the templates is set up in options and the default template path has been removed. I have used this setup across all our PCs for a long time unchanged. Spell check has always worked as expected. Now it doesn't work at all - the dialogue box appears but spelling errors are not found. I have reproduced that on both PCs with templates with styles set to DE DE and to EN GB, and the problem persists if the language choice is changed.

So, basically, I don't have to do anything to create the problem, it just happened. I hope this will give you sufficient info to reproduce the problem. As you have not been able to reproduce it, I will have a closer look on the Win 7 box to see if I can discover anything else. I can't see much point in attaching a specific template or document until I've done that, but there isn't anything special or complex in them.
Comment 3 mike.hall 2011-09-27 01:33:46 UTC
Ah, one additional point, there was various chatter in the forums that installing 3.4.3 RC2 was a way of solving the problem, ie that the distributed final version was for some reason working differently than the RC. I didn't try that as my need was, at the time, very urgent. However, this might explain why you aren't seeing the problem. I didn't install the RC on either PC.

Also to make things correct, one of my paras should have read (version numbers were wrong):
I installed 3.4.3 followed by the English help pack in each case. The Win 7
installation was clean at 3.4.2 with 3.4.3 installed later (new PC), the Vista
one was on a PC with many earlier versions.
Comment 4 vitriol 2011-09-27 01:35:46 UTC
IMHO it's just a duplicate of (in)famous Bug 37195.
@mike.hall@onepoyle.net
You can try this workaround:

https://bugs.freedesktop.org/show_bug.cgi?id=37195#c24
Comment 5 mike.hall 2011-09-27 01:47:36 UTC
@vitriol
Hm, maybe, I will have a look later, but that bug is supposed to have been fixed?
Comment 6 vitriol 2011-09-27 01:51:19 UTC
(In reply to comment #5)
> @vitriol
> but that bug is supposed to have been fixed?

Yes, but in next release.
Comment 7 Rainer Bielefeld Retired 2011-09-27 02:05:21 UTC
@vitriol:
Plausible assumption, reporter's latest comments lead to that direction, but

@reporter:
Do you see the problem with ALL documents you open after update 
(Your Comment 2: "it doesn't work at all" or really only in templates, as you wrote in Subject line ("is broken for templates")?
If it's for all documents it's a DUP as vitriol wrote.
AFAIK the fix will be in 3.4.3.
You can test the build from <http://dev-builds.libreoffice.org/daily/fdo37195/>, Please read
<https://bugs.freedesktop.org/show_bug.cgi?id=37195#c82>
<https://bugs.freedesktop.org/show_bug.cgi?id=37195#c87>
Comment 8 mike.hall 2011-09-27 03:02:31 UTC
@rainer
Thanks. I think you may mean the fix is in 3.4.4 - I have 3.4.3 already.

All our documents have templates and none work. I don't know how to create a document without a template - surely all have at least the default attached? Spell check also doesn't work for eg a .doc from elsewhere. The only reason I stressed 'user template' was because my default is not the LO default, which I seem to remember is generated on the fly rather than by attaching an object, and I wanted to make it clear that that option isn't possible on our systems because the default template is a user template object.

Sorry not to have noticed the relevant bug - I only searched within open ones.

I'd rather wait for the full release because I want to avoid parallel LO installations. Will the installation of 3.4.4 final over 3.4.3 correct the problem (if Vitriol's diagnosis is correct)?
Comment 9 mike.hall 2011-09-27 03:07:35 UTC
To clarify, all my comments relate to documents with user templates. I haven't tried spell-checking while editing a template.
Comment 10 Rainer Bielefeld Retired 2011-09-27 04:06:06 UTC
@mike.hall@onepoyle.net:
Yes, typo, Fix is in 3.4.4

You can use the linked 3.4.3 special version containing the fix without problems. I do no know whether it will repair the damaged user profile or only not damage a working one. I also do not know whether you have to uninstall your existing 3.4.3 before you install it, I recommend to uninstall.

I mar this one as DUP of Bug 37195 for now. Please feel free to reopen this Bug if you find evidence that we have an independent issue here.

*** This bug has been marked as a duplicate of bug 37195 ***