Bug 41342 - Libre Calc spreadsheet editing rows shifts and distort graphics vertically
Summary: Libre Calc spreadsheet editing rows shifts and distort graphics vertically
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-29 09:51 UTC by Robert Nowotny
Modified: 2014-12-19 13:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Nowotny 2011-09-29 09:51:50 UTC
When using a spredsheet with embedded graphics,
those graphics are shifted and sometimes distorted when inserting / deleting lines, sometimes simply by saving and re-opening the spreadsheet.

The more lines and the more graphics the spreadsheet contains, the worse.

The Effect is independent on OS. 

It will occur in version 3.4.3
the bug does not exist in version 3.3.4

The graphics are anchored in the cell.
Even protecting size and position does not help.

Here two sample files to play around. On the second one, the size and position is fixed (protected).

file#1: 
http://media.rotek.at/zsvc/librecalc/calc_grafiken_bad.ods

file#2: 
http://media.rotek.at/zsvc/librecalc/calc_grafiken_bad_protected.ods

yours sincerely
Ing. Robert Nowotny
Rotek GmbH
Hagenbrunn (near Vienna)
Comment 1 u2nBz 2011-11-08 06:42:22 UTC
Confirming this behavior, and possibly related to:

https://bugs.freedesktop.org/show_bug.cgi?id=42705
Comment 2 Björn Michaelsen 2011-12-23 12:35:27 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Florian Reisinger 2012-08-14 14:02:24 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:03:23 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:07:57 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:10:03 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian