Download it now!
Bug 41411 - LOCALHELP EDITING WRITER TABLE: Keyboard insertion/deletion of rows, columns, cells description incomplete
Summary: LOCALHELP EDITING WRITER TABLE: Keyboard insertion/deletion of rows, columns,...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-02 20:07 UTC by Allan Jacobs
Modified: 2018-10-14 05:54 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document, see Comment 1 (9.41 KB, application/vnd.oasis.opendocument.text)
2011-10-03 00:06 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Allan Jacobs 2011-10-02 20:07:42 UTC
Quoting from the 3.3 Writer Guide.

"You can also quickly insert a row or a column using only the keyboard:
1) Place the cursor in the row or column next to the row or column you want to insert.
2) Press Alt+Insert to activate keyboard handling.
3) Use the arrow keys as desired to add a row or column:
Left to insert a new column to the left of the cell where the cursor is located.
Right to insert a new column to the right of the cell where the cursor is.
Down to insert a new row below the cell where the cursor is.
Up to insert a new row above the cell where the cursor is.
The above keyboard technique can also be used to delete row
Alt+Insert keystroke combination in Step 2 with Alt+Delete."

Neither insertion nor deletion works as described.  The arrow key uses merely change the location of the cursor.
Comment 1 Rainer Bielefeld Retired 2011-10-03 00:05:43 UTC
NOT Reproducible with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]". But I see some Help and Manual issues.

Steps to reporduce:
0. Open attached sample document
1. Search Writer Help for "3 seconds", select shortcuts for writer, 
2. go to heading "Shortcut Keys for Tables in LibO-dev Writer", where you find
   required instructions
   Important: there you find the hint "3 seconds ..."
3. click C3
4. Test <Alt+Insert> 3 seconds then  <Rightarrow>
   As expected column inserted right from C3
5. Undo, click C3
6. Test <Alt+Insert> 3 seconds then  <Leftarrow>
   As expected column inserted left from C3
7. Undo, click C3
8. <Alt+Insert> 3 seconds then <Ctrl+Rightarrow>
   cell insertion as expected from Help, new cell right from C3, C4 shifted to 
   the right
9. Undo, click C3
10. <Alt+Insert> 3 seconds then <Ctrl+Leftarrow>
   cell insertion more or less as expected from Help, 
   C3 shifted to the left, new cell right from C3 
11. Undo, click C3
12. <Alt+Insert> 3 seconds then <Ctrl+Uparrow> (or <Ctrl+Downarrow>
   Expected: Some cell insertion, Uparrow and Downarrow not excluded in Help
   Actual: Nothing
13. Undo, click C3
14. <Alt+Del> 3 seconds then <Leftarrow>
   Column C deleted, Columns A,B shifted to the right
15. Undo, click C3
16. <Alt+Del> 3 seconds then <Rightarrow>
   Column C deleted, Column C shifted to the left
17. Undo, click C3
18. <Alt+Del> 3 seconds then <Uparrow>
    Row 3 deleted, cursor in C2
19. Undo, click C3
20. <Alt+Del> 3 seconds then <Downarrow>
    Row 3 deleted, cursor in C4
21. Undo, click C3
22. <Alt+Del> 3 seconds then <Ctrl+Rightarrow>
   Cell C3-D3 merged, Contents D3 remains
23. Undo, click C3
24. <Alt+Del> 3 seconds then <Ctrl+Leftarrow>
   Cell B3-C3 merged, Contents B3 remains
25. Undo, click C3
24. <Alt+Del> 3 seconds then <Ctrl+Uparrow> (or <Ctrl+Downarrow>
  Nothing Happens

My conclusion:
A) Manual (2011-06) is faulty, under Heading "Inserting rows and columns" hint that you have to press <Alt+Insert> or <Alt+Del> for 3 seconds is missing

B) Help is faulty:, "3 seconds in Insert mode" is not easy to understand (or IMHO wrong), should be "After 3 seconds insert mode becomes active" or similar, same for Delete mode

C) Help concerning steps 8,10 imprecise

D) Manual incomplete, instructions 'C' missing

E) Help imprecise concerning step 12

F) Manual incomplete, instructions 'E' missing

G) Help and Manual incomplete concerning step 14, 16, 18, 20, 22 (what content will remain?), 24 (what content will remain?)

@Allan Jacobs:
Can you reproduce my results? I believe you are victim of missing "3 seconds hint"?
If you find out that additional to the Help and Documentation issues a real UI problem (as you expected in your original report) does exist, please submit a new report for that.
Please file Bug reports with status UNCONFIRMED if your are not absolutely sure that you contributed all required background information, that the problem will be reproducible with information you can provide or that your enhancement request will be accepted! Thank you!

@David:
Can you please proceed Help / Manual issues?

@Christoph:
Should we not have something in the status line or anything else showing the new mode after 3 seconds?
Comment 2 Rainer Bielefeld Retired 2011-10-03 00:06:39 UTC
Created attachment 51890 [details]
Sample Document, see Comment 1
Comment 3 Christoph 2011-10-03 11:45:54 UTC
(In reply to comment #1)
> My conclusion:
> A) Manual (2011-06) is faulty, under Heading "Inserting rows and columns" hint
> that you have to press <Alt+Insert> or <Alt+Del> for 3 seconds is missing
> 
> B) Help is faulty:, "3 seconds in Insert mode" is not easy to understand (or
> IMHO wrong), should be "After 3 seconds insert mode becomes active" or similar, same for Delete mode

Concerning A,B: Maybe this is a misunderstanding (maybe on my side). After pressing <Alt+Insert>/<Alt+Delete>, the insert/delete mode becomes active for a duration of 3 seconds. If the user presses a (e.g.) cursor key within the three seconds, then insert/delete/merge/whatever is executed. If the user does not press a (e.g.) cursor key during the three seconds, then Writer goes back to the normal cursor navigation mode. That works as expected.

But, yes, some merging/deleting does not work as expected.

> @Christoph:
> Should we not have something in the status line or anything else showing the
> new mode after 3 seconds?

If there is a mode change, then yes, it should be shown. Something like "Table insert mode: Use <Cursor> to insert rows/columns, use <Ctrl>+<Arrow> to insert cells, press ESC to abort." But David knows better the terminology and the key markups.
Comment 4 Allan Jacobs 2011-10-03 18:12:08 UTC
This may well be an operating system specific bug.  I'm running Ubuntu 11.10.  About LibreOffice: LibreOffice 3.4.3  OOO340m1 (Build:302).
Comment 5 Rainer Bielefeld Retired 2011-10-03 22:31:01 UTC
@Christoph
Thank you for your explications, it's exactly as you say, it's not necessary to pres <Alt+Insert> for a while, but this "mode" ends approximately 3 seconds of keys released.

@David:
Please ignore my comments concerning A, B

@Allan:
Yes, that also might be. But I got this "press 3 seconds trip" because I was rather sure that I was able to reproduce your problem during my first tests. But may be It took some moments because after <Alt+Insert> I read what to do as next step, and that took 3,1s? I will do some further tests, but may be you are right that the problem is OS dependent. I will submit a new report for your old problem.
Comment 6 Björn Michaelsen 2011-12-23 13:23:35 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 7 Rainer Bielefeld Retired 2012-05-06 01:59:00 UTC
@Allan Jacobs 
do you still see a problem?
Comment 8 Paul Weiss 2013-01-13 18:50:25 UTC
Local help for 3.6.4.3 on Windows 7 (Text Documents->Tables in Text Documents->Adding or Deleting a Row or Column to a Table Using the Keyboard) still does not mention the 3-second timeframe. Wiki help is the same.
Comment 9 sophie 2013-09-15 10:00:10 UTC
Assigned to me - Sophie
Comment 10 Regina Henschel 2015-10-29 16:28:30 UTC
@Sophie: This bug has been untouched for two years. Are you indeed working on it? Otherwise please clear the "Assigned to" field.
Comment 11 sophie 2015-10-30 10:11:34 UTC
cleared assignee - Sophie
Comment 12 QA Administrators 2016-11-08 11:55:11 UTC Comment hidden (obsolete)
Comment 13 Thomas Lendo 2018-10-14 05:54:04 UTC
WONTFIX as this feature was removed from LibreOffice with Bug 116452 - Remove "3 seconds to add/delete col/row" functions.