Bug 41493 - Compare document with Encryption Password Protection fails silently
Summary: Compare document with Encryption Password Protection fails silently
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
: 80994 112374 (view as bug list)
Depends on:
Blocks: Password-Protected Document-Comparison
  Show dependency treegraph
Reported: 2011-10-05 13:28 UTC by Jean-Baptiste Faure
Modified: 2023-07-07 11:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:

test kit (26.03 KB, application/zip)
2012-04-06 01:54 UTC, Rainer Bielefeld Retired

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2011-10-05 13:28:11 UTC
Problem description: If you compare a text document with another which is password protected, you are asked for the password but the comparison does not occur

Steps to reproduce:
1. open an existing text document, eg a.odt
2. make some minor change and save this document as a new file with password, eg. a_mod.odt
3. close a_mod.odt and open a.odt
4. menu Edit > Compare document
5. choose a_mod.odt
6. LibreOffice ask for the password. Type in the password.

Current behavior: nothing happens

Expected behavior: "Accept or Reject Changes" is shown with the minor change done at step 2.

Remark: at this moment if you try to open a_mod.odt it opens in read-only mode, which proves that the file is already opened even it is not visible.
Comment 1 Jean-Baptiste Faure 2011-10-05 13:31:49 UTC
Confirmed under MS-Windows-XP and Linux Ubuntu 10.04 x86_64.

Side note: Bug report assistant: nice job :-)

Best regards. JBF
Comment 2 William Gathoye 2011-12-28 14:00:40 UTC Comment hidden (obsolete)
Comment 3 William Gathoye 2011-12-28 14:06:31 UTC Comment hidden (obsolete)
Comment 4 William Gathoye 2011-12-28 14:10:18 UTC Comment hidden (obsolete)
Comment 5 Rainer Bielefeld Retired 2012-04-06 01:53:40 UTC
I tried with Encryption password and 3.4.1RC1 (WIN7 64bit)  and got reporter's result, same with [Reproducible] with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-]", LibO Master 3.6, OOo 3.3, so this is inherited from OOo


@Jean-Baptiste Faure:
Do you agree with my results?
Comment 6 Rainer Bielefeld Retired 2012-04-06 01:54:33 UTC
Created attachment 59579 [details]
test kit

Do your own tests, password is "1"
Comment 7 Jean-Baptiste Faure 2012-04-08 00:58:54 UTC
(In reply to comment #5)
> [...]
> @Jean-Baptiste Faure:
> Do you agree with my results?

Yes, I agree. I asked on FR discuss ML for tests on legacy version of OOo and I got the confirmation that the bug is already there.

That said there is an obvious workaround:  before comparing the files, save a copy without password of the second file.

Best regards. JBF
Comment 8 ign_christian 2014-07-07 08:40:08 UTC
*** Bug 80994 has been marked as a duplicate of this bug. ***
Comment 9 QA Administrators 2015-07-18 17:43:58 UTC Comment hidden (obsolete)
Comment 10 Anton 2015-07-19 07:23:25 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2016-09-20 10:18:06 UTC Comment hidden (obsolete)
Comment 12 Anton 2016-09-20 13:49:42 UTC
ok, this is getting irritating because there is no progress after 5 YEARS at all. 

bugs does not disappear by itself and there is no point asking (even using automated bots) to retest if you done nothing.

This is the last year when I'm testing it. 

Gentoo Linux (current)
Current behavior (not changed): nothing happens
Comment 13 Timur 2017-09-13 17:01:48 UTC
*** Bug 112374 has been marked as a duplicate of this bug. ***
Comment 14 QA Administrators 2018-09-14 02:46:32 UTC Comment hidden (obsolete)
Comment 15 Timur 2018-09-14 08:33:13 UTC Comment hidden (obsolete)
Comment 16 Dave Lovelace 2018-09-15 02:33:05 UTC
I'm not downloading the latest rev, but this now works in the version I am running:
Version: (x64)
Build ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU threads: 2; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: group

There is still plenty of weirdness in trying to compare files, some of it quite irritating, but this problem (asks for password, uses it to open file, then does nothing) seems to have been fixed.  My heartfelt thanks to whoever made it work.

-- Dave
Comment 17 Timur 2019-01-10 10:15:11 UTC Comment hidden (obsolete)
Comment 18 Denis Sousa 2020-01-21 18:48:52 UTC Comment hidden (spam)
Comment 19 QA Administrators 2022-01-21 03:37:40 UTC Comment hidden (obsolete)
Comment 20 Jean-Baptiste Faure 2022-01-21 10:45:47 UTC
Nothing changed in Version: / LibreOffice Community
Build ID: de15e8d4f2f2e5d10cb5d9203e51f3a28347db8d
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Calc: threaded

Best regards. JBF
Comment 21 Dave Lovelace 2022-01-21 22:19:08 UTC
I guess I have to wonder what was going on when I commented quite a while back (2018-09-15 02:33:05 UTC, #16).  At any rate, the bug is still there now.  It MIGHT be relevant that these files are using "track changes", I suppose.

I also have to say about the same as Anton (# 12).  I've reported or gotten added to the tracking of several bugs.  YEARS go by, and they aren't fixed or (apparently) even worked on.  Yet every year I'm asked to go through the hassle of installing the latest version (losing history (that must be in the Windows registry) in the process).  The bug is always still there.  Several of these (this one for example) are quite serious, in terms of my ability to use LibreOffice for things I'm working on.  It's quite a pain.

Regarding comment # 7:  Yes, it's an obvious workaround.  It's also a security problem, defeating the whole purpose of encrypting documents.  If the comparisons worked a LOT better, I would do it anyway.  But as it is, if I'm going to do this, I save them in another format which can be compared by a simple diff.

Anyway: bug is still there as of now, in:
Version: (x64) / LibreOffice Community
Build ID: e1f30c802c3269a1d052614453f260e49458c82c
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 22 Stéphane Guillou (stragu) 2023-07-07 11:38:16 UTC
*** Bug 156187 has been marked as a duplicate of this bug. ***