Bug Hunting Session
Bug 41547 - WRITER: Turkish characters exported as blanks
Summary: WRITER: Turkish characters exported as blanks
Status: RESOLVED DUPLICATE of bug 66108
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-07 01:17 UTC by Emir Sarı (away)
Modified: 2013-06-24 17:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
pdf file (1.61 KB, application/pdf)
2011-10-13 09:10 UTC, Emir Sarı (away)
Details
odt file (9.44 KB, application/vnd.oasis.opendocument.text)
2011-10-13 09:11 UTC, Emir Sarı (away)
Details
pdf with correct rendering (13.31 KB, application/pdf)
2011-10-13 09:12 UTC, Emir Sarı (away)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı (away) 2011-10-07 01:17:55 UTC
Hello,

Whenever I write a document in Turkish on Writer and select 'PDF Export', the Turkish characters (ğ, ı, ş, ç) are not visible on the PDF. No problems with Windows or Linux versions. Really annoying bug.
Comment 1 Rainer Bielefeld Retired 2011-10-07 02:23:59 UTC
As reported not reproducible with "LibreOffice 3.4.3  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" and a text document containing text from report copy/pasted to LibO document.

@emir_sari@msn.com
Please 
- attach 
  -- a sample.odt document with a short text line in a common font
  -- a result.pdf document
- screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- contribute information concerning
  -- Really no problem with CALC, DRAW, IMPRESS?
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  -- also a Problem with older LibO Versions?
  -- everything else crossing your mind
Comment 2 Emir Sarı (away) 2011-10-13 09:10:17 UTC
Created attachment 52301 [details]
pdf file
Comment 3 Emir Sarı (away) 2011-10-13 09:11:06 UTC
Created attachment 52302 [details]
odt file
Comment 4 Emir Sarı (away) 2011-10-13 09:12:18 UTC
Created attachment 52304 [details]
pdf with correct rendering
Comment 5 Emir Sarı (away) 2011-10-13 09:14:37 UTC
Hello,

Sorry, I added the files.

By the way, I realized that this error does occur with Helvetica font. Other sans-serif fonts like Arial does not have any problem. Or Georgia. I added another .pdf file with correct rendering.
Comment 6 Rainer Bielefeld Retired 2011-10-13 09:53:43 UTC
Because it's a Mac bug I can't really reproduce, but
- Simply exporting from reporter's sample without Helvitica on my PC shows 
  several problems, letters from report are shown crippled and / or not italic
- switching font to Arial indeed solves the problem. 


@reporter:
Still waiting for info:
  -- Really no problem with CALC, DRAW, IMPRESS?
  -- also a Problem with older LibO Versions?

It seems I can't see a problem with "ç" in your "sample.pdf"

Can you please check whether Helvetica supports that characters? 
How does a print look?
How does a Postscript printout look?
How did you create your sample2.pdf "pdf with correct rendering"?
Comment 7 Emir Sarı (away) 2011-10-13 10:29:09 UTC
The problem persists with Calc, Impress and Draw. 

Yes, the problem used to exist within the older versions of Libre, at least two 3.4.x releases. 

Helvetica supports those characters, since I use them frequently with my native Mac OS X PDF exports and in other places throughout the system. 

I created the correct rendering by changing the font to "Georgia" and exporting the file as PDF. 

Sorry, but I do not have a printer, so I won't be able to reproduce the print. But I think it will look fine - I guess.
Comment 8 Rainer Bielefeld Retired 2011-10-13 23:02:44 UTC
@Sophie, Thorsten
Any idea how we can proceed this one?
Comment 9 Björn Michaelsen 2011-12-23 12:41:01 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 10 ZJL 2012-02-02 12:53:16 UTC
I had a similar problem with math symbol characters not being visible in exported PDFs; selecting 'Embed standard fonts' in the PDF export options dialog ('General' tab) solved the problem.

John
(LibreOffice 3.4.5 Writer / OS X 10.6)
Comment 11 Emir Sarı (away) 2012-02-15 04:45:15 UTC
Issue persists on 3.5.0.
Comment 12 Emir Sarı (away) 2013-06-24 07:18:54 UTC
I cannot test this bug further because of Bug 66108.
Comment 13 Khaled Hosny 2013-06-24 17:36:45 UTC

*** This bug has been marked as a duplicate of bug 66108 ***