Bug 41640 - Clipboard pasted after press Enter in cell comment
Summary: Clipboard pasted after press Enter in cell comment
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 56448 69408 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-10 00:19 UTC by Adam Groszer
Modified: 2015-10-19 06:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Groszer 2011-10-10 00:19:33 UTC
To repro:
Copy something to the clipboard. (e.g. some cells from the same sheet)
Select a cell.
Right click, Insert Comment.
Type some text, <enter> (as of you'd start a new line).
The previously copied cells are pasted to the selected cell, comment disappears and is lost.

---------------
Linux adiubuntu 2.6.35-27-generic #48-Ubuntu SMP Tue Feb 22 20:25:46 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

LibreOffice 3.3.4 
OOO330m19 (Build:401)
tag libreoffice-3.3.3.1, Ubuntu package 1:3.3.4-0ubuntu1
Comment 1 Johnny_M 2011-10-29 10:39:54 UTC
Same on LibreOffice 3.4.3 (release) with Win XP SP3 (32 bit).
Comment 2 Björn Michaelsen 2011-12-23 12:38:00 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Florian Reisinger 2012-08-14 13:59:34 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:00:45 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:05:28 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:07:29 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Adam Groszer 2012-08-14 14:08:06 UTC
khmm "no answer"...

still fails with 
LibreOffice 3.5.4.2 
Build ID: 350m1(Build:2)
Comment 8 Florian Reisinger 2012-08-14 14:11:48 UTC
Thanks for your quick reply and status changed to NEW. 

PS: Sorry for the comment spamming
Comment 9 retired 2014-02-12 10:25:01 UTC
And the usual: still valid? how about 4.2.0.4?
Comment 10 Adam Groszer 2014-02-12 16:47:55 UTC
I'm just at 4.0.2.2 because ubuntu 13.04 has that
but still fails
Comment 11 ign_christian 2014-07-12 10:24:06 UTC
Still reproduced in LO 4.2.5.2 - Ubuntu 12.04 x86

Platform All per comment 1
Comment 12 ign_christian 2014-07-12 10:39:33 UTC
*** Bug 56448 has been marked as a duplicate of this bug. ***
Comment 13 ign_christian 2014-07-12 10:44:18 UTC
Also reproduced in LO 3.3.0.4, but not happen in AOO 3.4.1 and 4.1.0
Comment 14 Winfried Donkers (retired) 2014-07-14 13:33:37 UTC
*** Bug 69408 has been marked as a duplicate of this bug. ***
Comment 15 Winfried Donkers (retired) 2014-09-11 06:57:44 UTC
Still present in 4.4.0.0alpha0+ (Linux) and 4.2.6 (Windows).
The way to reproduce is properly described in desription of this bug report.
Comment 16 Winfried Donkers (retired) 2014-09-11 07:14:41 UTC
Further to the steps to reproduce in description of this bug:
-the clipboard must contain a cell or a range of cells, with text in the clipboard, the problem does not occur
-the problem occurs regardless of the contents of the clipboard have been pasted or not.
-the problem occurs only once, i.e. if you reproduce the problem and insert 'another' comment, it works as expected.
-if the text entry in the comment is finished and <Enter> is not used, it works as expected. However inserting a next comment and pressing <Enter> makes the problem occur.
-when the problem occurs, the cursor is still in some sort of comment mode, i.e. when selecting a cell, the cursor looks like a + and the cell is not selected. Only when selecting a second time, the cell is selected.

So:
-the clipboard must contain (range of ) cell(s)
-using <Enter> to finish comment creation triggers a paste action in the cell (and discards the comment creation, but does not fully restore the mouse-mode), but only once, unless the clipboard content changes.
Comment 17 Winfried Donkers (retired) 2014-09-11 14:36:56 UTC
@Markus: Does this ring a bell with you? If it does and don't have time, could you give me a hint of where to look in the code?

It is not a MAB, but at least it is a very annoying bug.
Comment 18 QA Administrators 2015-10-14 19:56:49 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.1 or preferably 5.0.2.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-10-14
Comment 19 Winfried Donkers (retired) 2015-10-19 06:03:28 UTC
(In reply to QA Administrators from comment #18)
Can no longer reproduce with version 4.4.5.2 (Windows 7), nor on master (5.1.0.0.alpha1+,openSUSE13.1).
Taking the liberty to close this bug report.