Bug Hunting Session
Bug 41657 - EDITING: Inserting Powerpoint file CRASHES every time
Summary: EDITING: Inserting Powerpoint file CRASHES every time
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-10 09:54 UTC by Vossman
Modified: 2013-11-15 15:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
presentation test file, insert into this (11.45 KB, application/vnd.oasis.opendocument.presentation)
2011-10-10 09:58 UTC, Vossman
Details
powerpoint file to insert into presentation file (70.50 KB, application/vnd.ms-powerpoint)
2011-10-10 09:59 UTC, Vossman
Details
LO 3.5.0b1 MacOSX crash log (63.38 KB, text/plain)
2011-12-20 07:53 UTC, Vossman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vossman 2011-10-10 09:54:18 UTC
Steps to reproduce:

1. Open libreOffice Impress file
2. Insert->File...
3. Select Powerpoint file
4. Crash

Have not tested on other systems.
Comment 1 Vossman 2011-10-10 09:58:42 UTC
Created attachment 52187 [details]
presentation test file, insert into this
Comment 2 Vossman 2011-10-10 09:59:14 UTC
Created attachment 52188 [details]
powerpoint file to insert into presentation file
Comment 3 Rainer Bielefeld Retired 2011-10-12 00:11:12 UTC
[Reproducible] with "LibreOffice 3.4.3  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]".

Works fine with DRAW and OOo 3.1.1 Impress

Still a problem with Master.

It's annoying, but there is a simple workaround: open .ppt and copy sheets you need by drag and drop from slices pane. So I do not see this one as a "Most annoying 3.4" one

@Thorsten:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 4 Thorsten Behrens (CIB) 2011-12-20 07:12:22 UTC
Don't see that with 3.5.0 beta1 anymore, neither windows nor linux.
Comment 5 Vossman 2011-12-20 07:21:10 UTC
Still crashes for me with 3.5.0beta1 on Mac OS X, can someone else confirm.
Comment 6 Vossman 2011-12-20 07:53:26 UTC
Created attachment 54599 [details]
LO 3.5.0b1 MacOSX crash log
Comment 7 Rainer Bielefeld Retired 2011-12-20 08:22:29 UTC
Still CRASHes  with "LibreOffice 3.4.5 RC1  - WIN7 Home Premium (64bit) German UI [Build ID: OOO340m1 (Build:501)]"

but no longer a problem with 
Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta1 - WIN7 Home Premium (64bit) German UI [Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4] Windows_Release_Configuration  11-Dec-2011 06:51" 

May be Vossman's remaining crash has different roots?
Comment 8 Thorsten Behrens (CIB) 2012-01-10 03:32:55 UTC
Fixed for master and -3-5
Comment 9 Vossman 2012-01-12 07:50:01 UTC
Works for me in 3.5.0beta3, thanks for working on it.