Bug 41693 - pptx import issues: table formatting and transparent graphic overlay
Summary: pptx import issues: table formatting and transparent graphic overlay
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-11 11:08 UTC by mathog
Modified: 2013-11-24 22:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Original file, looks OK in PowerPoint 2003 and up. (331.82 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2011-10-11 11:08 UTC, mathog
Details
Page 1, as seen in Powerpoint (21.49 KB, image/png)
2011-10-11 11:08 UTC, mathog
Details
Page 1, as mangled by Impress (28.65 KB, image/png)
2011-10-11 11:09 UTC, mathog
Details
Page 2, as seen in Powerpoint, note the blue highlight region (124.28 KB, image/png)
2011-10-11 11:09 UTC, mathog
Details
Page 2 as mangled by Impress, note the scale change for blue regions (139.65 KB, image/png)
2011-10-11 11:10 UTC, mathog
Details
extended metafile of page 2 (977.79 KB, image/x-emf)
2011-10-11 12:27 UTC, mathog
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mathog 2011-10-11 11:08:08 UTC
Created attachment 52229 [details]
Original file, looks OK in PowerPoint 2003 and up.

Two pretty horrible import issues discovered in one document.  The original transparency.pptx has two slides with page setup to A4 landscape.

1.  Page 1, text does not scale properly.  Dividing lines absent.  This was I believe originally a formatted table.

2.  Page 2, the blue transparency regions used in the original to highlight sections of text are not scaled to match the rest of the page.
Comment 1 mathog 2011-10-11 11:08:59 UTC
Created attachment 52230 [details]
Page 1, as seen in Powerpoint
Comment 2 mathog 2011-10-11 11:09:28 UTC
Created attachment 52231 [details]
Page 1, as mangled by Impress
Comment 3 mathog 2011-10-11 11:09:59 UTC
Created attachment 52232 [details]
Page 2, as seen in Powerpoint, note the blue highlight region
Comment 4 mathog 2011-10-11 11:10:40 UTC
Created attachment 52233 [details]
Page 2 as mangled by Impress, note the scale change for blue regions
Comment 5 mathog 2011-10-11 11:55:43 UTC
For whatever its worth, the first page can be exported to .wmf or .emf and then read in successfully by Impress, Powerpoint, and Scribus.  However, while the second page can be exported to .wmf or .emf, nothing seems to be able to read it back in again properly, including powerpoint.  In the original the blue object is some sort of path, because right click has "edit points" on the menu.  However, after reading it back into powerpoint with Insert -> picture -> from file, then ungroup, the path edit option isn't present.  When the page2.wmf is read into impress the same way, the underlying text image is all that is visible, and ungroup is greyed out.  Powerpoint 2003 (with Office 2007 filters) can export to its own html format, and read the presentation back in, maintaining everything, but Impress has not been able to open/import this html.
Comment 6 mathog 2011-10-11 12:27:18 UTC
Created attachment 52235 [details]
extended metafile of page 2

When slide2.emf is placed in an Impress slide with insert -> picture -> from file all that is visible is the text.  Right click on it and select break.  It falls apart into objects.  However, there is no object corresponding to the blue overlay.  The same thing happens for the .wmf form.  The object must be there since something (although not the right thing, points are not selectable) shows up when the same process is carried out in Powerpoint.
Comment 7 mathog 2011-10-12 09:40:52 UTC
Further experimentation.  

Select the blue "highlighter" region in page 2 in Powerpoint
Copy
In an open Impress presentation, paste.

A rectangle of the appropriate size appears.  However, it is empty.  Click on it and the "picture" toolbar appears.  "Edit points" does nothing.

Select the same region in Powerpoint and draw->edit points brings up the control points.  

In PowerPoint modify the region to set transparency to zero.  
Repeat select/copy/paste into Impress.  

This time the region is visible.  Any nonzero transparency value in "format autoshape" in PowerPoint causes the imported object to be invisible, transparency must be exactly zero.  However, even with transparency set to zero, it is still a picture, not a polygon.  Neither "convert to polygon" nor "convert to curve" does anything (near as I can tell).

I had no difficulty creating a filled polygon object of the same color and with the original transparency as in the PowerPoint document, but it had to be done manually, using entirely Impress tools from the get go.  

So, in summary, it appears that importation of a polygon object from Powerpoint
to Impress is broken.  If the object isn't transparent then it shows up as a picture with the polygon region visible, if the object is transparent it shows up as an empty picture.  In no case is it correctly translated to a (filled) LibreOffice polygon object.

The polygonal nature of the object is present in the cut/paste object.  This can be demonstrated by pasting instead into Inkscape 0.48.  After doing so the control points can be edited.  Unfortunately in that case the transparency information is lost, no matter what it was originally, it ends up at 0 transparency in the new inkscape object.  However, it can be set back to a nonzero transparency value manually later.
Comment 8 mathog 2011-10-12 09:58:44 UTC
Stranger and stranger.  

In Powerpoint:
Create an identical shape using the drawing tools, a couple of overlapping rectangles with no edge line.  
Select all.
Cut
Paste special (PNG).  
Copy

In Impress
Paste
right click
convert -> polygon
The conversion settings dialog appears, let it run.
right click
break
The desired polygon object is present, along with some white polygons.

So....

When the original object is imported it is a "picture", but it is not one that
"convert -> polygon" will operate on.  There is no error message, no settings dialog, it just fails (or does something else) silently.
Comment 9 Björn Michaelsen 2011-12-23 12:39:19 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 10 mathog 2012-01-11 14:25:21 UTC
Checked this bug on 3.5.0beta2.

The problems with the first page are as described above.  The PNG that describes the image in LO 3.4.0 would be the same for 3.5.0b2.

The problems with the second page seem to be resolved in 3.5.0b2 - the blue area appears in Impress as it did in Powerpoint.
Comment 11 sasha.libreoffice 2012-03-29 05:21:21 UTC
I have created separate bugreport about this problem:
Bug 48047 - Impress FILEOPEN: pptx with table, formatting of table is lost
Comment 12 Florian Reisinger 2012-08-14 13:59:49 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 13 Florian Reisinger 2012-08-14 14:00:58 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 14 Florian Reisinger 2012-08-14 14:05:42 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 15 Florian Reisinger 2012-08-14 14:07:43 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 16 sasha.libreoffice 2012-08-15 08:22:44 UTC
in 3.6.0rc on Fedora 64 bit problem still exist
Comment 17 Florian Reisinger 2013-04-21 06:30:24 UTC
999,9% works here with Version: 4.1.0.0.alpha0+
Build ID: 61d1f8f237bb45901de9c8016ea48fab1c3570d @ Win 7 x64

Blue region + table formatting. The remaining problem is, that the table seems to large, although it fits in PowerPoint...

This bugs should be closed as the bug is working. Feel free to open a new bug for the table issue....