Bug Hunting Session
Bug 41746 - Null cell value causes calculation error.
Summary: Null cell value causes calculation error.
Status: RESOLVED DUPLICATE of bug 37860
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-13 07:24 UTC by Eugene Bodrero
Modified: 2011-10-15 02:46 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Bodrero 2011-10-13 07:24:27 UTC
A conditional statement such as 
  C7:  if ((c8-c7)<=0,"",(C8-C7)*24) 
will leave a null in the cell if the condition is true.

If a later cell adds this null cell, the calculation is invalid.
  C10:  =C7+C9  =>> Results ins #Value!

This operation has been allowed in all previous releases.

A work around is to use 
  C7:  if ((c8-c7)<=0,"0",(C8-C7)*24) 
but this clutters what would otherwise be a clean spreadsheet.
Comment 1 Markus Mohrhard 2011-10-15 02:39:32 UTC
I think this is part of our work to be more Excel compatible. "" is not a value but a string while "0" can be converted to 0. For example " 0" can't be converted too.

You have either the posibility to use 0 or "0".
Comment 2 vitriol 2011-10-15 02:46:49 UTC

*** This bug has been marked as a duplicate of bug 37860 ***