Bug Hunting Session
Bug 41887 - MinGW does not show included SVG images
Summary: MinGW does not show included SVG images
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Jan Holesovsky
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mabMinGW
  Show dependency treegraph
 
Reported: 2011-10-17 07:23 UTC by Pedro
Modified: 2014-06-17 04:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Simple Writer file with included SVG image (60.51 KB, application/vnd.oasis.opendocument.text)
2011-10-17 07:23 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2011-10-17 07:23:42 UTC
Created attachment 52424 [details]
Simple Writer file with included SVG image

A document with an included SVG image showed up correctly on Master compiled MSVC (from 2011-09-12) but nothing is displayed on the MinGW build
Comment 1 Rainer Bielefeld Retired 2011-11-27 22:16:28 UTC
[Reproducible] with parallel installation of MinGW Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI (Build ID:fba911f-2fcbe65-8b4f344-3bd0388) (daily/Win-x86@7-MinGW/master/2011-11-25_08.14.45)"

No problem with with Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [(Build ID:  4f11d0a-adcf6d5-c4bb9bd)]" Windows_2008R8 - 111118) 

No problem with "LibreOffice 3.4.4  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:402)]", so regression!

After having saved the document from MinGW build LibO 3.4.4 is unable to show the included SVG, but MSVC Master will show the svg in the new document.

@Jan:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 2 Michael Meeks 2012-05-29 02:14:46 UTC
Removing regression; MINGW is effectively a new platform, with plenty of issues - we should certainly track these together - but if this has never worked under mingw - it's prolly better not to clutter the regression query with them :-)
Comment 3 Jan Holesovsky 2014-06-17 04:26:54 UTC
The MinGW port is not maintained any more.