Download it now!
Bug 41888 - [FORMATTING] Shapes move on opening file
Summary: [FORMATTING] Shapes move on opening file
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other Linux (All)
: high critical
Assignee: Radek Doulik
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-10-17 07:47 UTC by Cor Nouws
Modified: 2011-12-01 09:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
presentation with shapes (383.99 KB, application/vnd.oasis.opendocument.presentation)
2011-10-17 07:48 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2011-10-17 07:47:18 UTC
I'll attach a presentation with two slides

On the first one, some shapes on top of a picture

On the second one, a picture with how it looks like when open in 3.4.3 and when opened in build from master

(I opened in Build ID: 4456143-f6a1fc5-e1a2fb3 )

When I place the shapes correct in the masterbuild, they still are in the correct position when I open in 3.4.3.
So the problem is on opening in Master.

Seen the same problem in more presentations (e.g. the one from Petr on releasing).
Comment 1 Cor Nouws 2011-10-17 07:48:44 UTC
Created attachment 52427 [details]
presentation with shapes
Comment 2 Petr Mladek 2011-10-25 10:42:32 UTC
I see it with a recent master build as well.

Radek, I think that it is your area. It looks like a shapes import/export incompatibility between 3.4 and master. Could you please have a look at it?
Comment 3 Petr Mladek 2011-10-26 01:17:18 UTC
I guess that it is related to the bug 42227.
Comment 4 Roman Eisele 2011-12-01 08:36:39 UTC
NOT (or: no longer) reproducible with
LibO-dev 3.5.0 
Build ID: 549f928-b211287-090bcba-45cf606
built 2011-12-01
no langkit installed (default UI language)
running on MacOS X 10.6.8 German.

For me, opening the sample document with the newest Master build gives the same (or almost the same) result as opening it with LibreOffice 3.4.4.

@Cor Nouws:
Could you please try this again with the newest master build?
Has the bug been fixed in between (would be great!) or am I missing something?
Comment 5 Cor Nouws 2011-12-01 09:33:48 UTC
(In reply to comment #4)
> @Cor Nouws:
> Could you please try this again with the newest master build?
> Has the bug been fixed in between (would be great!) or am I missing something?

Hi,

Obviously was the same bug as 42227.
Runs all fine now in my build from yesterday > fixed.

thanks!
Comment 6 Cor Nouws 2011-12-01 09:34:15 UTC
& close