Download it now!
Bug 41990 - Character layout does not clear all old pixels between justifying and redrawing
Summary: Character layout does not clear all old pixels between justifying and redrawing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 56932
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-19 02:24 UTC by Hamilton Turner
Modified: 2014-12-17 14:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
3 screen captures of the problem occurring in different locations. (49.54 KB, application/zip)
2011-10-19 02:24 UTC, Hamilton Turner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hamilton Turner 2011-10-19 02:24:08 UTC
Created attachment 52518 [details]
3 screen captures of the problem occurring in different locations.

(To start, I don't know if this is the right area to submit this bug - I read the list and picked as best as I could. Sorry, new to the LO project)

It appears that in my version (3.4.3 OOO340m1 (Build:302) ) my characters are frequently overlapping. As I type a line the characters on that line frequently (once every 10-15 lines) become muddled together. It seems to have something to do with the spacing between characters and words changing - the "old" character positions don't get cleared before the new characters are drawn. If I switch application focus out of LO and then back, the problem is gone and all characters are clean. If I scroll up and down, leaving the muddled bit visible in the document, then there is no effect. If I scroll the document beyond the muddled characters and then return to where I started, then all characters are clean. If I select the muddled characters there is no effect. 

Some pictures showing this are attached.
Comment 1 Ben Laenen 2011-11-06 11:21:27 UTC
Moving to product LibreOffice since this isn't about the DejaVu fonts.
Comment 2 Emir Sarı 2014-07-24 23:04:51 UTC
Mr. Hamilton, 

Can you still reproduce the issue with the latest version of LibreOffice?

Thanks,
Comment 3 Hamilton Turner 2014-08-03 02:58:57 UTC
Cannot replicate, please close