Bug 42070 - RTL support in broken in presenter Console extension
Summary: RTL support in broken in presenter Console extension
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:4.0.0
Keywords:
Depends on:
Blocks: rtl-meta 57422
  Show dependency treegraph
 
Reported: 2011-10-20 11:22 UTC by Lior Kaplan
Modified: 2012-11-26 01:09 UTC (History)
4 users (show)

See Also:


Attachments
screen shot of the console presenter extension in Hebrew (71.39 KB, image/png)
2011-10-20 11:22 UTC, Lior Kaplan
Details
presentor console on RTL UI (3.5.0 beta1) (104.83 KB, image/png)
2011-12-17 15:10 UTC, Lior Kaplan
Details
patch for fixing presnter console standrad layout mode (3.63 KB, text/plain)
2012-11-11 07:40 UTC, abdulmajeed
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lior Kaplan 2011-10-20 11:22:59 UTC
Created attachment 52604 [details]
screen shot of the console presenter extension in Hebrew

Hi,

I'm reporting a problem on behalf of a user.

While viewing a presentation in impress, with the console presenter extension under the UI in Hebrew, the translation to Hebrew appear backwards ("abc" appears as "cba"). This affects all the text in the extension, including the titles about the presenter windows, the buttons (prev, next etc...).

I checked the stings in Pootle, and they look OK and in the right direction.

Attached is a screen shot, and a link to the translation in Poole of the string above the presenter big screen (in English the text is "Current Slide (%CURRENT_SLIDE_NUMBER% of %SLIDE_COUNT%)").

https://translations.documentfoundation.org/he/libo34x_ui/translate.html?unit=5469640
https://translations.documentfoundation.org/he/libo34x_ui/translate.html?search=%D7%94%D7%A9%D7%A7%D7%A3+%D7%94%D7%A0%D7%95%D7%9B%D7%97%D7%99&sfields=source&sfields=target

(First link is the direct one, the second is though the search option).
Comment 1 Lior Kaplan 2011-12-17 15:10:14 UTC
Created attachment 54530 [details]
presentor console on RTL UI (3.5.0 beta1)
Comment 2 Lior Kaplan 2011-12-17 15:10:53 UTC
Reproducable also in 3.5.0 Beta1. I also notice a more severe behavior - the buttons order isn't reversed on display, but is reversed for clicking. 

So although the prev/next buttons are on the left side of the control bar, you should click on the right side of the bar to use these functionalities. Notice the position of the mouse cursor on the 2nd screetshot (on the exchange button), and which button is highlighted (the "next" arrow).
Comment 3 Michael Meeks 2011-12-20 09:42:50 UTC
Taking the bug; there is no RTL support in the presenter view (it turns out), although thankfully we have some a11y support. The underlying canvas has no mirroring support either, so - quite some fun there ...
Comment 4 Michael Meeks 2012-01-24 07:54:31 UTC
I handed my proto-patch over to Thorsten here :-)
Comment 5 abdulmajeed 2012-11-11 07:40:26 UTC
Created attachment 69891 [details]
patch for fixing presnter console standrad layout mode

This is part of the problem has been fixed 
hope to solve the rest.




We still have problem with the toolbar and the buttons  because vcl library  mirror the UI by default and we are trying to disable mirroring for presnter console. 



thanks.
Comment 6 abdulmajeed 2012-11-11 07:42:39 UTC
patch link on gerrit
https://gerrit.libreoffice.org/#/c/1028/
Comment 7 Not Assigned 2012-11-20 19:32:04 UTC
Faisal M. Al-Otaibi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e5c11c664f67ff9fd1120905b09a32bea3b2f6c

fdo#42070-Fix RTL support in presenter console



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Lior Kaplan 2012-11-22 16:53:51 UTC
Support is now available thanks the fix by Faisal. For completion of support use follow up bug 57422.
Comment 10 Lior Kaplan 2012-11-26 01:09:44 UTC
Verified on a private build (Debian 64bit).