Bug Hunting Session
Bug 42109 - FILEOPEN: RTF import don't understand some field names
Summary: FILEOPEN: RTF import don't understand some field names
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium major
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-22 04:07 UTC by Jean-Baptiste Faure
Modified: 2012-03-19 14:26 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
RTF document that is not correctly imported by LibO 3.4.3 (88.10 KB, application/rtf)
2011-10-22 04:07 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2011-10-22 04:07:24 UTC
Created attachment 52627 [details]
RTF document that is not correctly imported by LibO 3.4.3

Open the attached bugdoc. Several keywords are not interpreted by RTF import filter: MERGEFIELD, MERGEFORMAT and left as is.
This file opens correctly in OOo 3.2.1 and LibO 3.3.x but not in LibO 3.4.3 and in the master.

The attached file is a template used in French governemental administration. RTF format has been chosen because it is agnostic (in fact: understood as agnostic) about used office software. So this kind of defect blocks the migration of many users in the French adminitration from OOo 3.x and LibO 3.3 to LibO 3.4

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2011-10-22 04:09:17 UTC
Hi Miklos,

Please feel free to reassign if you can't deal with this bug.

Best regards. JBF
Comment 2 Miklos Vajna 2011-10-22 04:36:43 UTC
Hi JBF,

There is some kind of MERGEFORMAT and MERGEFIELD support in writerfilter, so it should not be too hard to fix this in master. Will have a look as time permits.

Miklos
Comment 3 Cédric Bosdonnat 2011-11-12 05:53:01 UTC
The import of the accents shown in that file is fixed by:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a232f007458c9f474c6bf8fdf1f7f2c5ae467cf
Comment 4 Miklos Vajna 2011-12-20 03:44:10 UTC
Support for fields inside tables were completely missing in the new RTF filter.

Fixed in master: http://cgit.freedesktop.org/libreoffice/core/commit/?id=133f4d750a46dc67797d2f23f25a1bb39620d59f

Cherry-picked to -3-5: http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=80bab876c3efce923b98caac2a6373e666664761
Comment 5 Jean-Baptiste Faure 2012-03-19 14:26:47 UTC
Working now as expected confirmed in LO 3.5.1. Closing. Thank you.