Download it now!
Bug 42147 - FILEOPEN: Opening valid ODF text document crashes Writer
Summary: FILEOPEN: Opening valid ODF text document crashes Writer
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-23 23:38 UTC by iburago
Modified: 2011-12-08 21:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The test case file causing a crash (16.17 KB, application/vnd.oasis.opendocument.text)
2011-10-23 23:38 UTC, iburago
Details
crash at the opening with 3.4.3 (58.33 KB, text/x-log)
2011-11-04 18:17 UTC, Julien Nabet
Details
logs at the opening on master (11.08 KB, text/plain)
2011-11-04 18:19 UTC, Julien Nabet
Details
backtrace with symbols (16.34 KB, text/plain)
2011-11-29 13:14 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description iburago 2011-10-23 23:38:52 UTC
Created attachment 52672 [details]
The test case file causing a crash

Valid ODF text documents (created in LibreOffice 3.4.1 without an issue) that
contain at least one page with a frame, size of which is in certain proportion
to the page size and the header height on that page, cannot be opened in
LibreOffice 3.4.3 without causing a crash.  Regardless of whether such
a document is opened from a running instance of Writer or whether it is passed
to 'libreoffice' executable as a command line argument (one can reproduce the
issue either way), LibreOffice starts to open the file showing a progress bar
and sometimes even rendering the first few pages of the document, and then
suddenly halts.

I experience the bug both on x86 and x86-64 systems running both Windows and
Linux.  The minimal document I can create to reproduce this crash behavior,
consists of a single page with a frame of particular size.  The file
containing that document is attached to this bug report.
Comment 1 Julien Nabet 2011-11-04 18:17:49 UTC
Created attachment 53159 [details]
crash at the opening with 3.4.3

I reproduce the crash on 3.4.3.
Here are the logs :
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0xae69ec9b, pid=12092, tid=3026773712
#
# JRE version: 6.0_23-b23
# Java VM: OpenJDK Client VM (20.0-b11 mixed mode, sharing linux-x86 )
# Derivative: IcedTea6 1.11pre
# Distribution: Debian GNU/Linux unstable (sid), package 6b23~pre11-1
# Problematic frame:
# C  [libswli.so+0x3ebc9b]  SwAnchoredObject** std::__copy_move<false, true, std::random_access_iterator_tag>::__copy_m<SwAnchoredObject*>(SwAnchoredObject* const*, SwAnchoredObject* const*, SwAnchoredObject**)+0xd31
#
# An error report file with more information is saved as:
# /home/maryline/compile-libreoffice/libo/hs_err_pid12092.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
#

[error occurred during error reporting , id 0xb]

So i attached the hs_err file.
Comment 2 Julien Nabet 2011-11-04 18:19:03 UTC
Created attachment 53160 [details]
logs at the opening on master

I don't reproduce the crash on master (git updated today) but attached the logs.
Comment 3 Julien Nabet 2011-11-04 18:20:10 UTC
Both tests have been runned on Debian x86-32
Comment 4 iburago 2011-11-12 20:14:30 UTC
The problem remains in LibreOffice 3.4.4 on x86 and x86-64 systems running
both Windows and Linux: Writer still crashes while opening the test case file.
Comment 5 Julien Nabet 2011-11-29 13:14:52 UTC
Created attachment 53960 [details]
backtrace with symbols

I reproduced the crash with 3.4.4 on Debian testing x86-32.
Since I had installed the symbols too, I attached the soffice process to gdb once I had opened Writer. Then I just opened the file of the the tracker and retrieved the bt. (http://wiki.documentfoundation.org/Development/How_to_debug#Attaching_to_the_soffice.bin_process)
Comment 6 Julien Nabet 2011-12-01 13:54:36 UTC
According to the bt, it may be the same as fdo#43007
Comment 7 Ivan Timofeev (retired) 2011-12-08 11:17:08 UTC
fixed on master and 3-5 for now.
Comment 8 Ivan Timofeev (retired) 2011-12-08 21:53:48 UTC
(In reply to comment #7)
> fixed on master and 3-5 for now.

...not by me, this was Caolán who done this
http://cgit.freedesktop.org/libreoffice/core/commit/?id=3524727db0f3cfecf3a47046795c527808c10c3e

The fix will also be in the oncoming LibO 3.4.5

Julien - thank you for the backtrace, I didn't read it accurately - sorry!

Anyway, the bug is fixed.