Download it now!
Bug 42243 - UI: Embedded OLE charts in (e.g.) impress cannot be copied to calc?!
Summary: UI: Embedded OLE charts in (e.g.) impress cannot be copied to calc?!
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-25 14:40 UTC by Michael Reese
Modified: 2013-01-29 21:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
pptx file with embedded chart object w/ above behavior problems. (11.57 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2011-10-25 14:40 UTC, Michael Reese
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Reese 2011-10-25 14:40:48 UTC
Created attachment 52769 [details]
pptx file with embedded chart object w/ above behavior problems.

Problem description: 

Two bugs, for the price of one:

Someone sent me a pptx file with an embedded Excel chart in it.  I can view it fine, though it's all bollocksed up, since the pptx (as with docx) conversion is not very good, at all. I'm not expecting the file conversion to be fixed any time soon, so....

Therefore I'm in dire need of modifying it.  While I can tweak things here and there, the best/easiest/most desireable way to fix it is to transport the data back to LO calc, and deal with it in a native format.

1)  Ideally, I would click on the object, copy it to calc, and then I'd get the dataset as well as the linked chart.  Instead, if I click on the OLE object and copy it (to any LO doc -- calc/impress/whatever), I get a chart that has the same formatting, but none of the data.  

2)  OK, I try to copy over the data itself and then reformat. I cannot do that either.  Well, I could, if I clicked on EVERY cell INDIVIDUALLY and then copied and pasted.  That is inane.  I can pull up the chart data, but I cannot select all??!??!?  I can't even select individual rows or columns. That has got to be a bug.

Steps to reproduce:
1. .... Open attached file
2. .... Enter data
3. .... Try to copy, note that it does not function.

Current behavior:
Loss of data with direct copy/paste of OLE objects

and lack of support in UI for copying/selecting data directly within said object.

Expected behavior:
Copy/paste should yield an identical copy of the object.  Internal data viewer should allow full selection/copy to facilitate import back into, e.g. calc

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.23) Gecko/20110921 Ubuntu/10.04 (lucid) Firefox/3.6.23
Comment 1 sasha.libreoffice 2012-04-18 06:49:30 UTC
Thanks for bugreport
about extracting data... Created separate bug:
Bug 43699 - Extract, copy or export Chart data tables from Charts in Writer documents

In msPower Point 2007 such functionality exist: option "Edit data" for diagram, when click it, opens Excel with diagram data.

What about attachment: file corrupted. Possible reason: edited in LibreOffice.
It is second bug, as I understand.
Comment 2 sasha.libreoffice 2012-04-18 07:09:18 UTC
Workaround for extracting table:
1. Open attached pptx in LibreOffice and save as odp
2. Right click produced odp file in file manager and select "Extract to separate folder" (or something like this)
3. enter in produced folder in folder "Object 1" and open file content.xml in Firefox
4. Select text there from tag <table:table until tag </table:table> and copy

5. Start LibreWriter with new empty document and create there table with 1 cell
6. Save this document in format fodt (flat odt), close Writer
7. Open produced fodt file in text editor
8. Scroll to end of document, select from tag <table:table until tag </table:table> and delete
9. paste in produced gap result of step 4.
10. save text, close, open in Writer. We see needed table

Though long description, it takes about one minute to do these manipulations
Comment 3 sasha.libreoffice 2012-11-26 11:24:10 UTC
in Bug 43699 this problem is solved.
But found another problem: copy-pasting diagram from Impress to Writer performs incorrectly. May be another bugreport for this problem needed.
(legend becomes corrupted, manual fixing needed)
Comment 4 Joel Madero 2013-01-29 21:13:25 UTC
I am marking this as WFM as it works for me with 3.6.4.3. 

@Michael - if you're still seeing this with a newer release please reopen the bug and I'll try to confirm it again, else we'll say this one is solved. Thanks for your patience and help!