Bug 42256 - Insert, Names, Define, Modify
Summary: Insert, Names, Define, Modify
Status: RESOLVED DUPLICATE of bug 40571
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
3.4.3 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
Depends on:
Reported: 2011-10-25 23:39 UTC by JohnRyan
Modified: 2011-10-26 09:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description JohnRyan 2011-10-25 23:39:44 UTC
My spreadsheet has 4 worksheets and eight named ranges.  This is a sheet I have been using for many years in previous versions with no problems.  Since I installed 3.4.3 (OOO340m1 (Build:302)) the program crashes whenever I try to change the "Assigned to:" data.
Steps I take are:
click on menu "Insert, Names, Define"
The define window opens showing all 8 items with scope "Document (Global)".
I select the first one, so that I can change the row number in the "Assigned to" field, e.g. from "$Accounts.$P$834" to "$Accounts.$P$860".
When I delete the "34" and then type "60", all is well.
As soon as I click on the now active "Modify" button, the program crashes.
These are the same steps that previously worked with no problem.
I have tried this many times in recent times and the behaviour is 100% consistent in that the program always crashes and the recovery function works as expected.

The only way I have been able to work around this problem is to first delete the previous range name and then insert it again, using the "Add" button.
Comment 1 GerardF 2011-10-26 09:18:28 UTC

*** This bug has been marked as a duplicate of bug 40571 ***