Download it now!
Bug 42293 - 10-second delay, wait, pause, freeze in splash screen start-up loading - All apps
Summary: 10-second delay, wait, pause, freeze in splash screen start-up loading - All ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-26 14:58 UTC by Carl Turney
Modified: 2015-06-17 12:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carl Turney 2011-10-26 14:58:55 UTC
Hi,

When I run a LibO application, the splash screen pauses or freezes (for about 10 seconds) when the progress bar reaches ~40% complete.

There is no disk activity at all during this time. i.e. It appears to be doing "nothing".

There was not such a =long= delay in starting LibO just a couple months ago.  Maybe a bug, or "feature", has been introduced in a recent version?

Note:  But if I run a second LibO application (e.g. Writer), while the first (e.g. Calc) is still running, the second app loads and runs almost immediately.

Thanks very much for striving to fix this.

Carl Turney, Melbourne, Australia
Comment 1 schreiber 2011-11-29 08:40:45 UTC
I can confirm this behaviour. Disabling logo in sofficerc leads to quick startup of Libreoffice. Tested on linux, LibO 3.3.4 (x64) and 3.4.4 (i386, x64).

Environment is a linux terminal server environment, LibO is displayed on a remote X display. Environment Debian Lenny or Squeeze. Packages from libreoffice.org as well as packages from squeeze backports are affected.

It can be reproduced on localhost through a bandwidth throttled ssh:

trickle -s -u 5000 -d 5000 -t 0.1 ssh -X localhost libreoffice --calc
Comment 2 Florian Reisinger 2012-01-22 04:27:51 UTC
Confirmed with LibO 3,5rc1 Ubuntu 10.04.3, x86_64
Comment 3 sasha.libreoffice 2012-02-06 05:16:57 UTC
Tools->Options  LibreOffice->Java "Use a Java runtime environment"
Enabled or Disabled?
Comment 4 schreiber 2012-02-06 07:00:46 UTC
Java is enabled. Tested versions:

On Lenny:
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8.10) (6b18-1.8.10-0~lenny2)
OpenJDK Server VM (build 14.0-b16, mixed mode)

On Squeeze:
java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

To me it looks like a lot of painting in the progress bar is taking place which slows down startup.
Comment 5 sasha.libreoffice 2012-02-06 08:12:17 UTC
And if disable Java?
Comment 6 schreiber 2012-02-07 00:11:46 UTC
The behaviour does not change if I
- enable/disable java
- switch NativeProgress setting in sofficerc
Comment 7 Julien Nabet 2013-12-07 00:30:24 UTC
Any update with newer LO version? (last one is 4.1.3)
Comment 8 QA Administrators 2015-04-19 03:22:09 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 9 Buovjaga 2015-06-17 12:28:27 UTC
Not reproduced.
Setting to WFM. Please set back to NEW, if this is still a problem for any of you.

Ubuntu 15.04 64-bit 
Version: 4.4.2.2
Build ID: 40m0(Build:2)
Locale: en_US