Bug Hunting Session
Bug 42301 - Formula editor: undo works incorrectly (regression after 3.3.4)
Summary: Formula editor: undo works incorrectly (regression after 3.3.4)
Status: RESOLVED DUPLICATE of bug 37405
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 46324 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-27 00:08 UTC by Bernhard M. Wiedemann
Modified: 2012-06-28 03:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard M. Wiedemann 2011-10-27 00:08:23 UTC
I have libreoffice-math-3.4.2.6 on openSUSE-12.1-RC
and when I run oomath
and type into it
1
backspace (or shift-left is the same)
2
ctrl-z

it comes out as "12" instead of "1"
Comment 1 collette 2012-02-21 06:46:57 UTC
*** Bug 46324 has been marked as a duplicate of this bug. ***
Comment 2 Alexander Karatarakis 2012-02-28 04:46:12 UTC
Tried in 3.4.4 and the problem persists (3.5.0 not yet on the ppa so I will test when it is available).

To clarify, the math editor seems to be having a problem when deleting characters. E.g:

1) Insert a formula and write: abc
2) Delete b
3) Write d between a and c: adc
4) Click undo

The result should be ac at this point, but is abdc.
Comment 3 Alexander Karatarakis 2012-02-28 15:33:47 UTC
Just tired 3.5.0 and the issue remains.
Comment 4 sasha.libreoffice 2012-04-18 08:34:37 UTC
reproducible in 3.5.2 on Fedora 64 bit and in 3.4.3 on Windows XP 32 bit
but not reproducible in 3.3.4, therefore regression after 3.3.4
Comment 5 Ivan Timofeev (retired) 2012-06-28 03:42:40 UTC

*** This bug has been marked as a duplicate of bug 37405 ***