Bug 42341 - PRINTING of particular business cards looses contents of some textboxes
Summary: PRINTING of particular business cards looses contents of some textboxes
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
PreBibisect
Hardware: x86 (IA32) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA target:3.5.7
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-10-28 06:54 UTC by Istvan Varga
Modified: 2014-05-19 12:42 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Original document (546.27 KB, application/vnd.oasis.opendocument.text)
2011-10-28 06:54 UTC, Istvan Varga
Details
Printing result (2.11 MB, application/pdf)
2011-10-28 06:58 UTC, Istvan Varga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Istvan Varga 2011-10-28 06:54:26 UTC
Created attachment 52855 [details]
Original document

Please check attachments. This is my business cards. I'm using this document for a while now but with this version I can't print a correct page from it. When I remove some data prining goes well, but this is made for a special business card paper format, so I can't remove anything.

Why I have to? It's very annoying, it should print corretly...

Writer's print preview shows everything okay. It doesn't matter what printer I use (physical laser/inkjet, virtual, pdf printer, etc.).

LibreOffice 3.4.3 
OOO340m1 (Build:302)
Comment 1 Istvan Varga 2011-10-28 06:58:22 UTC
Created attachment 52856 [details]
Printing result
Comment 2 Rainer Bielefeld Retired 2011-10-29 00:44:31 UTC
[Reproducible] with reporter's sample "businesscards.odt" and "LibreOffice 3.4.4RC1  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:401)]". Printing to printer FreePDF looses contents "VARGA ISTVÁN rendszer-informatikus" in some text boxes. 

No problem with PDF export

Works fine with LibreOffice Portable 3.3.3  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:301  Tag 3.3.3.1)]" and FreePDF, so regression.

@Cédric:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 3 Istvan Varga 2011-10-31 08:28:04 UTC
(In reply to comment #2)

> No problem with PDF export

There is. Please magnify it and you'll see unwanted lines around the name for example. I printed it from the exported PDF and after the unaccepted result I realized that PDF also have problems.
Comment 4 Rainer Bielefeld Retired 2011-10-31 09:07:59 UTC
@Istvan Varga
This is the Lost Contents Bug

For other problems please submit separate bugs!
Comment 5 Thomas Thym 2011-12-21 09:08:03 UTC
I am not sure. Perhaps this is related to https://bugs.freedesktop.org/show_bug.cgi?id=40489 "PRINTING: Option Buttons and Check Boxes not printed correctly"
There are also elements (check boxes) not printed (by the printer) but displayed and printed in PDFs.
Comment 6 Björn Michaelsen 2012-03-01 08:20:02 UTC
Regression does appear in oldest version of bibisect-3.5.tar.lzma and must be older.
Comment 7 Michael Stahl (allotropia) 2012-03-22 12:36:26 UTC
this broke in 3.5; both LO 3.4 and OOo 3.4 produce
substantially different PDFs when printing:
the one from 3.4 versions is ~586k in size, and in Evince i can select the text
the one from 3.5 is ~12.5m in size, and in Evince i can't select the text,
 and part of the text is missing as described by the reporter.

does anybody know of any substantial changes to PDF rendering
that were done for 3.5?
Comment 8 Michael Stahl (allotropia) 2012-03-22 12:38:48 UTC
oh, forgot this: if i remove the background picture from the frames,
then the text is correctly printed (well the white text is invisible,
but the black text is fully there)
Comment 9 Caolán McNamara 2012-03-22 13:07:43 UTC
re sizes, you're comparing non debug/dbgutil versions, right ?. i.e. IIRC there's some ifdefs in VCL to not do image/blob compression in pdf export at higher debug or dbgutil level or some such.

in general I'm unaware of any significant pdf changes in vcl anyway.
Comment 10 Caolán McNamara 2014-05-09 16:02:12 UTC
caolanm->mstahl: with libreoffice 4.2.3 I can export to pdf (or print to file as pdf) and I get a 590k resulting document that appears, to my eyes at least, to contain all the contents of the textboxes.
Comment 11 Michael Stahl (allotropia) 2014-05-19 12:30:44 UTC
seems to be fixed since a long time,
can reproduce it in 3.5.0 but not 3.5.7 or 3.6.7

but on current master, on loading the bugdoc the images are gone,
guess we should fix that, will file a new bug for that