Bug Hunting Session
Bug 42362 - Can't open file if filename contains high ASCII
Summary: Can't open file if filename contains high ASCII
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 45339 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-29 02:48 UTC by Jani
Modified: 2014-04-25 14:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Result of locale -a (2.11 KB, text/plain)
2012-11-24 22:46 UTC, Fiable.biz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jani 2011-10-29 02:48:52 UTC
Trying to open huoltopäiväkirja.ods will result to an error:
"/home/user/huoltopäiväkirja.ods does not exist."
renaming the file to huoltopaivakirja.ods and the file opens without problems.

LibreOffice 3.3.3 
OOO330m19 (Build:301)
Ver: 3.3.3.1-7.fc15

Linux oc7228322058.ibm.com 2.6.40.6-0.fc15.x86_64 #1 SMP Tue Oct 4 00:39:50 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Dolphin
Version 1.6.1
Using KDE Development Platform 4.6.5 (4.6.5)
Comment 1 Jani 2012-02-10 04:20:27 UTC
The fileopen issue still present at 
LibreOffice 3.4.5 
OOO340m1 (Build:502)
Comment 2 Stephan Bergmann 2012-02-10 06:24:35 UTC
This is a known limitation in LO's design, handling pathnames as Unicode internally.  When a pathname contains byte sequences that are not valid per the current locale's text encoding (or do unambiguously map to and from Unicode), LO has problems accessing that pathname.

What is your locale (i.e., output of "locale" in a shell), and how do you start LO and specify the file to be loaded (by typing "soffice huoltopäiväkirja.ods" into a shell)?
Comment 3 Stephan Bergmann 2012-02-10 06:25:13 UTC
"do *not* unambiguously," of course
Comment 4 Jani 2012-02-11 08:07:20 UTC
Output of locale:
============= >8 cut here ============
LANG=en_DK.UTF-8
LC_CTYPE="en_DK.UTF-8"
LC_NUMERIC="en_DK.UTF-8"
LC_TIME="en_DK.UTF-8"
LC_COLLATE="en_DK.UTF-8"
LC_MONETARY="en_DK.UTF-8"
LC_MESSAGES="en_DK.UTF-8"
LC_PAPER="en_DK.UTF-8"
LC_NAME="en_DK.UTF-8"
LC_ADDRESS="en_DK.UTF-8"
LC_TELEPHONE="en_DK.UTF-8"
LC_MEASUREMENT="en_DK.UTF-8"
LC_IDENTIFICATION="en_DK.UTF-8"
LC_ALL=
============= >8 cut here ============

I'm running Fedora 16 with KDE plasma.
Double clicking the spreadsheet file via dolphin (the filemanager) results to the error.
Opening the file via LO Calc, using File - Open, results to same error.

Trying to open via command line provides error:
I18N: X Window System doesn't support locale "en_DK.UTF-8"



The locale setting is what I've had on my system since Fedora 10 or so. Has en_DK.UTF-8 become ibsolete at some point?
Comment 5 Stephan Bergmann 2012-03-01 01:49:51 UTC
@Jani: please try one of the locales from the list output by Fedora-16's "locale -a", e.g., "en_DK.utf8"
Comment 6 Jani 2012-03-01 22:53:04 UTC
Changed the locale setting, the old one had been carried over or copied incorrectly in one of the upgrades I've done over the last couple of years.

Apparently this issue is related to KDE Plasma desktop: The problem still persisted. I logged out, logged back in using Cinnamon desktop -> no issue.
Comment 7 Stephan Bergmann 2012-03-01 23:50:05 UTC
So we can close this issue, right?
Comment 8 Jani 2012-03-02 06:38:16 UTC
Yeah, Ok to close.
Now reported against KDE: https://bugs.kde.org/show_bug.cgi?id=295212
Comment 9 Urmas 2012-03-14 01:50:22 UTC
*** Bug 45339 has been marked as a duplicate of this bug. ***
Comment 10 Fiable.biz 2012-11-24 22:46:02 UTC
Created attachment 70528 [details]
Result of locale -a

It has been suggested on KDE bugzilla to reopen this bug here:
https://bugs.kde.org/show_bug.cgi?id=295212
as a possible "problem of the kde integration module of libreoffice, because under the en_DK.UTF-8 locale:
  caligra suite can open that file
  libreffoce(without kde integration module) can open that file
  libreffoce(with kde integration module) can't open that file
".

I have a similar problem on Mageia 2, LibreOffice 3.5.5.3, with locale mn_MN.UTF8 . German language is not used at all.
I first recorded it there:
https://bugs.mageia.org/show_bug.cgi?id=7797
The message I get states:
$ soffice /home/henri/Documents/été.ods
I18N: X Window System doesn't support locale "mn_MN.UTF-8"
Comment 11 Fiable.biz 2012-11-26 02:33:09 UTC
If I remove libreoffice-kde:
urpme libreoffice-kde
then the problem disappears.
Comment 12 Robert 2013-01-21 10:58:26 UTC
Same issue here with libreoffice-3.6.4.3. I could resolve the problem by removing libreoffice-kde, too.
Comment 13 Luboš Luňák 2014-04-25 14:44:32 UTC
I can open huoltopäiväkirja.odt without problems using the KDE File Dialog from LibreOffice, so I assume this has been fixed.