Bug 42397 - : SUMIF fails if criteria text contains brackets
Summary: : SUMIF fails if criteria text contains brackets
Status: RESOLVED DUPLICATE of bug 42097
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-30 05:51 UTC by Richard Simmons
Modified: 2011-10-30 05:57 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Image showing correct and incorrect behaviour side-by-side (63.73 KB, image/jpeg)
2011-10-30 05:51 UTC, Richard Simmons
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Simmons 2011-10-30 05:51:43 UTC
Created attachment 52910 [details]
Image showing correct and incorrect behaviour side-by-side

Problem description: When using the SUMIF function, the function gives a result of 0 if the cell referenced in the criteria (second argument) contains brackets.

Steps to reproduce:

Enter the following data in A1:B6;
Primary Teacher	        3
Secondary Teacher	7
Teachers (other)	5
Primary Teacher	        3
Secondary Teacher	7
Teachers (other)	5

Enter the following in D1:D3;
Primary Teacher
Secondary Teacher
Teachers (other)

Enter the following formula in cell E1 and then copy down to E2 & E3
=SUMIF($A$1:$A$6,D1,$B$1:$B$6)

Note that the result for "Primary Teacher" is correct (ie 6), "Secondary Teacher" is correct (ie 14), "Teachers (other)" is incorrect (result is 0).  Now search and replace "Teachers (other)" with "Other Teachers" and note that the result is correct (ie 10).



Current behavior:

Expected behavior:

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Comment 1 vitriol 2011-10-30 05:57:59 UTC
Probably related to Bug 42097. Marked as a duplicate for now.

*** This bug has been marked as a duplicate of bug 42097 ***