Bug 42410 - UI: Inconsistency 'Find & Replace' Button
Summary: UI: Inconsistency 'Find & Replace' Button
Status: RESOLVED DUPLICATE of bug 51615
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: lowest minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, skillCpp
Depends on:
Blocks:
 
Reported: 2011-10-30 22:17 UTC by Robert Zelnik
Modified: 2015-12-15 22:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Zelnik 2011-10-30 22:17:49 UTC
I would like to have a "Replace & Find Next" button in Find and Replace dialogue. I need to find, manually check and replace many occurrences of the same string. With separate "Find" and "Replace" buttons I need to move the cursor up and down between them again and again, which is annoying. One button for both operations would be very useful.
Comment 1 sasha.libreoffice 2012-04-19 00:16:55 UTC
Thanks for new idea
Meanwhile, hold Alt and press buttons f and r on keyboard for "Find" and "Replace" correspondingly. It will improve productivity
Comment 2 Robert Zelnik 2012-04-20 02:26:35 UTC
Sasha, thanks for the tip. Just for explanation: Keyboard shortcuts are useful when you use the application frequently and/or remember the shortcuts. In that case it does improve your productivity. If I use some application rarely, usually I don't remember it's invisible features, so in that case I prefer availability through visible means like menu items or buttons.
Comment 3 sasha.libreoffice 2012-04-20 02:52:06 UTC
Thanks for additional information
> With separate "Find" and "Replace" buttons I need to move the
> cursor up and down between them again and again, which is annoying.
If we will have button "Replace & Find Next" and will not move cursor and not use keyboard, we all the same will replace all occurrences of text.

May would be better have something like "Replace with confirmation" which replaces text if we press Enter and not replaces if we press, say, space button. It is easy to remember, how to use it and easily to use.

In any case, it is up to developers to decide, how it should be. We only collect new ideas.
Comment 4 Robert Zelnik 2012-04-20 03:58:14 UTC
Replace with confirmation would also be great, although it's bit unconventional for me. For your info: "Replace & Find Next" button usually works this way: it replaces the current occurence, moves the cursor to the next occurence and wait to the user interaction.

In short: One click - one change, move to the next. Wait. That's all.
Comment 5 Rainer Bielefeld Retired 2013-02-04 06:34:38 UTC
I agree with  Robert Zelnik and I wonder whether we really need  an enhancement request for something new.

Robert's description matches with the Behavior of 'Find & Replace' in Writer, and I think we only need to eliminate the inconsistency that in Calc 'Replace' does not automatically move focus to the next hit?
Comment 6 Rainer Bielefeld Retired 2013-02-14 09:27:41 UTC
In all other LibO applications (I checked Writer and DRAW) Find and replace works as follows:
a) <Find> jumps to next hit and highlights it
b) <Replace> replaces highlighted contents 
c) after it automatically next hit will be found and highligted

Only in Calc for step c you have to click <Find> again for next hit

May be there are some reasons for the current different behavior because that never worked different (I checked back until OOo 1.1.5)?

Low priority because of bug age and unclear reasons

If devs agree that this really would be an improvement: Fix should not be too difficult
Comment 7 Jorendc 2013-04-03 22:13:37 UTC
Hi,

Sorry for this, but I'm going to mark this older bugs as a duplicate of a newer bug (Bug 51615). This is not our conventional workflow, but I already send a patch to gerrit to fix this inconsistent behavior (https://gerrit.libreoffice.org/#/c/3197/) regarding bug 51615.

Thanks for reporting,
Joren

*** This bug has been marked as a duplicate of bug 51615 ***
Comment 8 Robinson Tryon (qubit) 2015-12-15 22:41:05 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval,   SkillCpp  )
[NinjaEdit]