Bug 42416 - standard.dic contains relation to OOo
Summary: standard.dic contains relation to OOo
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: lowest trivial
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: 33150
  Show dependency treegraph
 
Reported: 2011-10-31 03:21 UTC by Mike §chinagl
Modified: 2012-11-08 14:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike §chinagl 2011-10-31 03:21:36 UTC
The standard dictionary file (standard.dic) and other user generated files contain a first line which refers to OOo.  


Steps to reproduce:
1. Go to standard.dic in User folder (under Windows that is 
C:\Dokumente und Einstellungen\~user\Anwendungsdaten\LibreOffice\3\user\wordbook
2. Open standard.dic with text editor
3. In first text line it reads "OOoUserDict1"
4. Reproduce with any other user generated user dictionary and the first line reads "OOoUserDict1" again 

Current behavior:
- shows wrong first indication line in standard .dic file
- shows wrong first indication line in user genrated .dic file and should continue numbering like "OOoUserDict2"

Expected behavior:
- first text line it reads "OOoUserDict1" insead of "LibUserDict1"
- further user generated .dic files should number up "LibUserDict2", "LibUserDict3" etc.

Platform (if different from the browser): 
- XP with LibO 3.4.3 (Browser: Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1)
- same happens under Ubuntu 10.10 with LibO 3.4.3
Comment 1 manj_k 2011-11-09 10:43:38 UTC
'OOoUserDict1' is the file format (encoding, 'magic string') for user-readable and user-editable custom dictionaries [introduced with OOo].

See, e.g.:
https://issues.apache.org/ooo/show_bug.cgi?id=60698#c15
https://issues.apache.org/ooo/show_bug.cgi?id=91392

IMHO: RESOLVED INVALID.

Feel free to reopen that bug, if you did not agree with this decision.
Comment 2 Mike §chinagl 2011-11-20 01:33:23 UTC
(In reply to comment #1)
> 'OOoUserDict1' is the file format (encoding, 'magic string') for user-readable
> and user-editable custom dictionaries [introduced with OOo].
> 
> See, e.g.:
> https://issues.apache.org/ooo/show_bug.cgi?id=60698#c15
> https://issues.apache.org/ooo/show_bug.cgi?id=91392
> 
> IMHO: RESOLVED INVALID.
> 
> Feel free to reopen that bug, if you did not agree with this decision.

I would like to reopen this bug, because I think that the decision was right for OOo, but now that LibO exists I think the dictionaries instead of 'OOoUserDict1' should contain a LobO related string like 'LibOUserDict1'

I would like to hear more voices on this issue as it could have long lasting relevance.
Comment 3 manj_k 2011-11-20 02:08:01 UTC
(In reply to comment #2)
> [...]
> I would like to hear more voices on this issue as it could have long lasting
> relevance.

Agreed.
I've modified 'Version' to 'unspecified' (= valid for all versions of LibO).
Comment 4 Urmas 2012-11-08 14:32:22 UTC
Why should we BREAK COMPATIBILITY for vanity? Maybe you won't believe that, but some people are actually trying to WORK in LibreOffice...