Download it now!
Bug 42429 - Feature request: tabbed interface
Summary: Feature request: tabbed interface
Status: RESOLVED DUPLICATE of bug 37134
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-31 06:57 UTC by niklas.s.rosenqvist
Modified: 2013-12-15 20:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description niklas.s.rosenqvist 2011-10-31 06:57:19 UTC
Hello everyone!

I know that there is a lot of work being done on the UI at the moment with the planning of releasing LibreOffice to tablet platforms and other form factors. So I thought that I should add my two cents to the idea pool.

Wouldn't it be much more effective to utilize a tabbed interface for LibreOffice than having multiple instances of the same application running? If I work with many documents at the same time it's much easier to switch to another open document if I can see it as a tab in the window I have focused. I use GNOME-Shell as my primary desktop environment and it, like Unity, doesn't show titles of the windows in the same manner as Windows's or Gnome2's taskbar. So it's not as easy to handle multiple open documents at the same time.

Either it can be implemented that Writer features tabs of all open Writer-documents and Calc features tabs of all open Calc-documents. Or the suite can use one single window to handle all kinds of LibreOffice supported media. To me it doesn't make much sense to ship the suite with one application called "LibreOffice" which is just used to open other applications/modules (I don't know how LibreOffice is designed). Why not manage all open documents from this one window?
Comment 1 vitriol 2011-10-31 07:00:14 UTC

*** This bug has been marked as a duplicate of bug 37134 ***
Comment 2 vitriol 2011-10-31 07:13:30 UTC
OK, different request than Bug 37134, but I think that can be drawn in the same bug...
Comment 3 Ilian Dimitrov 2012-01-17 11:39:20 UTC
+1

I agree it's going to be a killer feature if there were tabs in Libre Office.
Comment 4 Adolfo Jayme 2013-12-15 20:05:27 UTC

*** This bug has been marked as a duplicate of bug 37134 ***