Bug 42501 - PRINTING: Printout of spreadsheet tab not working as expected
Summary: PRINTING: Printout of spreadsheet tab not working as expected
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-02 02:13 UTC by mlerjen
Modified: 2013-11-25 14:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Spreadsheet with three sheets. Tab 2 should be exported as pdf, but how to find out the page number??? (280.47 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-09-13 19:37 UTC, mlerjen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mlerjen 2011-11-02 02:13:20 UTC
Task: Printout of a table on the second tab of a spreadsheet. (First tab contains a large table).

Problem: Print and pdf export always start with the first tab. It is impossible (or at least not obvious) to find out the page number corresponding to the table on the second tab.
In OOO, the print preview shows the correct page numbers that I can enter in the print dialog to have the table on the second tab printed/pdf exported. This does not work correctly in LibreOffice.
Comment 1 sasha.libreoffice 2012-04-19 02:28:08 UTC
Thanks for bugreport
in 3.3.4 and 3.5.2 on Fedora 64 bit not reproducible for me

Please, verify if in last version of LibreOffice still reproducible
Comment 2 mlerjen 2012-04-19 04:03:35 UTC
The problem still exists in pdf export. pdf export always start with the first tab. It is impossible (or at least not obvious) to find out the page number corresponding to the table on the second tab.


Although, printing is now ok in 3.5.2 on Mac.
Comment 3 sasha.libreoffice 2012-04-19 05:02:13 UTC
Thanks for additional testing
For exporting to PDF try this: File->Print, tab "Option", field "Print to file"
Comment 4 mlerjen 2012-04-19 05:13:56 UTC
A similar option as you describe exists in the MacOS print dialog. This might be OK in many cases, but the File->Export as PDF ... Dialog offers more options for PDF export.
The only problem is that the connection from spreadsheet tabs to page numbers is not clear. It would be nice if this could be fixed somehow. Thank you!
Comment 5 sasha.libreoffice 2012-04-19 05:44:01 UTC
> The only problem is that the connection from spreadsheet tabs to page numbers
> is not clear.
I never printed from all tabs at once, so can not currently say something useful. Sorry. May be someone else can help. 
Leaving status to Unconfirmed for this bug will appear on top of search results of Bugzilla.
Comment 6 Alex Thurgood 2012-09-13 15:34:13 UTC
Doesn't "Print Preview" in the LO "File" menu show you a preview of how your document would be printed out with all tabs, from which you can derive the page number of any given sheet ?

A sample document would be nice that illustrates the problem, it doesn't have to be big, just representative.


Alex
Comment 7 mlerjen 2012-09-13 19:37:16 UTC
Created attachment 67119 [details]
Spreadsheet with three sheets. Tab 2 should be exported as pdf, but how to find out the page number???

Unfortunately File->Print Preview is not helpful. It shows just the pages of the current sheet, but not the pages of all sheets of the spreadsheet document.

The page number field in the pdf export dialog always refers to the page numbers of the whole document(i.e. page 1 = first page of sheet1, but impossible to know the page number of the first page of sheet2) , whereas the page numbers in File->Print Preview are just relative to the current sheet (page 1= first page of the current sheet).


Please find attached an example file that might help to reproduce the problem. The problem is: If you want to have just sheet 2 in a pdf (File->Export as PDF, because only here you have all pdf export options): How to find the page number of this sheet2, that has to be entered in the pdf export dialog box?
Comment 8 sasha.libreoffice 2012-09-14 14:40:16 UTC
Thanks for attachment
Please, try this with attachment: select second sheet, File->Export to PDF, select option "Selection" on first tab. And tell how many pages are in resulting PDF.

And I agree that this is not very obvious. Page number and preview are not shown. With File->Print situation is much more handy, but there is not enough pdf-specific options.
Comment 9 mlerjen 2012-09-14 15:45:38 UTC
Thanks for the hint. 

Highlighting the content of sheet2 and choosing "Selection" in pdf export is a solution for my problem. So my direct problem is solved.

And we have now found the main point: How to connect page numbers, that are not counted in the same way depending on context (single sheets or overall document) with the pdf-exporter and print dialog is not obvious. It is a conceptual problem and the software architects/main developers have to define an "universal" concept for it.

Thank you for your help!
Comment 10 Alex Thurgood 2012-09-19 07:32:35 UTC
I suggest this be set to WFM, and a new issue opened for enhancement pertaining to the determination of PDF printing options for any given page other than those on the first sheet.

Alex
Comment 11 mlerjen 2012-09-19 08:53:26 UTC
I completely agree. With "set to WFM" you mean to set it to "resolved-works for me", right?
Who is supposed to do that and to open the new feature request?

Thank you for your help!
Comment 12 Alex Thurgood 2012-09-24 07:46:50 UTC
Closing as WFM, opened new issue 55273, as request for enhancement.