Download it now!
Bug 42513 - [Calc] Modify cell name causes crash
Summary: [Calc] Modify cell name causes crash
Status: RESOLVED DUPLICATE of bug 40571
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-02 06:35 UTC by Colin Beckingham
Modified: 2011-11-02 08:16 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Beckingham 2011-11-02 06:35:44 UTC
Using 3.4.3 downloaded from LO site. OpenSUSE 11.4 64 bit, custom kernel 3.1, Gnome 2

To recreate:

1. Open new spreadsheet
2. enter sample data in cell A1, A2, select A1
3. Insert->Names->Define enter name eg "One", click 'Add' and 'OK' to close dialog. OK so far.
4. Reopen name dialog, select name "One". 'Assigned to' control is activated.
5. Click in 'Assigned to' control and edit to show name 'One' assigned to A2, click 'Modify'
6. Calc immediately freezes or crashes. Dialog controls are unresponsive. Repeatedly clicking the X to close the dialog finally succeeds in crashing LO Calc, restarting LO allows recovery to continue to last saved point.

Happens consistently.

Workaround: delete name first, save SS, then create it anew.
Comment 1 simc 2011-11-02 08:10:58 UTC
I've the same bug on MacOS
Comment 2 vitriol 2011-11-02 08:16:48 UTC

*** This bug has been marked as a duplicate of bug 40571 ***