Download it now!
Bug 42537 - RTL UI [AR]: "active indication" background with border (for icons) in menu at left instead at right
Summary: RTL UI [AR]: "active indication" background with border (for icons) in menu a...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: Other Windows (All)
: medium normal
Assignee: Ivan Timofeev (retired)
URL:
Whiteboard: BSA target:3.6.0 target:3.5.3
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-11-02 15:34 UTC by Ibrahim
Modified: 2012-04-17 08:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of bug (336.22 KB, image/jpeg)
2011-11-02 15:34 UTC, Ibrahim
Details
Screenshot (437.57 KB, image/png)
2012-04-04 04:27 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ibrahim 2011-11-02 15:34:53 UTC
Created attachment 53086 [details]
screenshot of bug

Problem description: 
Lines and squares in menus in Arabic user interface aligned to left while must aligned to right.

See these screenshots:
http://i290.photobucket.com/albums/ll251/ibraheem_alex/lineandsquareofmenusbug-2.jpg
http://i290.photobucket.com/albums/ll251/ibraheem_alex/lineandsquareofmenusbug-1.jpg

Steps to reproduce:
1. Change the language user interface to Arabic.
2. Open any menu or menus containing checked boxes.

Current behavior:
lines of menus and checked boxes appears in left of menu and must appear in right because Arabic user interface aligned form right to left (Arabic language writes from right-to-left).

Expected behavior:
Same as Current behavior.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Comment 1 Rainer Bielefeld Retired 2011-11-02 23:32:27 UTC
[Reproducible] with "LibreOffice 3.4.4RC2  - WIN7 Home Premium (64bit) Arabic UI  [OOO340m1 (Build:402)]". 

In menus Icons and checkmarks are correctly at  the richt of the text, but the thin blue frames with transparent dark backgronds, what should come up behind Idons of active functions, are at left from the text, not behind the icon. Additionally the separation line what separates the icons column from the texts column is on the wrong side, also left instead of right from the menu texts.

This makes LibO more or less unusable for rtl., So this might be a "Most Annoying Bug"

@Ibrahim:
did you also observe that with earlier versions?

@Sophie
Do you know who handles such RTL GUI problems?
Comment 2 Ibrahim 2011-11-03 20:33:31 UTC
Yes, I observed that with earlier versions.
Comment 3 Rainer Bielefeld Retired 2012-04-04 04:25:05 UTC
I checked with Server installation "LibreOffice 3.3.3  AR UI / German Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit) and it looked ok for me, "active" background was at the right side of the menu correctly behind the icons, please see attached screenshot. So this one seems to be a REGRESSION

3.4 lifecycle is terminated, so shift to “Bug 37361 LibreOffice 3.5 most annoying bugs”

@Ivan:
Will you find the time to handle this RTL issue? Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 4 Rainer Bielefeld Retired 2012-04-04 04:27:00 UTC
Created attachment 59468 [details]
Screenshot

Seems OK in 3.3.3, See Comment 3

I forgot to mention that I did not a new test with current Release or Master, but I doubt that this became fixed in between.
Comment 5 Ivan Timofeev (retired) 2012-04-11 11:05:53 UTC
I can't test patches on Windows, but I blindly committed a partial fix
http://cgit.freedesktop.org/libreoffice/core/commit/?id=a4cc4d3ec982ac61100b337125983afa0bb6fbc3
Let's check it in a daily master build...

It's not clear to me how I could properly fix checkmark backgrounds, the coordinate correction magic runs through the entire code. %-)
Comment 6 Rainer Bielefeld Retired 2012-04-11 21:44:35 UTC
Modified Assignee due to the facts.

@Ivan:
I would try to help, but the daily builds I know only are English / LTR, so it seems I can't support here.
I wonder why we did not get a atomatic message here "Ivan Timofeev has committed a patch ....", can you please check that?
Comment 7 Ivan Timofeev (retired) 2012-04-11 22:31:48 UTC
You can test RTL UI on en-US builds! ;) Just add the SAL_RTL_ENABLED enviroment variable. For example:

run cmd.exe
> set SAL_RTL_ENABLED=1
> cd "C:\Program Files\LOdev 3.6\program"
> soffice.exe

or add it globally in the system settings to inverse all LibO instances.

Anyway, I have tested it with master~2012-04-11_22.00.43..., and it works. (unexpected result :) I'll try to fix the checkmark backgrounds soon.

> I wonder why we did not get a atomatic message here

because I forgot to add 'fdo#42537' to the commit message.
Comment 8 Not Assigned 2012-04-14 10:04:51 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7179a362dd5788c4c4f7197d15abfa17e0cad584

vcl: win: fix RTL checkmark backgrounds fdo#42537
Comment 9 Ivan Timofeev (retired) 2012-04-14 10:39:10 UTC
Fixed in master, proposed for libreoffice-3-5.
Comment 10 Not Assigned 2012-04-17 07:57:56 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=672071c02622c8ad4b9f23f2a5b885cfe7f72669&g=libreoffice-3-5

fdo#42537: fix RTL menu rendering on Windows


It will be available in LibreOffice 3.5.3.
Comment 11 Ivan Timofeev (retired) 2012-04-17 08:44:33 UTC
Marking FIXED.
P.S. Rainer, I forgot to tell that I managed to set up a working MinGW build in a virtual machine for testing purposes.