Bug 42560 - Make Insert Special Character dialog non-modal
Summary: Make Insert Special Character dialog non-modal
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 RC1
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-03 08:18 UTC by beimaginativeegroup
Modified: 2014-11-06 05:02 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Special Character dialog on Windows, from tool bar launch 4.4.0alpha1+ (24.49 KB, image/png)
2014-11-05 14:17 UTC, V Stuart Foote
Details
the new dialog with Insert button (25.29 KB, image/png)
2014-11-05 15:21 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description beimaginativeegroup 2011-11-03 08:18:30 UTC
Problem description: When you choose a special character from the dialogue box it closes. 

Steps to reproduce:
1. Open a document in LibreOffice Writer
2. Go to Insert > Special Character
3. Choose a character
4. Click OK

Current behavior: The dialog box closes after inserting the special character

Expected behavior: The dialog box should remain open just in case you want to insert another character after it. 

Platform (if different from the browser): Windows XP
              
Browser: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.106 Safari/535.2
Comment 1 vitriol 2011-11-03 08:27:38 UTC
enhancement
Comment 2 sasha.libreoffice 2012-02-06 07:15:26 UTC
in LibO 3.5.0 beta is no button "Insert" in this dialog
Comment 3 Roman Eisele 2012-05-03 04:44:14 UTC
This is a Writer feature request, therefore changed 'Component' to 'Writer'.
Comment 4 sasha.libreoffice 2012-05-03 05:22:35 UTC
Not only Writer. In Calc and Impress the same problem
Comment 5 almos 2013-04-13 18:09:17 UTC
Have you tried clicking on more than one character in the table? With each click you append the character to the string below the table, and 'OK' inserts the whole string. It's different from MS Office, but not hard to get used to IMHO.
Comment 6 Urmas 2013-04-14 10:54:46 UTC
Clarifying the issue.
Comment 7 beimaginativeegroup 2013-04-15 19:36:36 UTC
Setting this as FIXED.
Comment 8 Urmas 2013-04-15 19:52:38 UTC
It's not fixed.
Comment 9 beimaginativeegroup 2013-04-17 16:18:45 UTC
The original issue is now fixed because there is a way to do multiple special characters.
Comment 10 almos 2013-04-18 09:01:20 UTC
Maybe this functionality can be made more intuitive, if the 'OK' button is renamed to 'Insert selected characters'?
Comment 11 beimaginativeegroup 2013-04-20 08:40:15 UTC
Good idea.
Comment 12 V Stuart Foote 2014-11-05 07:33:12 UTC
A little QA housekeeping, setting to NEW from REOPENED

The Special Character dialog has allowed multiple selection and insertion for some time. So, the remaining work for this enhancement appears to be a simple change of generic OK label to be an Insert action label.  

@Jay, @Kendy would you add this to the Design/UX slate for any needed discussion.
Comment 13 Yousuf Philips (jay) (retired) 2014-11-05 07:55:01 UTC
The dialog was revamped in bug 64302 and i can see the 'OK' button is now 'Insert' in master.

Version: 4.4.0.0.alpha1+
Build ID: ad6d94009cf8ea526eb70bf1a07e5c6a21320f83
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-11-04_00:14:41
Comment 14 V Stuart Foote 2014-11-05 14:17:01 UTC
Created attachment 108961 [details]
Special Character dialog on Windows, from tool bar launch 4.4.0alpha1+

(In reply to Jay Philips from comment #13)
> The dialog was revamped in bug 64302 and i can see the 'OK' button is now
> 'Insert' in master.
> 
> Version: 4.4.0.0.alpha1+
> Build ID: ad6d94009cf8ea526eb70bf1a07e5c6a21320f83
> TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-11-04_00:14:41

@Jay, are we talking about different widgets? I'm launching from the standard toolbar, is there another way to activate?

On Windows 7 sp1, 64-bit en-US with
Version: 4.4.0.0.alpha1+
Build ID: 3efc3cc5b0b4b6151e928c2348c7dc6f74181db5
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-10-28_22:16:12

p.s.
Launch from Toolbar in current TB39 debug builds are having an assertion issue I need to unwind.
Comment 15 Adolfo Jayme 2014-11-05 14:54:31 UTC
(In reply to V Stuart Foote from comment #14)
> Created attachment 108961 [details]
> Special Character dialog on Windows, from tool bar launch 4.4.0alpha1+


You should try a newer build…
Comment 16 V Stuart Foote 2014-11-05 15:21:22 UTC
Created attachment 108967 [details]
the new dialog with Insert button

Hmm, it is there with

Version: 4.4.0.0.alpha1+
Build ID: b7d8a58ff2698ffc6e22943f64aa97c5ea253bd9
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-05_00:14:13

But seems like commit for bug 64302 should already have been present with the 2014-10-28 TB51 build. Oh well...

On to other issues, sorry for the noise.
Comment 17 Adolfo Jayme 2014-11-06 04:44:58 UTC
(In reply to V Stuart Foote from comment #16)
> But seems like commit for bug 64302 should already have been present with
> the 2014-10-28 TB51 build. Oh well...

The git log is useful for these things ;)

http://cgit.freedesktop.org/libreoffice/core/log/cui/uiconfig/ui/specialcharacters.ui
Comment 18 V Stuart Foote 2014-11-06 05:02:06 UTC
(In reply to Adolfo Jayme from comment #17)
> The git log is useful for these things ;)
> 
> http://cgit.freedesktop.org/libreoffice/core/log/cui/uiconfig/ui/
> specialcharacters.ui

Sorry, I think I had only been looking at cuicharmap.cxx in Opengrok and missed your commit against the .ui