Bug Hunting Session
Bug 42575 - Sum across sheets don't work if one of the terms of the sum is ""
Summary: Sum across sheets don't work if one of the terms of the sum is ""
Status: RESOLVED DUPLICATE of bug 37860
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-03 17:13 UTC by Marc Muehlfeld
Modified: 2011-11-03 23:11 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Sample spreadsheet showing the problem. (7.97 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-11-03 17:13 UTC, Marc Muehlfeld
Details
Screenshot of the error (32.37 KB, image/png)
2011-11-03 17:15 UTC, Marc Muehlfeld
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2011-11-03 17:13:26 UTC
Created attachment 53135 [details]
Sample spreadsheet showing the problem.

If you have a sum() across multiple sheets and at least one of the terms of the sum is set empty by "" (e.g. by an other formula), then the sum() formula don't work any more. If the field is really empty (nothing in it), then sum() works.

I tried this - and it's reproducable - with 3.4.x on Linux (Fedora 16) and Windows 7.

With LO 3.3.x and OOo 3.3.0 this formula works fine.
Comment 1 Marc Muehlfeld 2011-11-03 17:15:52 UTC
Created attachment 53136 [details]
Screenshot of the error
Comment 2 vitriol 2011-11-03 23:11:28 UTC

*** This bug has been marked as a duplicate of bug 37860 ***