Download it now!
Bug 42772 - Launch of Libreoffice 3.4.4 impossible after update from version 3.4.1
Summary: Launch of Libreoffice 3.4.4 impossible after update from version 3.4.1
Status: RESOLVED DUPLICATE of bug 38913
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-11-10 01:05 UTC by Rahaga RAHANDRAHA
Modified: 2012-09-05 08:45 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rahaga RAHANDRAHA 2011-11-10 01:05:27 UTC
Hello,

Having downloaded the released version 3.4.4 of Libreoffice Suite with the french help pack version, when trying to launch the programme, I systematically get the following message :

  Nom d’événement de problème:	BEX
  Nom de l’application:	soffice.bin
  Version de l’application:	3.4.402.500
  Horodatage de l’application:	4eb09214
  Nom du module par défaut:	MSVCR90.dll
  Version du module par défaut:	9.0.30729.6161
  Horodateur du module par défaut:	4dace5b9
  Décalage de l’exception:	0002e9f4
  Code de l’exception:	c0000417
  Données d’exception:	00000000
  Version du système:	6.1.7601.2.1.0.768.11
  Identificateur de paramètres régionaux:	1036
  Information supplémentaire n° 1:	70d5
  Information supplémentaire n° 2:	70d5762ff668ba7bf0e5139640d4fd2f
  Information supplémentaire n° 3:	9113
  Information supplémentaire n° 4:	9113cc9806ac09b5a84e7a6890b88824

Thank you in advance for correcting this probably little bug and for keeping me informed on the process to follow in order to get the Suite back to work.
Comment 1 Christian Ehrlicher 2011-11-12 01:06:47 UTC
I've exactly the same problem (with a slightly differeent msvcrt90 version) on Windows7 after upgrading from 3.4.3. Uninstall + Reinstall doesn't help either.
I'm using Windows 7, 64Bit
Comment 2 mrkahuna 2011-11-13 10:17:48 UTC
Same problem here on Win7 64-bit after upgrading from 3.4.3.  Uninstall/reinstall didn't work.
Comment 3 Christian Ehrlicher 2011-11-19 02:08:15 UTC
Here some news: When I remove all optional components all works fine again. Lokks like there's a problem between different ms visual studio runtime versions as it crashes somewhere deep inside msvcrt.dll ...
Comment 4 Petr Mladek 2011-11-22 04:12:56 UTC
Tor, Fridrich, do you have any idea what has changed between 3.4.3 and 3.4.4?

I wonder if it might be related to the fix building of the 64-bit Windows Explorer extension, bug 36950.

Rahaga, Christian, MrKahuna, does it help you to disable just the "Windows Explorer" extension?
Comment 5 Christian Ehrlicher 2011-11-25 06:15:15 UTC
No, that's not the problem. I have to remove all extensions under optional components except the python scripting to be able to start LO.
Comment 6 Don't use this account, use tml@iki.fi 2011-12-07 04:44:19 UTC
Unsurprisingly, was not able to reproduce, on (32-bit) XP. Will try 64-bit Windows 7, too.

Do we have any knowledge of exactly which extensions were installed in the 3.4.1 installations, and whether all the same then were installed also when installing 3.4.4? (In the case where the problem showed up.)
Comment 7 Don't use this account, use tml@iki.fi 2011-12-07 05:20:18 UTC
Could not reproduce on first try on 64-bit Windows 7 either (actually Windows Server 2008 R2).

Both on XP and WS2008R2 I used what I hope was a clean (virtual) machine, and a "typical" installation.
Comment 8 Don't use this account, use tml@iki.fi 2011-12-07 06:05:04 UTC
Could not reproduce on WS2008R2 with all optional components either.
Comment 9 Christian Ehrlicher 2011-12-07 08:46:57 UTC
@Tor: I've two systems upgraded from 3.4.x to 3.4.4 - on one system all works fine and on the other I've the problems described above. Both have the same configuration - Windows 7 64Bit. The only difference is that one system is a Home version and the other Enterprise... but I doubt that this really matters.
I also already tried to remove all msvcrt runtimes so both systems are equal - no chance... really strange thing.
Comment 10 Don't use this account, use tml@iki.fi 2011-12-07 09:01:44 UTC
Christian: Could there be bogus versions of msvcr90.dll (if that is what is causing problems; at least it is mentioned in the initial comment) somewhere in PATH on the problematic systems?

Would you people who have seen this problem say that your systems are ones where you (or somebody else) have been doing arbitrary "tricks" while trying to fix various problems in various software? Perhaps "tricks" that require administrator access, perhaps inspired by random more or less reliable advice found by googling? Like copying dlls here and there?
Comment 11 Petr Mladek 2011-12-22 02:22:13 UTC
The bug is not reproducible on other similar systems. It must be related to the particular system. Such bugs can't block the release => lowering severity.
Comment 12 aanno 2011-12-24 01:48:35 UTC
Sorry to say that I have exactly the same problem after update.
Comment 13 Colin Morris 2011-12-29 06:17:04 UTC
Hopefully my extensive IT support background will come in handy here.

I had the reported problem with installing 3.4.4 on Windows 7 64bit and resolved it by installing Java Runtime 6 32-bit version (I forgot I had uninstalled it previously months ago, to be honest!). 

The only way I found out what the problem might be was by attempting to install 3.3.4 after the failure of the new version. On first opening of newly installed 3.3.4, it gave all sorts of warnings about Java Runtime. On subsequent openings, it doesn't.

Before my initial attempts to install 3.4.4, I was trying to use the 'File Wizards - Letter' function in version 3.4.3 of Libreoffice writer and it kept crashing without a warning. I noticed after installing 3.3.4 this morning that not only does 3.3.4 warn you about Java Runtime on first opening, but when using 'File - Wizards - Letter' it also told you that the reason this functionality failed is that Java Runtime is not installed.

So basically, it looks like the problem with version 3.4.x of LibreOffice is that it doesn't handle missing Java Runtime errors either properly or at all.

Someone else with the problem want to try this out?

Colin.
Comment 14 Shelley Powers 2012-01-01 10:14:10 UTC
I also have this problem: just tried to upgrade from 3.4.1 to 3.4.4 and I can't launch LibreOffice Base. 

I have the version 7 Java Runtime, and really don't want to uninstall it to revert to an earlier version. 

I received the following errors:

Log Name:      Application
Source:        Application Error
Date:          1/1/2012 12:03:09 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Shelley-PC
Description:
Faulting application name: soffice.bin, version: 3.4.402.500, time stamp: 0x4eb09214
Faulting module name: MSVCR90.dll, version: 9.0.30729.6161, time stamp: 0x4dace5b9
Exception code: 0xc0000417
Fault offset: 0x0002e9f4
Faulting process id: 0xd58
Faulting application start time: 0x01ccc8af9dc27ad5
Faulting application path: C:\Program Files (x86)\LibreOffice 3.4\program\soffice.bin
Faulting module path: C:\windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57\MSVCR90.dll
Report Id: dc9af318-34a2-11e1-bfaf-60eb69875d15
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2012-01-01T18:03:09.000000000Z" />
    <EventRecordID>16208</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Shelley-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>soffice.bin</Data>
    <Data>3.4.402.500</Data>
    <Data>4eb09214</Data>
    <Data>MSVCR90.dll</Data>
    <Data>9.0.30729.6161</Data>
    <Data>4dace5b9</Data>
    <Data>c0000417</Data>
    <Data>0002e9f4</Data>
    <Data>d58</Data>
    <Data>01ccc8af9dc27ad5</Data>
    <Data>C:\Program Files (x86)\LibreOffice 3.4\program\soffice.bin</Data>
    <Data>C:\windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57\MSVCR90.dll</Data>
    <Data>dc9af318-34a2-11e1-bfaf-60eb69875d15</Data>
  </EventData>
</Event>
Comment 15 Shelley Powers 2012-01-01 10:15:45 UTC
Sorry, forgot to mention I'm also running Windows 7 64-bit Home.
Comment 16 pinebender 2012-01-06 10:29:04 UTC
I also had this same issue with the application crashing upon startup after upgrading to version 3.4.4. I was able to fix this by doing the following:

Uninstall Java 7 update 2
Install Java 6 update 30

After I removed Java 7 from the system and installed Java 6 the application opened with no problems whatsoever.

This system is running Windows Vista Ultimate SP2 (32-bit)
Comment 17 liam.kirsh 2012-02-17 00:22:56 UTC

*** This bug has been marked as a duplicate of bug 38913 ***
Comment 18 Stephan Bergmann 2012-09-05 08:45:18 UTC
Windows exception code c0000417 and offset 0002e9f4 in msvcr90.dll indicate this is a duplicate of Bug 38913.