Bug 42782 - improve cross-cultural appeal of image fallback
Summary: improve cross-cultural appeal of image fallback
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: difficultyBeginner, easyHack, skillCpp, topicCleanup
Depends on:
Blocks:
 
Reported: 2011-11-10 04:05 UTC by Michael Meeks
Modified: 2015-12-15 16:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2011-11-10 04:05:33 UTC
Our UI appears to include a dog image:

sw/source/ui/frmdlg/frmpage.src:    Bitmap BMP_EXAMPLE
sw/source/ui/frmdlg/frmpage.src-    {
sw/source/ui/frmdlg/frmpage.src-        File = "dog.bmp" ;
sw/source/ui/frmdlg/frmpage.src-    };

While I happen to like dogs, man's best friend etc. Some eg. Islamic cultures are highly allergic to such imagery. It is quite possible that this image is not used anyway.

So:

a) by git grep BMP_EXAMPLE

and unwinding the code, we need to work out if it is possible (somehow) to show this image in the UI. If we decide that it is not, we should just remove it.

b) as/when/if we find out what it is useful for; we should describe how that is shown, and ask the art team (libreoffice-ux-advise@lists.freedesktop.org) to create an alternative image (specifying it's context).

:-)
Comment 1 Björn Michaelsen 2011-11-15 15:35:20 UTC
The files:
 ./default_images/sw/res/dog.png
 ./ooo_custom_images/human/sw/res/dog.png
 ./ooo_custom_images/oxygen/sw/res/dog.png
 ./ooo_custom_images/hicontrast/sw/res/dog.png

should be removed along with the dog in the source.

I also wonder, were this is used in Writer -- maybe we have a "Microsoft Bob" implementation in it?
Comment 2 Stefan Knorr (astron) 2011-12-12 11:02:55 UTC
So, ... things I found out so far:
* the dog appears to be used as a replacement preview image (to demonstate flipping) in the dialogue that appears when right-clicking on an imported image, selecting Picture... and then going to the Picture tab.
* I could so far not trigger the appearance of the dog, whether I tried with corrupt or vector images.
* If the dog's appearance can indeed be triggered, the replacement image could be something like the image under [theme folder]/sd/res/image.png.
Comment 3 Eike Rathke 2011-12-14 15:03:29 UTC
The dog is displayed on the said Picture tabpage if you have a linked graphic image and the file linked to is gone.

Besides that I wouldn't argue with religious context, just that in different cultures the same animal may mean different things. It might also be something to eat ;-)

Using animals (or humans ...) as icons is a no-go in i18n context.
Comment 4 Julien Nabet 2011-12-14 22:48:46 UTC
Just for reminding, "Libre" means in French "Free" (like "Freedom").
So those who may be shoked by a simple image of a dog are free to use another software.
If not, we should care about removing images of :
- pigs
- black cats
 -snakes and spiders (some may have an heart attack by seeing them)
...
avoid to use words in docs like :
- bullet (cause it makes think to gun and we don't want violence)
..

In conclusion : I really hope to see "Resolved/wont fix" here.
Comment 5 Michael Meeks 2011-12-15 02:53:58 UTC
Hi Julien; so - we're also free (Libre) to make the software more friendly to people of other cultures :-) as for snakes, spiders etc. - I guess they belong in the clipart. Also - FWIW, this dog is really rather hard to trigger - but we've found a way to do that ;-)

On the other hand - this is a rather light hearted easy-hack (ie. it's not of vast significance, but is easy enough and can help get someone into the code) - so we're not investing tons of time into it.
Comment 6 Julien Nabet 2011-12-15 03:04:32 UTC
Hi Mike,

The problem is not the time to spend to resolve this.
The problem is that to be friendly, we have to do this.
I do not want to appear friendly to some talibans.
I wouldn't like a hijab to be added on a woman image of a clipart just to be friendly to someone.
Moreover, a dog even for some are useful for keeping herd or for defende oneself for muslims.

Come on, it's not even a Mahomet caricature !

Sorry if i take it very seriously but if this is done, I'll keep on to use LO because I still think it's a great soft and you all guys do a great job but i'll stop to contribute. (I know it won't even make a slight difference :-))

Julien
Comment 7 Michael Meeks 2011-12-15 04:17:32 UTC
Hi Julien,

So - I'd really like to talk to you on the phone about this; can you grab me on IRC ? Secondly this is really normal software industry practice we're talking about here for example:

http://dsc.sun.com/dev/gadc/technicalpublications/articles/archi18n.html
or
http://developer.apple.com/library/mac/#documentation/MacOSX/Conceptual/BPInternational/Articles/InternatAndLocaliz.html

"Icons and graphics (especially those containing culture-specific images) must be changed to be more culturally appropriate."

> The problem is that to be friendly, we have to do this. I do not want
> to appear friendly to some talibans.

So - I share your concern: that it is easy to go too far in this sort of thing - you give some examples of going too far :-) If we were adding clauses to our license to demand that all female users of the software do not use it for business use [ trying to make up some ridiculous pseudo-cultural stipulation here ] - then I'd be outraged along with you :-) in this case I couldn't care less. Can you even make your LibreOffice show that dog picture ? [ it takes quite some skill ].

Anyhow - I'd like to talk interactively on this - bugzilla is not the best place I feel.

ATB.
Comment 8 Michael Meeks 2011-12-16 01:58:35 UTC
de-easy hacking, and tweaking title to be less provocative to dog lovers.
Comment 9 Korrawit Pruegsanusak 2011-12-19 06:00:55 UTC
Stefan Knorr (astron) fixed this in master (3.6)
http://cgit.freedesktop.org/libreoffice/core/commit/?id=02c790620b63de3fb8d6dd63255444ff40aad34a
Comment 10 Michael Meeks 2011-12-19 08:25:53 UTC
Egad; I was going to close this wontfix and open a new, neutral bug around cleaning up the visual appeal of that image/ - but didn't get to it.

Apologies for that, and the rather inflammatory initial description.
Comment 11 Stefan Knorr (astron) 2011-12-19 09:41:52 UTC
Sorry for pushing that early (the patch was a bit of a work in progress, since I first wanted to find out about how to display the new image at actual size) – my git mastery's at fault here.
Comment 12 Michael Meeks 2011-12-20 04:35:10 UTC
Closed WONTFIX; it's successor lives on as bug#43976
Comment 13 Robinson Tryon (qubit) 2015-12-15 16:27:27 UTC
Migrating Whiteboard tags to Keywords: (EasyHack,DifficultyBeginner,SkillCpp,TopicCleanup)
[NinjaEdit]