Bug Hunting Session
Bug 42797 - FILEOPEN: XLSX with column chart & error bars not displayed properly
Summary: FILEOPEN: XLSX with column chart & error bars not displayed properly
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-10 12:41 UTC by smaybo
Modified: 2014-05-02 15:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
ZIP file containing excel spreadsheet with a chart that is not formatted properly in LOCalc and a PDF showing screenshots of how they appear in Excel 2007 via LibreOffice Calc 3.4.3 (194.09 KB, application/x-zip-compressed)
2011-11-10 12:41 UTC, smaybo
Details
Comparison of the chart in Excel 2010 and LibreOffice 4.1.1.2 (382.87 KB, image/jpeg)
2013-10-02 13:46 UTC, Zeki Bildirici
Details

Note You need to log in before you can comment on or make changes to this bug.
Description smaybo 2011-11-10 12:41:39 UTC
Created attachment 53380 [details]
ZIP file containing excel spreadsheet with a chart that is not formatted properly in LOCalc and a PDF showing screenshots of how they appear in Excel 2007 via LibreOffice Calc 3.4.3

Problem description: 

Steps to reproduce:
1. open attached spreadsheet (chart problem 1.xlsx)
2. view chart within spreadsheet in LibreOffice Calc
3. See diferrences in Excel 2007 vs LibreOffice Calc 3.4.3 in attached file (PDF)

Current behavior:

The issues on the LibreOffice image are circled in red and are..

1. multi-line titles come across to LibreOffice in a single line and the entire title cant be seen
2. the error bars are not taken into account when the Y axis is drawn (Excel is 0-3 and LibreOffice Calc is 0-2.5)
3. the issue above also cuts off the top half of the highest error bar from being visible
4. the legend item labels of "treated/untreated" in Excel are ignored in LibreOffice (the cell data is used instead of the label that can be set)

Expected behavior:

1. proper format of title, error bars, y-axis and legend

Platform (if different from the browser): 
              
Browser: ANY
 LibreOffice 3.4  340m1(Build:302) running on Ubuntu 10.10, i686
Comment 1 tester8 2011-11-11 13:57:38 UTC
totally Reproduced with

LO 3.4.4
Ubuntu 10.04.3 x86
Linux 2.6.32-34-generic Russian UI

Please, stop post your browser info; it is not needed until you have a deal with a site bug.
Comment 2 Tom Williams 2013-05-04 22:31:19 UTC
I just viewed your test case in LibreOffice 4.0.3.2 (rc2) on Ubuntu Linux 13.04 (64-bit) and the title is fully visible, but still on one line. Also the "treated/untreated" legend titles do appear.  The error bar issue still remains and the bars didn't appear in full color, for whatever reason.
Comment 3 ign_christian 2013-06-11 07:51:39 UTC
I can confirm same behavior same as Tom, (LO 4.0.4.1 - Win7 32bit)
Comment 4 Zeki Bildirici 2013-10-02 13:46:57 UTC
Created attachment 86966 [details]
Comparison of the chart in Excel 2010 and LibreOffice 4.1.1.2

Checked with LibreOffice 4.1.1.2(portable) Not better than previous ones. Also the color is missing now. untreaded and treated has now come and title borders are better but still the tile level is cut by 2,5.

You may see the difference in screenshot, Excel 2010 vs LibreOffice 4.1.1.2(portable)

Best regards,
Zeki
Comment 5 ign_christian 2013-10-03 02:33:14 UTC
You're right Zeki, I also saw same result with LO 4.0.6.1 (Win7 32bit).
I think we should move this bug to component: Chart.

Summary of the chart problem:
- Legend appears correctly : SOLVED
- Chart title in a single line
- Y error bars misplaced in Positive (+) Parameters
- Wrong Y axis
- Wrong area fill : REGRESSION from LO 3.4.4 (comment 1)
Comment 6 Xisco Faulí 2014-03-31 16:13:45 UTC
This issue is still reproducible with:
   - Libreoffice 4.1.5.3 Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24
   - Libreoffice 4.2.2.1 Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f
   - Libreoffice 4.3.0.0.alpha0 Build ID: b6a43bcbbf9e9a5655fd36fd4c8ef72d585f67b0
Comment 7 Markus Mohrhard 2014-04-05 17:02:36 UTC
Please split that bug report into several ones each dealing with exactly one problem.
Comment 8 tommy27 2014-05-02 15:23:44 UTC
as Markus said this report is a collection of different problems.

I mark this as INVALID since the policy is to have a single issue described per report.

so please check each still reproducible issue, query Bugzilla to see if it has not yet reported then open new separate reports.
Comment 9 tommy27 2014-05-02 15:30:31 UTC
you can also file new single bugs in this meta-bug:
https://bugs.freedesktop.org/show_bug.cgi?id=75057