Bug 42879 - Number from custom Lists Style not shown in custom Outline style from ODT created in Calligra until cleared direct formatting
Summary: Number from custom Lists Style not shown in custom Outline style from ODT cre...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chapter-Numbering
  Show dependency treegraph
 
Reported: 2011-11-13 09:24 UTC by Gopalakrishna Bhat
Modified: 2019-12-27 19:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document showing the problem (4.82 KB, application/vnd.sun.xml.writer)
2011-11-13 09:24 UTC, Gopalakrishna Bhat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gopalakrishna Bhat 2011-11-13 09:24:30 UTC
Created attachment 53478 [details]
Sample document showing the problem

Create a document with outline levels in Calligra Words and open that in LibreOffice. We find that the outline numbers are not shown. Attached is a document created in Calligra Words having the problem
Comment 1 sasha.libreoffice 2012-04-20 05:13:46 UTC
Thanks for bugreport
What site http://odf-validator.rhcloud.com/ tells about attached file:

list101.odt/META-INF/manifest.xml: Warning: The directory 'Thumbnails/' is not a sub-document and should not be listed in the 'META-INF/manifest.xml' file of ODF package 'list101.odt'!

list101.odt/styles.xml[99,109]: Error: attribute "style:name" has a bad value: "Numbering Style for Head 11" does not satisfy the "NCName" type

list101.odt/styles.xml[113,254]: Error: unexpected attribute "text:note-continuation-notice-forward"

list101.odt/content.xml[18,75]: Error: element "text:h" is missing "id" attribute
---end of citation---

PS: msOffice 2007 opens attached file correctly.
Comment 2 Joel Madero 2012-09-07 20:25:46 UTC
Confirmed. Marking as NEW, setting Priority, changing title as it's not a FILEOPEN issue.

Set as Minor (makes it somewhat harder to make professional quality work if using both Calligra and LO) and Low because I doubt this affects many users.
Comment 3 Joel Madero 2012-09-07 20:25:59 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2015-01-05 17:51:43 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-01-23 16:24:30 UTC
Reproduced.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 07e84cae983c08afdba03018413a19d01abb3006
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-19_06:15:38
Comment 6 QA Administrators 2016-02-21 08:36:00 UTC Comment hidden (obsolete)
Comment 7 Timur 2018-01-04 14:11:37 UTC
Repro with 6.1+. 
If Head 1 is cleared from direct formatting, then numbering appears.
Comment 8 QA Administrators 2019-01-05 03:41:25 UTC Comment hidden (obsolete)
Comment 9 sdc.blanco 2019-12-27 19:18:33 UTC
Should this bug still be open?  As I understand the problem, a program from 2011 has produced a document that does not behave as expected in LO.

In comment #7, it was noted that the problem was "resolved" by Clearing Direct Formatting.  

But notice this alternative procedure.

1.  Open the attachment.
2.  Place cursor on first line (Head1) (same story for third line with Head2)
3.  Format > Paragraph 
4.  Notice that "Numbering Style" is "None"
5.  View > Styles (F11)  (Right-click on "Head 1"- Modify)
6.  Notice that "Numbering Style" is "Numbering Style for Head 1"
7.  Apply the style "Head 1" to the first line (even though it appears that this is the applied style (e.g., use drop-down box in Toolbar and Choose "Head 1" -- even though it is already selected, or double-click on "Head 1" in Styles window)

Result:  Expected behavior is observed.

Explanations: 

As the procedure here showed, the attached document did not have the right numbering style for the paragraph style.

The comment #7 procedure of clearing direct formatting is functionally equivalent to (re-)applying the "Head 1" style. 

If the problem is that Calligra has not produced an adequate document then I would say "NOTOURBUG"



There does not
Comment 10 Buovjaga 2019-12-27 19:21:04 UTC
You are right, let's close