Bug 42915 - Date category axis with missing category values interpreted as zero date
Summary: Date category axis with missing category values interpreted as zero date
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: Other All
: lowest normal
Assignee: Markus Mohrhard
URL:
Whiteboard: BSA target:6.3.0 target:6.2.0.1 targe...
Keywords: preBibisect, regression
Depends on:
Blocks:
 
Reported: 2011-11-14 04:38 UTC by jkonecny
Modified: 2018-12-03 10:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Excel spreadsheet to demonstrate problem. (37.00 KB, application/vnd.ms-excel)
2011-11-14 04:38 UTC, jkonecny
Details
Chart as displayed in LO (70.72 KB, image/jpeg)
2011-11-14 04:39 UTC, jkonecny
Details
Chart as displayed in Excel (107.97 KB, image/jpeg)
2011-11-14 04:40 UTC, jkonecny
Details
Simpler reproducer based on ODS (13.28 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-11-29 11:36 UTC, Markus Mohrhard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jkonecny 2011-11-14 04:38:31 UTC
Created attachment 53518 [details]
Excel spreadsheet to demonstrate problem.

Problem description: 

Steps to reproduce:
1. View attached spreadsheet in LO 3.4.4
2. View attached spreadsheet in Excel or Excel viewer
3. Note massive differences in chart on "GRAPH" sheet

Current behavior:  Chart displays incorrectly

Expected behavior:  I expected the chart to look the same in LO as it does in Excel.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Comment 1 jkonecny 2011-11-14 04:39:23 UTC
Created attachment 53519 [details]
Chart as displayed in LO
Comment 2 jkonecny 2011-11-14 04:40:00 UTC
Created attachment 53520 [details]
Chart as displayed in Excel
Comment 3 tester8 2012-01-08 08:15:06 UTC
Reproduced with

LOdev 3.5.0beta2 
4ca392c-760cc4d-f39cf3d-1b2857e-60db978
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI
Comment 4 jkonecny 2012-02-15 09:16:07 UTC Comment hidden (obsolete)
Comment 5 jkonecny 2012-03-26 07:48:15 UTC Comment hidden (obsolete)
Comment 6 jkonecny 2012-11-02 12:29:18 UTC
reproduced in 3.6.3.2
Comment 7 Alexandr 2014-07-21 13:02:15 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2015-09-04 02:48:49 UTC Comment hidden (obsolete)
Comment 9 Alexandr 2015-09-19 17:20:56 UTC
Reproducible with LibreOffice 5.0.1 on Debian.
Comment 10 Robinson Tryon (qubit) 2015-12-09 16:40:16 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2017-01-03 19:43:31 UTC Comment hidden (obsolete)
Comment 12 eisa01 2018-06-16 18:11:07 UTC
This is still present

The lines in the chart actually renders somehow in LO 3.3, but I can't select the chart and it's not identical to Excel either

Version: 6.2.0.0.alpha0+
Build ID: b292a27698e85fd9d60c03613c3b0c67835c4dc1
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-06-06_23:25:55
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 13 Timur 2018-08-15 18:03:36 UTC Comment hidden (obsolete)
Comment 14 Xisco Faulí 2018-08-16 08:14:33 UTC
(In reply to Timur from comment #13)
> Sorry for turning this to NeedInfo but: when I try to open with Excel, I get
> warning "File Error: data may have been lost" and a lot of #DIV/0!. 
> Could someone create minimal correct XLS/X and then reproduce LO bug?

No problem here with MSO 2010. Which version are you using ??

btw, the problem is still reproducible in


Version: 6.2.0.0.alpha0+
Build ID: 1af7f19224f18e5025352339648db659575eae33
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

and

LibreOffice 3.5.0 
Build ID: d6cde02

but not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 15 Timur 2018-08-16 11:53:13 UTC
(In reply to Xisco Faulí from comment #14)
>> (In reply to Timur from comment #13)
>> with Excel, I get warning "File Error: data may have been lost"
> No problem here with MSO 2010. Which version are you using ??
MSO 2013.
But let's disregard error message, because MSO still shows the chart and MSO saved xlsx doesn't have it. 
We still need to pinpoint the cause of wrong LO rendering. Lines are wrong while points are correct.
Comment 16 Markus Mohrhard 2018-11-29 11:34:51 UTC
The issue is not an import issue and unrelated to the XLS filter. I'll attach a simple reproducer based on an ODS file.
Comment 17 Markus Mohrhard 2018-11-29 11:36:40 UTC
Created attachment 147136 [details]
Simpler reproducer based on ODS
Comment 18 Commit Notification 2018-11-29 22:32:56 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/33c0a64650646fc542a104f025abbf30d1b7628f%5E%21

tdf#42915, NaN in a date axis can destroy the whole chart

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2018-11-29 22:33:03 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b937c6deb2e5610c26dc7082fcdbb0f4835ecd99%5E%21

related tdf#42915, pass NaN through date transformation

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2018-11-30 12:18:56 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/55c5382591305a872b961d54571e3c823728ccb2%5E%21

tdf#42915, NaN in a date axis can destroy the whole chart

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2018-12-03 10:25:27 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/0a906dc78b575d696d402fb81900700e6e8e761e%5E%21

tdf#42915, NaN in a date axis can destroy the whole chart

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.