Bug Hunting Session
Bug 42929 - EDITING: Issue with language flagging, custom locale keyboard
Summary: EDITING: Issue with language flagging, custom locale keyboard
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-14 11:52 UTC by Jeremy Brown
Modified: 2016-09-19 16:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Zip file containing custom locale and custom keyboard for Windows Vista/7 for the ebo-CG language (Teke-Eboo) (433.91 KB, application/zip)
2011-11-14 11:52 UTC, Jeremy Brown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Brown 2011-11-14 11:52:35 UTC
Created attachment 53554 [details]
Zip file containing custom locale and custom keyboard for Windows Vista/7 for the ebo-CG language (Teke-Eboo)

Problem description:

This may be a feature request and not a bug report.

I recently created a spell check dictionary for the ebo-CG language. LibreOffice developers were kind enough to add the ebo-CG language to the list of spell check languages, so I can actually use it. Thanks!

My problem came when I started testing the spell check dictionary in LibreOffice. I have used Microsoft's Locale Builder to create a custom locale for ebo-CG, and I have used Microsoft's Keyboard Layout Creator to create a keyboard for that locale as well.

However, when I create a text document in LibreOffice, choose my ebo-CG keyboard, and start typing, it creates text flagged as being in the "Unknown" language, instead of Teke-Eboo (ebo-CG).

I don't know if this is a problem with the custom locale not reporting the correct information to LibreOffice, or what.

It would be great if LibreOffice could detect even custom locale information like mine and set the text correctly.

As an additional request, which is definitely a feature request, it would be great if LibreOffice could have fallback functionality to enable spell check and language flagging in any of the 3-code ISO639-3 language codes found at ethnologue.org. Even if LibreOffice couldn't display the language name etc., if it could still flag the entered text as being, for example, "ebo-CG" (even if it doesn't really know what that language is). And it would be great if you could enable spell check for language codes, even if LibreOffice doesn't know what they are.

The organization I work for, among other things, creates dictionaries for lots of minority languages that aren't in ISO639-1 or ISO639-2. It would be great if we could create custom locales & have LibreOffice enter the text while recording the 3 letter ISO639-3 code (even without giving a pretty language name). And to be able to create spell check dictionaries for them, without having to bug LibreOffice developers every time we want to add a new language. Since there are actually over 6000 languages in the world, the long term question is if you want a language selection list that is almost 7000 items long.

Steps to reproduce:
1. Use Microsoft Locale Builder to create a locale using an ISO639-3 code for a language that does not exist in ISO639-3 but which is in the LibreOffice spell check language list (e.g. ebo-CG)
2. Install the custom locale.
3. Use the Microsoft Keyboard Layout Creator to create a keyboard for that locale.
4. Install the custom keyboard.
5. Create a new text document in LibreOffice.
6. Use the Microsoft Language Bar and select the keyboard created in step 3.
7. Enter text in LibreOffice.
8. The text will be flagged as "Unknown" instead of "Teke-Eboo".

Current behavior:
The text entered with an ebo-CG keyboard is not flagged as being ebo-CG (Teke-Eboo) in LibreOffice. It is instead flagged as being "Unknown".

Expected behavior:
The text entered with an ebo-CG keyboard should be flagged as Teke-Eboo, since this is a language that can be set in LibreOffice.

Platform (if different from the browser): 
Windows Vista
Windows 7
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0
Comment 1 Michael Meeks 2013-05-21 10:02:28 UTC
Eike - any chance you could help confirm this ? one of our two Need_Advice bugs ? :-)
Comment 2 Urmas 2013-05-21 18:28:28 UTC
I believe it is not possible to detect which custom locale is used for text entry, as they all share the same LCID.
Comment 3 Jeremy Brown 2013-05-21 19:35:26 UTC
There is now a work-around to this problem.

There's a new checkbox option in 4.0 (see Bug 36324 ) that helps with this problem. (Options -> Language Settings -> Languages -> [] Ignore system input language). Now the user can select the language they want for a run of text, and if this box is checked, LibreOffice will completely ignore the locale info coming from the MS keyboard.

This means that even if LibreOffice can't detect the custom locale, the user is still able to enter text in their chosen language without it being changed to "Unknown" or some other language they don't want.
Comment 4 Robinson Tryon (qubit) 2013-10-23 18:41:20 UTC Comment hidden (obsolete)
Comment 5 Eike Rathke 2013-10-24 01:16:52 UTC
I was about to remove Need_Advice from whiteboard as comment 2 pointed out the cause, a custom locale in Windows gets a static LCID assigned that just says "this is a custom locale". However, I've no idea if Windows provides any means to figure out what the actual locale is, language tag wise (for which I could add Need_Advice again and therefor leave it in ;-)

The situation does not per chance change with a recent build from current master? See http://dev-builds.libreoffice.org/daily/master/
Comment 6 Robinson Tryon (qubit) 2013-11-18 18:06:48 UTC
(In reply to comment #5)
> 
> The situation does not per chance change with a recent build from current
> master? See http://dev-builds.libreoffice.org/daily/master/

Eike - Would it be helpful for OP/QA to do additional testing, or is this something that the devs need to tackle?
Comment 7 Eike Rathke 2013-11-25 11:23:01 UTC
It could be tested whether the problem still exists in master/4.2 or not, with all the BCP 47 rework, or how it manifests now. However, obtaining some info for a custom locale maybe could be implemented, I don't know the Windows API (yet?).
Comment 8 Robinson Tryon (qubit) 2014-02-03 20:26:38 UTC
(In reply to comment #7)
> It could be tested whether the problem still exists in master/4.2 or not,
> with all the BCP 47 rework, or how it manifests now.

Jeremy - Could you please re-test and confirm that this bug is present in 4.2.0 final or in a daily build of master?

Thanks!
Comment 9 QA Administrators 2014-09-03 21:32:35 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2014-10-05 22:59:46 UTC Comment hidden (obsolete)
Comment 11 Robinson Tryon (qubit) 2015-12-18 10:24:09 UTC Comment hidden (obsolete)
Comment 12 Xisco Faulí 2016-09-19 16:47:55 UTC Comment hidden (obsolete)