Bug 42935 - Ease to open spelling options while editing a document with no misspelled words.
Summary: Ease to open spelling options while editing a document with no misspelled words.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: low enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
: 48021 62345 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-14 16:20 UTC by hakim.cassimally
Modified: 2016-05-20 09:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hakim.cassimally 2011-11-14 16:20:28 UTC
To open spelling options, you normally choose:

  Tools -> Spelling and Grammar... -> Options...

When there are no misspelt words in the document, as soon as you've invoked "Spelling and Grammar..." a modal popup appears over the usual dialog, with "The spellcheck is complete..."  As it's modal, you can't click on "Options...", and the dialog disappears when you click OK.

The workaround then, to access the spelling options for a document, is to kludge by first inputting a misspelt word.  This is counter-intuitive.

<parenthesis>
There doesn't seem to be another obvious way to get to Spelling options:

   LibreOffice -> Preferences... -> LibreOffice? / LibreOffice Writer? -> ...?

Also, the menu invoked by clicking on the Language name in the status bar doesn't offer a shortcut to spelling options either)
</parenthesis>
Comment 1 Rainer Bielefeld Retired 2011-11-14 23:17:22 UTC
@reporter
Menu 'Tools -> Options -> Language Settings -> Writing Aids' is not appropriate for your needs?
Comment 2 hakim.cassimally 2011-11-15 01:36:17 UTC
@Rainer: ah ok (Preferences Menu) -> Language Settings -> Writing Aids does indeed have the spelling options (in a different layout), thanks.

This is still a usability bug though: 

1) if you know that spelling options are *usually* accessed through Tools -> Spelling & Grammar..., it is perverse to sometimes hide this info.

2)  as per original report, I looked under Preferences for either a) the component I was using "LibreOffice Writer", or general settings "LibreOffice".  

I don't remember if I thought of checking if there were other top-level options (that were, for some bizarre reason, not under "LibreOffice"), and clicked through to "Language Settings".

Even if I *had* clicked to Language Settings, I'm not sure that "Writing Aids" makes me think of "Spelling" (which is what it means).

And even if I *had* clicked on Writing Aids, the fact that it's in an entirely different layout to the dialog I was expecting, and starts with a list of supported languages, I might have discounted it.

(Bearing in mind that when you're frantically looking for an option, you tend to ge a little one-track-minded about it!)

Thanks again, H
Comment 3 hakim.cassimally 2011-11-25 04:35:40 UTC
Apologies - not sure if I was meant to revert status back from "NEEDINFO"?  I've taken liberty of setting back to "UNCONFIRMED".  Hope that's OK, and please re-set if not!
Comment 4 Rainer Bielefeld Retired 2011-11-25 07:41:41 UTC
I believe a second button in the "Spellcheck conmplete" message might do the job?
Currently we only have <ok>, when you click it the Spellcheck dialog disappears.
A second Button <Settings> or similar that opens a spellcheck options dialog would ease handling.
Comment 5 Urmas 2013-09-01 06:05:52 UTC
*** Bug 48021 has been marked as a duplicate of this bug. ***
Comment 6 Brenda Granados 2013-09-21 12:55:49 UTC
*** Bug 62345 has been marked as a duplicate of this bug. ***
Comment 7 Kumāra 2013-09-23 08:21:15 UTC
(In reply to comment #4)
> I believe a second button in the "Spellcheck conmplete" message might do the
> job?
> Currently we only have <ok>, when you click it the Spellcheck dialog
> disappears.
> A second Button <Settings> or similar that opens a spellcheck options dialog
> would ease handling.

Agree. Alternately: Add Tools - Spelling and Grammar Options...

It's so deep in Options that people may not find it. If they do, it's indeed annoying for people who need to access it frequently. Typing a non-word to get at it is much faster!
Comment 8 Adolfo Jayme 2016-05-19 19:38:31 UTC
WORKSFORME in LibreOffice 5.1. If I open the Spelling dialog with no misspelled words, after the “Spellcheck complete” message I can click around the spelling options since the dialog is no longer closed automatically.
Comment 9 Kumāra 2016-05-20 04:13:01 UTC
I believe FIXED is a more suitable status, though it's better to also indicate into to that.
Comment 10 Kumāra 2016-05-20 04:35:00 UTC
(In reply to Kumāra from comment #9)
> I believe FIXED is a more suitable status, though it's better to also
> indicate into to that.

Oops... I;m not sure what happened. I mean indicate the bug fix to that.
Comment 11 Adolfo Jayme 2016-05-20 09:34:31 UTC
You only change to FIXED when you identify a related commit. You don’t, the correct status is WORKSFORME. Whatever 🙄, here it is: http://cgit.freedesktop.org/libreoffice/core/commit/?id=ae20b8147307de84318598be72977abc3f7bdda9