Bug Hunting Session
Bug 42939 - SVG Export ignores line width
Summary: SVG Export ignores line width
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.0.4
Keywords: regression
: 56433 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2011-11-14 22:30 UTC by Rainer Bielefeld Retired
Modified: 2013-07-15 13:23 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Test kit Comparing results in 3.4.4 and Master (472.31 KB, application/x-zip-compressed)
2011-11-14 22:30 UTC, Rainer Bielefeld Retired
Details
Similar results on Firefox 8.0 in OSX (348.02 KB, application/zip)
2011-11-15 02:48 UTC, rk601
Details
Screenshot of circle.odg from MasterTest but grey line's width modified to 0.001cm and back to 0.01cm. (99.27 KB, image/png)
2012-03-22 06:58 UTC, Christina Rossmanith
Details
New simplyfied test kit (37.94 KB, application/x-7z-compressed)
2012-08-12 15:31 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-11-14 22:30:09 UTC
Created attachment 53565 [details]
Test kit Comparing results in 3.4.4 and Master

Steps to reproduce with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) German UI [(Build ID:  6b0de40-0bc4ff4-ca7e6f5-9125509-ce71330)]" (111111):

0. Download and unzip attached "SVGSCALETestkit.zip", go to
   folder
1. Open "circle.odg"
2. Select all, Export to "circle1.svg" (does not matter whether
   you check "selection" or not
3. Open "circle1.svg in Web Browser or similar
   Expected: looks like in DRAW
   Actual: Ruler lines much too thick, blue circle border much
           too thin (See "Screenshots.PDF"). You should see same
           result with my "circle1.svg"

Works fine with "LibreOffice 3.4.4  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:402)]", so REGRESSION

Further tests showedlots of other problems, I will submit additional bugs referring to this test kit.
              
Browser I usd for the Test: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20110928 Firefox/7.0.1 SeaMonkey/2.4.1

@rk601@yahoo.com:
I see you very active in SVG questions, can you please try to confirm my observations?
Comment 1 Rainer Bielefeld Retired 2011-11-14 22:32:13 UTC
Addition to step 0: go to folder _MasterTests_

- Reported with Bug Submission Assistant -
Comment 2 rk601 2011-11-15 02:48:40 UTC
Created attachment 53568 [details]
Similar results on Firefox 8.0 in OSX

We have found similar results.

As an example, we tested the desired functionality in the Master:

LibO-dev 3.5.0 
Build ID: a7553b2-533e3c6-ca7e6f5-9125509
On OSX 10.6.8

Located at:

http://dev-builds.libreoffice.org/daily/MacOSX_10.6.7_Intel_no-moz/master~2011-11-13_01.04.10/

with

master~2011-11-13_01.04.10_LibO-Dev_OOO350m1_MacOS_x86_install_en-US.dmg

Steps to reproduce:

1. Download and unzip attached "SVGSCALETestkit.zip", go to
   folder
2. Open "344Tests-circle" and "MasterTests-circle", respectively
3. Select all, Export to "344Tests-circle-OSX.svg" and "MasterTests-circle-OSX.svg" (does not matter whether you check "selection" or not
4. Open "344Tests-circle-OSX.svg" and "MasterTests-circle-OSX.svg" in Web Browser or similar
   Expected: SVG should like the same
   Actual: Ruler lines much too thick, blue circle border much
           too thin (See "Screenshots.PDF").

Browser used for the Test: Firefox: Mozilla/8.0 (OSX 10.6.8)

See attachment "circle tests on OSX.zip" for sample documents and screenshots.
Comment 3 Thomas Hackert 2012-01-21 01:55:18 UTC
Hello Rainer, *,
I can confirm this behaviour with LO 3.5.0-RC1 under Debian Testing AMD64 ... :( As rk601 has confirmed it with MacOS too, I change the platform to all and the status to new.
HTH
Thomas.
Comment 4 Christina Rossmanith 2012-03-22 06:55:15 UTC
The problem can be solved if "stroke-width" with an appropriate value is added to the paths. 1cm equals 1200 units in circle.svg, thus the circle border (0.1cm) needs stroke-width="120" added and the grey lines stroke-width="12". 

The result then still looks different from the odg original (grey lines too wide). BUT if you change line thickness of a single grey line in the odg from 0.01cm to something different and back to 0.01cm that line width is like in the exported svg (cf. attachment circle_work.odg)
Comment 5 Christina Rossmanith 2012-03-22 06:58:04 UTC
Created attachment 58870 [details]
Screenshot of circle.odg from MasterTest but grey line's width modified to 0.001cm and back to 0.01cm.
Comment 6 Rainer Bielefeld Retired 2012-08-12 15:29:12 UTC
I attach a new sample showing the problem in a more simple way. 

In test kit "NewSample.7z" "sample.odg" shows concentric circles and line parts all with different line widths.
In Export from "samplefrom3604.svg" all lines have the same width.
That's also visible in export from 3.5.6.2, but worked fine with 3.4.5

Still [Reproducible] with parallel installation of Master "LOdev  3.7.0.0.alpha0+   - WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 7d8cd0a]" (tinderbox: 2008R2@20, pull time 2012-08-10 23:27:17)
Comment 7 Rainer Bielefeld Retired 2012-08-12 15:31:30 UTC
Created attachment 65473 [details]
New simplyfied test kit

New test kit as announced in comment before

@Thorsten:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf.
Comment 8 Rainer Bielefeld Retired 2012-08-12 15:38:15 UTC
Already [Reproducible] with "LibreOffice 3.5.1.2 German UI/Locale [Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66] on German WIN7 Home Premium (64bit)
Comment 9 Michael Meeks 2012-08-13 10:21:48 UTC
Christina - any thoughts on adding stroke-width attributes ? or a patch here ? it seems to have become a most-annoying-bug somehow :-)
Comment 10 Jorendc 2013-02-12 20:00:39 UTC
I still can reproduce using Linux Mint 14 x64 LibreOffice Version 4.1.0.0.alpha0+ (Build ID: cbc722733bb272b0f26efec09b478bed9a3cdb9).

@Rainer: I'm not convinced this is a MAB... we need to 'clear' the 3.5 list, therefore I remove it for now from the 3.5. I tend not to mark it as a mab3.6... Are you still convinced this is a mab? If so, we can place it on the mab3.6.

Kind regards,
Joren
Comment 11 Michael Meeks 2013-04-25 12:49:12 UTC
It seems I fixed this in master a while back - I just pushed that to gerrit for review for -4-0.
Comment 12 Michael Meeks 2013-04-25 12:55:31 UTC
And that just got pushed to -4-0 so fixed - should be in the next 4.0.x (is that 4.0.4 ?)
Comment 13 Commit Notification 2013-04-25 13:00:04 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b2d1cd9873995b93577273ad8b3fb7fd4230ced9&h=libreoffice-4-0

fdo#42939 - write svg line widths for META_POLYLINE_ACTION.


It will be available in LibreOffice 4.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 ign_christian 2013-07-15 13:23:45 UTC
*** Bug 56433 has been marked as a duplicate of this bug. ***