Bug 42952 - FILESAVE: Mac Open-Save Dialogs--Tries to Connect to Servers
Summary: FILESAVE: Mac Open-Save Dialogs--Tries to Connect to Servers
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-15 09:51 UTC by noibsguy
Modified: 2013-08-11 15:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Warning message server can't be found (218.78 KB, image/jpeg)
2011-11-15 09:51 UTC, noibsguy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description noibsguy 2011-11-15 09:51:19 UTC
Created attachment 53581 [details]
Warning message server can't be found

This is a very specific issue that only relates to the Mac version of LibreOffice and ONLY when preferences are set to use Mac Open/Save dialog boxes.  This issue has been present for several versions of LO.

I often have two Samba servers on my Mac desktop.  I do not and have not written directly to them from LO and I haven't opened any files on them from LO.

If I save a LO file that's open on my Mac back to Mac while the servers on simply on my desktop, then the next time that I do a "Save as..." with respect to that file, LO will automatically remount those two servers if they are available and can be mounted.  If I'm at home, those servers are not available on my local network and in that case, LO will display messages (while the Save as... dialog box is open) saying that it cannot connect to the servers--one message each for each server.  A screen snapshot of that is attached.

If I choose to use LO open/save boxes instead of Mac OS X open/save boxes, that doesn't happen.  Also, if I've previously saved a LO document when there weren't any servers mounted on my desktop, then this issue doesn't present itself.

What I've tried (unsuccessfully):

• Deleted entire LO folder within Users/myusername/Library/Application Support and then restarted LO so that it will build a new folder in Application Support
• Saved offending documents at Excel and then opened new Excel file in LO and resaved as LO
• General Mac System Preferences set to remember zero connected servers
• Don't have my computer listed in my Finder sidebar, thus, it doesn't appear in any open/save Mac dialog boxes. 

And, to reiterate, this problem doesn't exist if native LO open/save dialog boxes are used.  I've never had this problem using any other software.

I think (but not sure) that this problem started when I updated to Mac OS X 10.7.  I'm currently at 10.7.1 and using the latest full release of LO.
Comment 1 sasha.libreoffice 2012-04-20 07:03:33 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible

And it happens only if Samba server is up? If down then not happens?
Comment 2 noibsguy 2012-04-20 07:25:26 UTC
Sorry.  I had forgotton about this bug submission.  I have some additional information that will help.

I had an Mac OS X alias to an SMB server among a list of folders that contain most of my LibreOffice documents.  Thus, when I accessed either an open or save dialog box in LibreOffice, that alias would be visible in the list of folders that I would be accessing.  At that point, LibreOffice would mount that server on the desktop.  Understand that simply having that alias file in the open/save dialog box would prompt the server to mount--I didn't have to click on it.

And, if I set my LO preferences to use native open/save dialog boxes (instead of the Mac OS X version), this didn't happen.  Further, no Mac application that I own will mount a server just because an alias to that server appears in an open or save dialog box.

Also, the question as to what happens if the server is not available:  A message is displayed saying that "There as a problem connecting to the <name of server> server."

My workaround is not to have an alias to a server within a directory that I'm likely to access from a LO open or save dialog box.
Comment 3 sasha.libreoffice 2012-04-20 07:34:52 UTC
Thanks for additional information
Comment 4 solecism 2012-06-20 11:38:56 UTC
I'm experiencing the same problem as the initial poster; when using the mac-native file dialogs, I'm continually prompted for credentials to mount SMB volumes that I've used in the past, even if not recently and, even though I haven't navigated to them nor yet selected a file in the dialog.

I noticed this in Impress, under OS X 10.6.8 
LibreOffice 3.5.4.2
Build ID: 165a79a-7059095-e13bb37-fef39a4-9503d18

Turning off the native file dialogs in the preferences (checking the 'Use LibreOffice Dialogs' option) is a viable workaround for now.
Comment 5 noibsguy 2012-06-20 15:26:17 UTC
I'm the creater of this bug report.  Let me condense the bug description:  If "Use LibreOffice Dialogs" is NOT checked in the preferences, LO will use the native Mac OS X open/save dialogue boxes.  If there is an alias to a server or file on a server within the directory path that is likely to be accessed within LO, LO will attempt to resolve that alias by mounting the server on the desktop when the open/save dialogue box appears.  This should not happen unless one were to actually click on that alias.

I think it's clearly a bug, but it's easy to avoid by careful placement of aliases to servers or by not using the native Mac dialogue boxes.
Comment 6 Alex Thurgood 2012-06-21 03:14:20 UTC
I haven't seen this on OSX 10.6.8 with any version of LO yet, so it would appear to be Lion specific.


Alex
Comment 7 Alex Thurgood 2012-06-21 03:17:11 UTC
(In reply to comment #6)
> I haven't seen this on OSX 10.6.8 with any version of LO yet, so it would
> appear to be Lion specific.
> 
> 
> Alex

Hmm, but I'm not using any SMB mounts, to that might be the difference between my experience and Comment #4
Comment 8 Joel Madero 2013-05-15 04:46:28 UTC
@Joren - another one of those fun OSX ones, you mind testing it out?
Comment 9 Alex Thurgood 2013-05-15 07:03:17 UTC
All,

I'll see if I can reproduce with a "SMB-only" connection to my OSX server, but I'll have to fiddle around with the settings as I'm currently using AFS and SMB (as a fallback), and that combination doesn't cause the problem mentioned here. 




Alex
Comment 10 Jorendc 2013-05-15 12:55:43 UTC
(In reply to comment #8)
> @Joren - another one of those fun OSX ones, you mind testing it out?

I don't have any server here ... so can't test this one.
Comment 11 Alex Thurgood 2013-05-23 15:38:35 UTC
Hmm, the server share automount function seems to be a feature of OSX 10.7 and later. I see it for example on OSX 10.8.3 with AFP shares, and even with aliases, and I actually like this feature, because it means you don't get the annoying crash that used to occur and has been noted separately here :

https://bugs.freedesktop.org/show_bug.cgi?id=37666

Alex
Comment 12 Alex Thurgood 2013-05-23 15:43:33 UTC
For me, the behaviour reported is normal system behaviour for OSX => 10.7, isn't it ?


Alex
Comment 13 Alex Thurgood 2013-05-23 16:57:09 UTC
The following discussions would seem to point to OSX's Finder and mount system as the culprit of mount woes and not general apps (including LO) as such  :


http://yourmacguy.wordpress.com/2012/06/29/osx-automount/


Alex
Comment 14 retired 2013-07-17 08:55:37 UTC
Unsure to set this to either NOTABUG or NOTOURBUG as of comment 12/13.
Comment 15 noibsguy 2013-07-17 13:56:10 UTC
I feel like notourbug might be best.  It still feels like a bug and if someone who doesn't know about this issue experiences it, it will probably feel like something is wrong when they experience the delay associated with trying to mount a server.  If the server isn't available, the delay will be pretty long and they will receive an error message.
Comment 16 sasha.libreoffice 2013-07-19 12:15:27 UTC
And I am sure that it is our bug. All time consuming operations should inform user that preforms work that takes some time. And should be ability to abort such prolonged in time operation.
Comment 17 Vincent Kersten 2013-08-11 15:13:49 UTC
Hello,
i experience the same problem with an alias to another mac (which is not available atm) and osx10.6.8. timeout takes quite a while and needs to time out at least two times before i can do anything in the file dialog. Did not switch to LO native filewindows yet, but def. is a bug as far as i am concerend, since other Mac apps do not try to resolve aliasas on the desktop.

Regards,


  Vincent