Bug 42986 - UI wide screen format (16:9): Add Page size and radio buttons 16:9 / 4:3 in Presentation Wizard
Summary: UI wide screen format (16:9): Add Page size and radio buttons 16:9 / 4:3 in P...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Rob Snelders
QA Contact:
URL:
Whiteboard: target:3.6.0 target:3.7.0
Keywords: difficultyBeginner, needsDevEval, topicUI
: 51285 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-16 05:14 UTC by rotwang2011
Modified: 2015-12-16 05:19 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Patch to have 16:10 format in Impress (3.78 KB, patch)
2012-06-22 12:58 UTC, Rob Snelders
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rotwang2011 2011-11-16 05:14:42 UTC
Give some thought to a matching set of 16:9 format templates, since most decent modern projectors are natively wide-screen.
Comment 1 sasha.libreoffice 2012-03-30 04:10:39 UTC
Thanks for new idea
At least screens (monitors) already are widescreen.
Step to reproduce:
in Impress do Format->Page, tab "Page", field "Format"
There is format "Screen" but no format "Widescreen"
reproduced in 3.5.1 on Fedora 64 bit
Comment 2 sasha.libreoffice 2012-04-02 01:14:49 UTC
Thanks for reply to my email:
I'd just about given up on hearing anymore about this one. As far as I can remember, my original desire was to create widescreen (16:9) format presentations. You can easily get 16:9 aspect ratio pages by playing with the paper sizes, thats not a problem. what stops me dead every time is that all the templates are firmly built round an assumption of 4:3 aspect ratio. What I needed was a complete, ground up, 16:9 aspect solution starting from the templates and working up. I've looked at generating a new set of templates (briefly) but there is only room for just so much pain in my life. There must be a way to generate a template file, but I haven't found it yet. This is going to be a future necessity, as all decent modern displays and projection systems are now 16:9 format.

Sorry for can not understand this:
>What I needed was a complete, ground up, 16:9 aspect solution starting from the >templates and working up.
What exactly should be done besides of adding new template?
Comment 3 gleppert 2012-04-08 00:28:18 UTC
I second this request for enhancement in order to make wide screen presentations easier to create.

I guess the first step would be indeed to have in Format -> Page the choice between "Screen" and "Wide screen" like Sasha proposed it.

I assume that this is an EasyBug. Could you please add it to the EasyBug list?
Comment 4 sasha.libreoffice 2012-04-09 01:25:59 UTC
@ Rainer
Users want this bug to be added to EasyBugs. We need Your advice here.
Best regards. sasha
Comment 5 gleppert 2012-04-09 03:01:13 UTC
Side note:To make the solution more comprehensive, it would make sense to also add a check box for the 16:9 format in the presentation wizard (File -> Wizards -> Presentation). Currently, there are only check boxes for "Overhead sheet", "Paper", "Screen" and "Slide".
Comment 6 Rainer Bielefeld Retired 2012-04-09 03:33:30 UTC
Since Saturday I own a new 16:9 Monitor, so for today I had this on my agenda :-)

IMHO we should leave the current Screen format with new name "Screen 4:3" and add a new one "Screen 16:9"

Ivan:
Do you agree with making it "EasyHack"?
Comment 7 Rainer Bielefeld Retired 2012-04-09 03:36:59 UTC
The page format will also be required for DRAW.

May be the Wizard enhancement should be separated  to a different bug depending on this one?
Comment 8 Ivan Timofeev (retired) 2012-04-12 06:26:19 UTC
Hmm, The report was about the templates, why we are talking about UI improvements here? :)

(In reply to comment #6)
> Saturday I own a new 16:9 Monitor

Congrats! ;)

> IMHO we should leave the current Screen format with new name "Screen 4:3" and
> add a new one "Screen 16:9"

Well, "Screen" is 28cm:21cm. But I wonder what the name "Screen" means. What screen? My screen? No, my screen has different proportions and size. Or it means 'typical 4:3 screen'? Then where this 'typical' comes from? Any statistics?

But seriously: I am a bad English speaker and I have no idea of the name. And what size we will use (in cm)? 

> Do you agree with making it "EasyHack"?

Sure, it is quite easy.
Code pointers:
cui/source/tabpages/page.(src|cxx) - page setup.
sd/source/ui/dlg/dlgass.(src|cxx) - presentation wizard

(In reply to comment #7)
> May be the Wizard enhancement should be separated  to a different bug depending
> on this one?

No, it should not I think.
Comment 9 gleppert 2012-04-12 06:32:49 UTC
@Ivan: Thank you for your post. You are right that two thing got mixed up: a) the addition for a "page" format for 16:9 and b) to add templates for 16:9.
Shall we create two different bug entries for that?
Comment 10 Ivan Timofeev (retired) 2012-04-12 06:54:31 UTC
(In reply to comment #9)
> Shall we create two different bug entries for that?

probably yes, but a) needs some discussion.
Comment 11 rotwang2011 2012-04-12 07:41:31 UTC
I wasn't sure how deep this would need to go, or what the complications might be, but what I need to do is to give presentations on 16:9 format large screen projectors. This means setting up 16:9 format templates (if there is any documentation on how to build a template from scratch, point me towards it please!) and having them handled correctly (for certain values of correct). Bear in mind that I may have to run Presentation Manager on a 4:3 format laptop screen.
Comment 12 rotwang2011 2012-04-12 07:49:31 UTC
As for sizes, I would prefer to think in pixels (as in 1920x1080), rather than centimeters, my screen sizes run  from 8 feet wide to 60 feet. As long as I can do that I don't mind what size you choose, what matters to me is the aspect ratio.
Comment 13 gleppert 2012-04-12 09:57:27 UTC
Since this bug had already been renamed to "UI wide screen format (16:9): Add Page size and radio buttons 16:9 / 4:3 in Presentation Wizard", I follow Ivan's suggestion to open a second bug entry for the addition of 16:9 templates to LibreOffice Impress.

There is the other Bug 48616

I apologize the confusion!
Comment 14 gleppert 2012-04-12 10:59:47 UTC
I just searched the internet how to create 16:9 presentations in Impress. As it seems there are "metric" and "imperial measures" advice in the Internet:

In a book by Jacquline Rahmehipour et al. (page 63) they suggest:
28 x 15.75 cm

In a youtube video gotoguyenterprises suggests:
16" x 9"

Since the previous one (the metric one) is more reasonable for printing I think it is the way to go. Is it?

Links:
Book: http://books.google.de/books?id=Iu8LZjDR9RAC&lpg=PA62&ots=ghY36ZKmZt&dq=Master%20im%2016%3A10-%20oder%2016%3A9-Format%20erstellen%20openoffice&pg=PP1#v=onepage&q&f=false
Video: http://www.youtube.com/watch?v=U6GF5mLhaEs
Comment 15 Not Assigned 2012-04-23 11:39:09 UTC
Rob Snelders committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9c99dac0968c405537cd6094a46c7f6de01ccc4e

fdo#42986 Add Presentationsize 16:9 Widescreen
Comment 16 Rob Snelders 2012-04-24 15:57:22 UTC
This bug is solved with the patch I send.
Comment 17 gleppert 2012-05-17 06:06:29 UTC
Can anyone add this enhancement to the page "Release Notes 3.6" on wiki.documentfoundation.org? I think a brief description about it is still missing there. Thanks.
Comment 18 Rob Snelders 2012-05-17 06:26:46 UTC
added it to the https://wiki.documentfoundation.org/ReleaseNotes/3.6#Impress
Comment 19 vitriol 2012-06-21 01:36:38 UTC
*** Bug 51285 has been marked as a duplicate of this bug. ***
Comment 20 Zeki Bildirici 2012-06-21 01:41:47 UTC
(In reply to comment #19)
> *** Bug 51285 has been marked as a duplicate of this bug. ***

Hi,

Hope to see this issue is fixed. And sorry for the duplicate bug.(Just learning to search :)) 

Could you add the option for 16:10 size, which ratio is quite popular on laptops.

MS Impress has this ratio too.

Best regards,
Zeki
Comment 21 Zeki Bildirici 2012-06-21 02:03:14 UTC
(In reply to comment #20)
> MS Impress has this ratio too.

I mean MS PowerPoint :) 

Btw http://en.wikipedia.org/wiki/16:10 states that industry moves away from 16:10 to 16:10, however people have purchased this screens and they are still in use.

Regards,
Zeki
Comment 22 sasha.libreoffice 2012-06-21 02:04:53 UTC
> 16:10 to 16:10, however people have purchased this screens and they are still
How it can be?
Comment 23 Zeki Bildirici 2012-06-21 02:31:08 UTC
(In reply to comment #22)
> > 16:10 to 16:10, however people have purchased this screens and they are still
> How it can be?

They are still on the market. Today one asked about this issue on 1440x900 desktop monitor. Also laptops are on sale 1280x800.
Here[1],For example one of the largest on-line elecronics store, sales monitors: 

16:9 (Wide Screen) 90 unique items
16:10(Wide Screen) 6 unique items
4:3  (Normal Screen) 4 unique items


Those will have min 3 years of usage time. I think my Plasma TV has 16:10 too :)

1- http://www.hepsiburada.com/liste/monitorler/department.aspx?CategoryId=57
Comment 24 sasha.libreoffice 2012-06-21 03:17:58 UTC
> 16:10 to 16:10, however people have purchased this screens and they are still
I mean that from 16:10 to the same 16:10. Something mistyped.

I know that it is boring to manufacturers to nothing change. And therefore they change all things all time.
Comment 25 Rob Snelders 2012-06-22 12:58:41 UTC
Created attachment 63363 [details]
Patch to have 16:10 format in Impress

Here is the patch that adds it.
I'll try to send it to gerrit tomorrow so it gets into master
Comment 26 Rob Snelders 2012-07-05 11:47:27 UTC
added it to gerrit
Comment 27 Not Assigned 2012-07-06 03:05:39 UTC
Rob Snelders committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b8c5f6577911ebb15ad7eb7f60ad5bb9d8d37f0b

fdo#42986 - UI wide screen format (16:10): Add Page size
Comment 28 Albert Pool 2014-03-30 11:32:51 UTC
It's great to have 16:9 format as a possibility in Impress, but it should also be able to open 16:9 .pptx presentations of MS Office correctly - currently it still displays them in 4:3 by default causing elements to fall off-screen. Should I open a new bug for this?
Comment 29 Rob Snelders 2014-03-30 12:13:27 UTC
Please open a new bug for this. This is a problem then with opening/saving pptx-format.
Comment 30 Robinson Tryon (qubit) 2015-12-16 05:19:05 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval, DifficultyBeginner  TopicUI  )
[NinjaEdit]