Bug Hunting Session
Bug 43087 - UI: Missing message "cell protected" when Trying to modify or delete protected contents
Summary: UI: Missing message "cell protected" when Trying to modify or delete protecte...
Status: RESOLVED DUPLICATE of bug 45191
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4 Daily
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Protection
  Show dependency treegraph
 
Reported: 2011-11-19 04:59 UTC by Stefan Lindel
Modified: 2018-02-22 16:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file with style sheet tableContent (20.06 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-11-20 02:45 UTC, Stefan Lindel
Details
step1 (278.40 KB, image/jpeg)
2011-12-06 00:11 UTC, Stefan Lindel
Details
step2 (388.41 KB, image/jpeg)
2011-12-06 00:12 UTC, Stefan Lindel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Lindel 2011-11-19 04:59:36 UTC
I can add a style sheet in calc but i can't edit the style sheet or delete it

OS Windows 7 and Kubuntu 11.10
Comment 1 Rainer Bielefeld Retired 2011-11-19 23:48:33 UTC
@Stefan Lindel:
We can't fix your problems, only LibO-bugs.

May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport> carefully?
Then please:
- Write a meaningful Summary
- Attach atest ket (not only screenshot)
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (and if possible how to created a 
  sample document from the scratch)
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC (especially: video card)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO version and localization (UI language)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration ...)
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an OOo Issue that might be useful
  -- everything else crossing your mind after you read linked texts
Comment 2 Stefan Lindel 2011-11-20 02:45:28 UTC
Created attachment 53699 [details]
Sample file with style sheet tableContent

in the sample file i can't edit or delete the style sheet tablecontent
Comment 3 Rainer Bielefeld Retired 2011-11-30 23:53:58 UTC
@Stefan Lindel
May be it's because of the Table cell protection?
I asked you 13 questions and got 1 answer, that's a really poor relation. Please check my suspect and if you can't confirm it please contribute the missing requested information.
Comment 4 Stefan Lindel 2011-12-06 00:11:55 UTC
Created attachment 54133 [details]
step1

step1
Comment 5 Stefan Lindel 2011-12-06 00:12:15 UTC
Created attachment 54134 [details]
step2
Comment 6 Stefan Lindel 2011-12-06 00:12:40 UTC
In te sample File you can add a custom stylesheet but you can't edit or delete a stylesheet which you are added. So it may be a error in the gui or in the app.
Comment 7 Rainer Bielefeld Retired 2011-12-06 00:53:02 UTC
In attached sample document some context menu items that are not possible because of sheet protection, an so they are not available / visible in context menu, what's ok.

But you can select a complete row and then click "delete row" icon without any reaction / message. That's worrying.

Additionally (as from original report) when you try to delete a style referencing to a protected cell also no message appears.

That should be improved. 

@Stefan Lindel:
No, it's because the style sheet references to a protected cell, and so, of course, it can not be deleted

Still my most questions without answer, but they are no longer necessary.

@Kohei:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 8 xiaoli 2013-03-24 11:26:36 UTC
I found the same behaviour on LO 4.0.1
My OS is Ubuntu 12.04 AMD64.
It seems not being os depended bug.
Comment 9 ign_christian 2013-09-24 02:37:02 UTC
*** Bug 45191 has been marked as a duplicate of this bug. ***
Comment 10 Timur 2018-02-22 16:30:29 UTC
This is a messy bug, hard to understand. So, regardless it's earlier, I'll mark as a duplicate. Even if not about Delete and warning, it's invalid.

*** This bug has been marked as a duplicate of bug 45191 ***
Comment 11 Timur 2018-02-22 16:53:24 UTC
OR this this a dupe of Bug 57102