Bug 43100 - EDITING: It is better for spaces at the end of line to cause a new line
Summary: EDITING: It is better for spaces at the end of line to cause a new line
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Attila Szűcs
URL:
Whiteboard: BSA target:7.5.0
Keywords:
Depends on:
Blocks: Writer-UX
  Show dependency treegraph
 
Reported: 2011-11-19 20:55 UTC by Hong Xu
Modified: 2022-07-04 13:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hong Xu 2011-11-19 20:55:31 UTC
Problem description: 

Steps to reproduce:
1. Create a new document;
2. Input words until the end of a line;
3. Now press a space, but the cursor kept still.

Current behavior:
The cursor doesn't move.

Expected behavior:
The cursor moves to a new line.

Platform (if different from the browser): 
Both Windows and Linux
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Comment 1 Vicente Rafael Estévez Vacas 2012-04-15 08:54:04 UTC
[Reproducible] with "LibreOffice 3.4.6 - Debian Squeeze (32bit) Spanish
UI"

If I have understood correctly, the cursor should stay in line. He stays in the same line but I do not see it being a mistake.
Comment 2 Hong Xu 2012-04-15 09:34:45 UTC
It's no big deal; but moving to a new line makes it clear that a space is pressed.
Comment 3 sasha.libreoffice 2012-04-21 02:15:57 UTC
reproduced in 3.5.2 on Fedora 64 bit
IMHO this problem is since version 2.0 of OpenOffice
Comment 4 sasha.libreoffice 2012-04-21 02:17:37 UTC
Workaround: use Ctrl-Shift-Space instead of spaces
Comment 5 Zoltán Hegedüs 2013-11-07 11:34:05 UTC
4.0.6 release: If I am keeping pressed the key space, the cursor moves right, and after the end of the line, the cursor moves back to the last non-space character. After it, if I press a non-space key, this always will be at the begin of the next line, even if I typed enough spaces to placing this not to the begin of the next line, but to the middle of the next line, for example. I always set off all in the Automatic Correcting window (this is a word-for-word translation from Hungarian, the English name maybe other, see near the end of the menu Tools).
Comment 6 A Barker 2015-08-26 03:07:41 UTC
Version: 4.3.7.2 (build id: 4.3.7.2-9.fc21, fedora 21), same problem. For a better user experience the cursor & spaces should continue on the next line. 

If you enter a number of spaces at the end of the line (Say 4 or 5) then edit the preceding text, the additional spaces will now become visible in the text. This is a little unsightly and requires further editing.

Also note that when pressing space at the end of the line any text on the following lines (and subsequent paragraph) does not include the additional spaces. This problem not only appears at the end but also at the start of any line that has been word wrapped too. (place the cursor at the beginning of a line that has been word wrapped and press space)

Better to provide immediate feedback when pressing space at the end or beginning of word wrapped lines. Work around suggested is not really a viable option since most users would never expect/know to press Ctrl-Shift-Space.
Comment 7 tommy27 2015-09-25 05:11:52 UTC
still reproducible under Win8.1x64 using LibO  5.1.0.0.alpha1+ (x64)
Build ID: 8c7ba16ba4bdedb4354f342b20d5a5de8a132b48
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-24_21:53:09
Locale: it-IT (it_IT)
Comment 8 tommy27 2015-09-25 05:15:49 UTC
same thing in OOo 3.3.0 so it's an inherited issue
Comment 9 Commit Notification 2022-06-24 12:15:43 UTC
Attila Szűcs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7ef9c3ef30023cc40068e1f735aa4bec4811288b

tdf#43100 tdf#104683 tdf#120715 sw: cursor on spaces over margin

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 NISZ LibreOffice Team 2022-06-28 11:25:49 UTC
LibreOffice shows now the nonprinting characters beyond the right margin. 
The cursor won't moves new line until you put some printable character.
If you want spaces in the next line you should have to line break and put spaces in the new line.

Verified in:
Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 415dc3bb1c03dbdbc3cbca274bc435ac7557ba2d
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 11 Commit Notification 2022-06-29 08:51:38 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/761d3a128214b48645f00e2ff094e0f8928d1ee1

Revert "tdf#43100 tdf#104683 tdf#120715 sw: cursor on spaces over margin"

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2022-07-04 13:35:33 UTC
Attila Szűcs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/690d4eb71509649ad147cfe60f5b97e2cfaaa519

tdf#43100 tdf#104683 tdf#120715 sw: cursor on spaces over margin

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.