Bug Hunting Session
Bug 43318 - PRINTING standard shapes with bitmap area: filling exceeds shape area (regression since 3.3.4)
Summary: PRINTING standard shapes with bitmap area: filling exceeds shape area (regres...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.1 RC1
Hardware: All All
: highest major
Assignee: Not Assigned
URL:
Whiteboard: BSA bibisected35older
Keywords: regression
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2011-11-28 16:55 UTC by Paul Mirowsky
Modified: 2014-02-12 10:06 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Drawing with error. (70.61 KB, application/vnd.oasis.opendocument.graphics)
2011-11-28 16:55 UTC, Paul Mirowsky
Details
abnormal Bullzip PDF print output (99.87 KB, application/pdf)
2013-08-09 15:06 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Mirowsky 2011-11-28 16:55:54 UTC
Created attachment 53920 [details]
Drawing with error.

Problem description: When printing an object that uses a "bitmap" selected from the "Area" menu.  It looks correct when on the screen, but is not constrained within the object when printed. LibreOffice Draw

Steps to reproduce:
1. Create a cylinder from Basic Shape icon
2. Go to Bitmaps tab. Create a bitmap using pattern editor with Foreground color of Yellow 2 in second column.  Background color on all others of Green 3. Save/Add bitmap with name "wiring grn/yel".
3. Apply "wiring grn/yel" from Area tab by selecting  Fill with Bitmap and then selecting "wiring grn/yel".
4. Print to printer

Current behavior: When printed to HP OfficeJet Pro 8500 Premier, bitmap is not constrained to inside object.

Note that variations on bitmap behavior varies with setting on Area tab. Also varies when grouping other object with bitmap object.

Original error discover in Writer when printing object copied from Draw.

Expected behavior: Bitmap remains inside object.

Platform (if different from the browser): Window XP Home Edition service pack 3
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:8.0.1) Gecko/20100101 Firefox/8.0.1
Comment 1 sasha.libreoffice 2012-02-13 05:52:38 UTC
reproduced in 3.5.0 rc 3 and in 3.6.0 master on Fedora 64 bit
but not reproduced in 3.3.4, therefore regression
Steps to reproduce:
0. Open attachment in Draw
1. Open page 3, select picture there and increase it to be on whole page
2. File->Print, maximize Print dialog, scroll to page 3

Expected: figure with round top and bottom
Actually: figure with polygonal  top and bottom
Comment 2 Rainer Bielefeld Retired 2012-02-13 08:01:25 UTC
[Reproducible] with "LibreOffice 3.4.1RC1  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:101)]". I believe it came with 3.4.0
PDF export is not affected.

@sasha:
I would prefer to see this one as 3.4 Most Annoying
Comment 3 sasha.libreoffice 2012-02-13 08:20:09 UTC
Sorry! I thought 3.4 is already forgotten.
Comment 4 Björn Michaelsen 2012-02-22 02:16:17 UTC
regression between 3.3->3.4 => bibisected35older
Comment 5 Ivan Timofeev (retired) 2012-02-28 07:03:10 UTC
Reproducible with Writer as well.
I printed the doc to PDF via CUPS-PDF-Printer - looks ok => it is a Print Dialog problem. IIRC there was some work on the preview creation boost (in days of OOo), maybe that is related. Maybe not though.
Comment 6 Ivan Timofeev (retired) 2012-02-28 10:56:12 UTC
(In reply to comment #5)
> IIRC there was some work on the preview creation boost (in days of OOo), maybe
> that is related. Maybe not though.

Ah, no, that's another story.

BTW, more simple steps to reproduce the bug from scratch:
1. Create new document.
2. Menu: View->Toolbars->Drawing and draw Ellipse from Basic Shapes.
3. Right click on it -> Area... -> Change Fill from Color to Bitmap -> Press Ok
4. Ctrl+P and see on the preview.

Interestingly, that works for simple Ellipse (not from Basic Shapes). What's the difference?..

Print dialog creates metafiles and renders them via drawinglayer, drawinglayer/source/processor2d/vclmetafileprocessor2d.cxx may be related...

Just my two cents.
Comment 7 Rainer Bielefeld Retired 2012-03-19 01:54:37 UTC
I believe this one has the same roots like "Bug 40421 - PRINTING shapes with transparent(?) Bitmap background loses bezier curves" or even might be a DUP).
Comment 8 Rainer Bielefeld Retired 2012-12-10 05:47:58 UTC
Worked fine with Server Installation of "LibreOffice 3.3.3  German UI/Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit), so Regreession

AOOo 3.4.1 does the job without a murmur

I nominate this one as HardHack on <http://wiki.documentfoundation.org/HardHacks> and shift it to 4.0mab, because lifecycle of 3.5 is terminated
Comment 9 David Tardon 2013-05-02 10:32:01 UTC
*** Bug 40421 has been marked as a duplicate of this bug. ***
Comment 10 marshals 2013-05-02 10:37:06 UTC
this might also be related to 40863
Comment 11 Thorsten Behrens (CIB) 2013-05-07 16:53:45 UTC
The connection to bug 40421 seems plausible - let alone I was not able to reproduce this one here on Linux, so please someone who can try with one of the next nightly builds (fix is in master).
Comment 12 tommy27 2013-08-09 15:06:54 UTC
Created attachment 83894 [details]
abnormal Bullzip PDF print output

tested on Win7 64bit and LibO 4.0.4

I'm on vacation with no printer available, however I tried to print with a virtual PDF printer (Bullzip) and the output is abnormal.

direct PDF export looks fine.
Comment 13 Björn Michaelsen 2014-01-17 09:58:36 UTC
(This is an automated message.)

Setting priority to highest as this is a 4.0 MAB. This is part of an effort to make the importance of MAB reflected in priority too.
Comment 14 stragu 2014-02-12 08:07:46 UTC
Could someone test if this is still an issue in 4.1 and/or 4.2?
Comment 15 sasha.libreoffice 2014-02-12 10:06:05 UTC
in 4.1.3 on Fedora RFR 64 bit works correctly
Closing as WorksForMe

Thanks to developers for fixing this bug!