Bug Hunting Session
Bug 43380 - FILEOPEN: RTF doesn't open properly; just shows a blank page; crashes in LO 3.5.0 beta2
Summary: FILEOPEN: RTF doesn't open properly; just shows a blank page; crashes in LO 3...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other All
: high critical
Assignee: Miklos Vajna
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-30 08:44 UTC by cbullock.public
Modified: 2012-03-19 23:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Loaded RTF document is blank (65.03 KB, image/png)
2011-11-30 08:44 UTC, cbullock.public
Details
Example document that produces the described error. (97.24 KB, application/rtf)
2011-12-20 09:59 UTC, cbullock.public
Details
pdf export with LO 3.5.0 beta2+ (50.42 KB, application/pdf)
2011-12-27 03:37 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cbullock.public 2011-11-30 08:44:17 UTC
Created attachment 53972 [details]
Loaded RTF document is blank

Problem description: 

  When I open some RTF files (but not all; so far it only appears to be RTFs with text form fields), Writer starts just fine but only a single blank page is shown.  The same document will load properly in AbiWord, MS Office 2003 and MS Office 2010.  Writer still opens .ODF and .DOC files correctly.

  This did not happen previously (the problem did not exist as of two weeks ago).

Steps to reproduce:
1. Double-click on RTF file within Nautilus file manager or
2. run 'libreoffice --writer <document>.rtf' from the command line.  No error message occurs.
3. ....

Current behavior:

  Some RTF documents will no longer open; only a blank, single page is shown.

Expected behavior:

  Document opens and displays correctly.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Comment 1 Jean-Baptiste Faure 2011-12-18 09:26:34 UTC
Please provide a RTF file showing the problem.

I suggest you to try LO 3.5.0 beta-1 which has a new RTF filter. 

Best regards. JBF
Comment 2 cbullock.public 2011-12-20 09:59:17 UTC
Created attachment 54601 [details]
Example document that produces the described error.

I cannot submit an original document due to client confidentiality.  However, I was able to strip out and replace identifying information while still producing the error.
Comment 3 Jean-Baptiste Faure 2011-12-24 09:43:14 UTC
Thank you for this attachment. Indeed your file opens in LO 3.4.4 as a blank page. What is surprising is that LO 3.5.0 (LibreOffice 3.5.0beta2+ Version ID : 746cde4-7f15fca-1fc8c06-ca8e46d-b96fade) crashes when opening this file.

Side note: Abiword 2.8.6 opens the file and it is not a blank page.

Miklos: feel free to reassign if youo can't handle this bug. I am not able to decide if it is a duplicate of another crash you already know.

Best regards. JBF
Comment 4 Miklos Vajna 2011-12-25 03:51:30 UTC
I'm not really aware of any crashes at the moment, so surely not a duplicate.

Will have a look soon.

Thanks.
Comment 5 Miklos Vajna 2011-12-26 15:06:18 UTC
Fixed in master: http://cgit.freedesktop.org/libreoffice/core/commit/?id=e4e77861c6a42d040230f4b1ca22ad5e8c3d52a2

Also, the "Bitte Fax-Nr. wählen" wasn't red, as it should be, that is fixed in master, too: http://cgit.freedesktop.org/libreoffice/core/commit/?id=e71d6df4137515f928d87375e404459cf9f310be

I've cherry-picked both fixes to -3-5 as well.
Comment 6 Jean-Baptiste Faure 2011-12-27 03:37:03 UTC
Thank you Miklos !
No crash anymore in LibO 3.5.0 beta2+ (LibreOffice 3.5.0beta2+ Version ID : 570120e-7f15fca-1fc8c06-ca8e46d-b96fade).

But I do not see any "Bitte Fax-Nr. wählen" when I open the bugdoc https://bugs.freedesktop.org/attachment.cgi?id=54601. Are you sure that all needed fix done in master have been backported to 3.5.0 branch ?

I will attach pdf export of the document as I see it in LO 3.5.0 beta2+.

Best regards. JBF
Comment 7 Jean-Baptiste Faure 2011-12-27 03:37:59 UTC
Created attachment 54841 [details]
pdf export with LO 3.5.0 beta2+
Comment 8 Miklos Vajna 2011-12-27 05:28:47 UTC
The text is marked as "hidden", so it won't show up in the pdf export. ;-) Though if you open the RTF manually, then you should see it.
Comment 9 Jean-Baptiste Faure 2011-12-27 05:38:04 UTC
(In reply to comment #8)
> The text is marked as "hidden", so it won't show up in the pdf export. ;-)
> Though if you open the RTF manually, then you should see it.

Ah ok, I see the text now and it is red. :-)
Thank you very much.
JBF
Comment 10 Jean-Baptiste Faure 2012-03-19 23:14:18 UTC
Fix confirmed in LO 3.5.1. Closing. Thank you.