Download it now!
Bug 43429 - Opening of docx-file with mathematical formulas crashed writer. (Sample provided)
Summary: Opening of docx-file with mathematical formulas crashed writer. (Sample provi...
Status: RESOLVED DUPLICATE of bug 36982
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-01 09:35 UTC by Tero Miettinen
Modified: 2018-10-29 19:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
File that causes the crash. (119.78 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-12-01 09:35 UTC, Tero Miettinen
Details
This screenshot shows how the sample DOCX file looks when I open it with LibreOffice 3.4.4 on WinXP (59.91 KB, image/png)
2011-12-02 01:33 UTC, Roman Eisele
Details
This screenshot shows how the sample DOCX file looks when I open it with LibreOffice 3.4.4 on MacOS X 10.6.8 (197.54 KB, image/png)
2011-12-02 01:39 UTC, Roman Eisele
Details
This screenshot shows how the sample DOCX file looks when I open it with LibreOffice master build 2011-12-01 on MacOS X 10.6.8 (161.22 KB, image/png)
2011-12-02 01:40 UTC, Roman Eisele
Details
This screenshot shows how the sample DOCX file should look (MS Office 2007 on Windows 7), upper part (23.83 KB, image/png)
2011-12-02 02:38 UTC, Roman Eisele
Details
This screenshot shows how the sample DOCX file should look (MS Office 2007 on Windows 7), lower part (27.94 KB, image/png)
2011-12-02 02:38 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tero Miettinen 2011-12-01 09:35:03 UTC
Created attachment 54027 [details]
File that causes the crash.

Attempting to open the attached docx-file causes the Writer to crash at startup.

Version in use is LibreOffice 3.4.2 
OOO340m1 (Build:203)
Comment 1 Roman Eisele 2011-12-01 13:27:24 UTC
I cannot confirm this: both
-- LibreOffice 3.4.4 with German langpack
-- LibO-dev 3.5.0 
   Build ID: 549f928-b211287-090bcba-45cf606
   build date: 2011-12-01
both running on MacOS X 10.6.8 German
open the DOCX document without crashing etc.

Two ideas:
-- maybe the problem was fixed in LibreOffice 3.4.3/3.4.4?
-- maybe this bugs depends on the operating system?

@ Tero Miettinen:
-- Could you please test if the bug is still present for you with LibreOffice 3.4.4?
-- Which Operating System do you use? If Windows, which version?

PS: But there is another issue: at least with the current master, the formulas look rather strange ... But this issue should get reported separately.
Comment 2 Tero Miettinen 2011-12-02 00:30:54 UTC
I updated to LibreOffice 3.4.4
OOO340m1 (Build:402)

Same problem still exists.

I'm running 64-bit Windows 7.
Comment 3 Roman Eisele 2011-12-02 01:32:03 UTC
@ Tero Miettinen:
Thanks for trying LibreOffice 3.4.4! So it looks like this is an operating-system dependent bug. I can confirm this, too:

PARTIALLY REPRODUCIBLE with
LibreOffice 3.4.4 with German langpack installed,
running on Windows XP Version 5.1 German (Build 2600.xpsp ... Service Pack 3):

When I open the sample DOCX file with LibreOffice 3.4.4 on Win XP, LibreOffice doesn’t crash, BUT it only shows 5 lines of text -- all the formulas and all text after the first formula are gone! So, no crash for me, but at least a very substantial loss of data.

I will attach a screenshot to show this result, and I will also attach screenshots which show how the documents looks like in LibreOffice running on MacOS X.
Comment 4 Roman Eisele 2011-12-02 01:33:11 UTC
Created attachment 54056 [details]
This screenshot shows how the sample DOCX file looks when I open it with LibreOffice 3.4.4 on WinXP
Comment 5 Roman Eisele 2011-12-02 01:39:38 UTC
Created attachment 54057 [details]
This screenshot shows how the sample DOCX file looks when I open it with LibreOffice 3.4.4 on MacOS X 10.6.8
Comment 6 Roman Eisele 2011-12-02 01:40:36 UTC
Created attachment 54058 [details]
This screenshot shows how the sample DOCX file looks when I open it with LibreOffice master build 2011-12-01 on MacOS X 10.6.8
Comment 7 Roman Eisele 2011-12-02 02:38:00 UTC
Created attachment 54061 [details]
This screenshot shows how the sample DOCX file should look (MS Office 2007 on Windows 7), upper part
Comment 8 Roman Eisele 2011-12-02 02:38:49 UTC
Created attachment 54062 [details]
This screenshot shows how the sample DOCX file should look (MS Office 2007 on Windows 7), lower part
Comment 9 Rainer Bielefeld Retired 2011-12-02 05:19:51 UTC
Still [Reproducible] with "LibreOffice 3.4.4  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:402)]" and 
[Reproducible] with Server installation of  Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 130028f-b211287-090bcba-45cf606-05891e7]" Win-x86@9-Voreppe - 111130)

I will do some futher research later.
Comment 10 Roman Eisele 2011-12-02 06:06:54 UTC
After further research, I found that there is alredy Bug 36982 -- "Writer ignores text after Equation in docx" with some discussion. Looking at the sample file, I conclude that it is the same bug -- most times, on Windows the contents of the file after (and including) the first formula get ignored, and comment #11 for Bug 36982 already mentions the crash that occurs under some circumstances.

Therefore marking this bug as a duplicate of Bug 36982.

@Rainer Bielefeld: sorry for making work for you! I should have noticed the duplication earlier, but yesterday I did not find out about Bug 36982.

But we still have to figure out:
-- when the contents of the DOCX file after (and including) the first formula get ignored
-- and when the crash mentioned by Tero Miettinen occurs.
Both problems happen on Windows only, of course ...

*** This bug has been marked as a duplicate of bug 36982 ***
Comment 11 Roman Eisele 2012-03-13 06:48:46 UTC
Just some hint:

Bug 36982 should be fixed now by http://cgit.freedesktop.org/libreoffice/core/patch/?id=b68f06287d34833a59841b8000641a02d0994eb8

This patch will appear in LibO 3.5.2 and 3.4.6. We should check if the patch also fixes the iussue reported in the present bug report (I would expect so). If it doesn’t fix the issue reported in the present bug report, we need to reopen this bug.