Bug 43451 - Long Password fails for file saving LibreOffice CALC file as MS Excel XLS file
Summary: Long Password fails for file saving LibreOffice CALC file as MS Excel XLS file
Status: RESOLVED DUPLICATE of bug 43452
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-01 20:52 UTC by C. Andrews Lavarre
Modified: 2013-11-27 14:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
ODS file encrypted with 16 character password (10.19 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-12-03 16:05 UTC, C. Andrews Lavarre
Details
LibreOffice XLS file encrypted with 16 character password 1234567890123456 (7.00 KB, application/vnd.ms-excel)
2011-12-03 16:09 UTC, C. Andrews Lavarre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description C. Andrews Lavarre 2011-12-01 20:52:35 UTC
LibreOffice 3.4.2 
OOO340m1 (Build:1206)
OpenSuSE 11.4 KDE 4.6
Comment 1 C. Andrews Lavarre 2011-12-03 16:05:30 UTC
Created attachment 54094 [details]
ODS file encrypted with 16 character password

It is a 
     LibreOffice Calc ODS file

Supports bug report:
43451: Long Password fails
Comment 2 C. Andrews Lavarre 2011-12-03 16:09:21 UTC
Created attachment 54095 [details]
LibreOffice XLS file encrypted with 16 character password 1234567890123456

This is a LibreOffice Calc XLS file.
 
It has been encrypted with the 16-character password
      1234567890123456

Trying to open it with that password fails with the message
      The password is invalid. Cannot open the file.

However, if you use only the first fifteen characters
     123456789012345

then the file opens correctly.
Comment 3 C. Andrews Lavarre 2011-12-03 16:15:00 UTC
+ You are correct that the bug is INVALID with respect to ODS files.

+ You are INCORRECT that the bug is invalid with respect to XLS files:

     - I attach two files, trash16.ODS and trash16.XLS.
     - Both have been encrypted with the same 16-character password:
          1234567890123456

+ The ODS file opens correctly with this password

+ the XLS file FAILS to open, with the message:
      The password is invalid. Cannot open the file.

+ However, if you use only the first fifteen characters
     123456789012345

then the file opens correctly.

So this bug report is VALID:

LONG PASSWORD ENCRYPTION FAILS FOR XLS FILES IN LIBREOFFICE CALC

Best regards,
Andy Lavarre
alavarre@gmail.com
Comment 4 C. Andrews Lavarre 2011-12-03 16:16:29 UTC
+ You are correct that the bug is INVALID with respect to ODS files.

+ You are INCORRECT that the bug is invalid with respect to XLS files:

     - I attach two files, trash16.ODS and trash16.XLS.
     - Both have been encrypted with the same 16-character password:
          1234567890123456

+ The ODS file opens correctly with this password

+ the XLS file FAILS to open, with the message:
      The password is invalid. Cannot open the file.

+ However, if you use only the first fifteen characters
     123456789012345

then the file opens correctly.

So this bug report is VALID:

LONG PASSWORD ENCRYPTION FAILS FOR XLS FILES IN LIBREOFFICE CALC

Best regards,
Andy Lavarre
alavarre@gmail.com
Comment 5 C. Andrews Lavarre 2011-12-03 16:17:48 UTC
+ You are correct that the bug is INVALID with respect to ODS files.

+ You are INCORRECT that the bug is invalid with respect to XLS files:

     - I attach two files, trash16.ODS and trash16.XLS.
     - Both have been encrypted with the same 16-character password:
          1234567890123456

+ The ODS file opens correctly with this password

+ the XLS file FAILS to open, with the message:
      The password is invalid. Cannot open the file.

+ However, if you use only the first fifteen characters
     123456789012345

then the file opens correctly.

So this bug report is VALID:

LONG PASSWORD ENCRYPTION FAILS FOR XLS FILES IN LIBREOFFICE CALC

Best regards,
Andy Lavarre
alavarre@gmail.com
Comment 6 Jean-Baptiste Faure 2012-01-29 01:58:20 UTC
Ok, it seems that LO does not expect the user may have chosen a password with more than 15 characters.

@reporter: could you clarify if your bug report 43452 is the same as this one?

Best regards. JBF
Comment 7 C. Andrews Lavarre 2012-01-29 09:21:26 UTC
Yes the two  bugs are the same. I have a flakey mouse pad that sometimes sends messages before I am ready to send them... :-(

Sorry.

Kind regards, Andy
Comment 8 Jean-Baptiste Faure 2012-01-29 09:33:38 UTC
(In reply to comment #7)
> Yes the two  bugs are the same. I have a flakey mouse pad that sometimes sends
> messages before I am ready to send them... :-(
> 
> Sorry.
> 
> Kind regards, Andy

Ok, closing as duplicate of bug 43452.

Thank you.

*** This bug has been marked as a duplicate of bug 43452 ***