Bug Hunting Session
Bug 43458 - LibreOffice does not start with a second monitor connected
Summary: LibreOffice does not start with a second monitor connected
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: All Linux (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-12-02 01:28 UTC by Cor Nouws
Modified: 2012-01-17 01:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
gdb output (7.79 KB, text/plain)
2011-12-20 01:43 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2011-12-02 01:28:09 UTC
Laptop X86
Ubuntu 
Extra monitor

Trying to start from terminal:
Gdk-CRITICAL **: IA__gdk_display_get_screen: assertion `ScreenCount (GDK_DISPLAY_X11 (display)->xdisplay) > screen_num' failed


Build ID: 5317074-2fcbe65-1f92ab1-3bd0388-ce71330
Build ID: 93acae3-090bcba-45cf606


Is no problem with older builds from master, e.g Build ID: 4456143-f6a1fc5-e1a2fb3
Comment 1 Cor Nouws 2011-12-02 01:36:28 UTC
so... when I start without the extra monitor, then connect the monitor, and try to open a document > same crash
Comment 2 Michael Meeks 2011-12-02 09:01:32 UTC
So - this is a linux & gtk backend error. I can't reproduce - indeed, with my second monitor connected everything works beautifully, and I get remote projecting just nicely. My xrandr output is:

$ xrandr
Screen 0: minimum 320 x 200, current 2944 x 1200, maximum 8192 x 8192
LVDS1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1920x1200      60.0*+   50.0  
   1600x1200      60.0  
   1400x1050      60.0  
   1280x1024      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1024x768+1920+432 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9     59.9  

Can you attach yours ?
Comment 3 Cor Nouws 2011-12-02 12:19:02 UTC
The extra monitor giving the problems is at my office.

At home I have two monitors that do not give the problem:

-I-
Screen 0: minimum 320 x 200, current 2646 x 1024, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
   1366x768       60.0*+
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1280x1024+1366+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024      60.0*+   75.0  
   1280x960       75.0     70.0     60.0  
   1152x864       75.0     70.0     60.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
TV1 unknown connection (normal left inverted right x axis y axis)
   848x480        30.0 +
   640x480        30.0 +
   1024x768       30.0  
   800x600        30.0  

-II-
Screen 0: minimum 320 x 200, current 2048 x 768, maximum 8192 x 8192
LVDS1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
   1366x768       60.0 +
   1360x768       59.8     60.0  
   1024x768       60.0* 
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1024x768+1024+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
TV1 unknown connection (normal left inverted right x axis y axis)
   848x480        30.0 +
   640x480        30.0 +
   1024x768       30.0  
   800x600        30.0 

Will post info on the other monitor asap, probably next Monday
Comment 4 Cor Nouws 2011-12-05 00:00:05 UTC
So here the output with the divice that make's it impossible to run the mentioned versions:

Screen 0: minimum 320 x 200, current 2646 x 1024, maximum 8192 x 8192
LVDS1 connected 1366x768+1280+256 (normal left inverted right x axis y axis) 293mm x 165mm
   1366x768       60.0*+
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 340mm x 270mm
   1280x1024      75.0*+   60.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
TV1 unknown connection (normal left inverted right x axis y axis)
   848x480        30.0 +
   640x480        30.0 +
   1024x768       30.0  
   800x600        30.0
Comment 5 Michael Meeks 2011-12-05 03:12:48 UTC
OOh - you have three displays ? and one rather nasty; can you send a screenshot of the gnome display configuration applet ? can you confirm that if you disable the TV output you don't get the bug ?

TV1 unknown connection (normal left inverted right x axis y axis)
   848x480        30.0 +
   640x480        30.0 +

Any chance you can run a build with symbols in it under gdb thus:


gdb ./soffice.bin
break g_logv
run

when it fails:

t a a bt

Thanks :-)
Comment 6 Cor Nouws 2011-12-05 04:32:44 UTC
Well, I have TWO displays...

and the output is:
~$ xrandr
Screen 0: minimum 320 x 200, current 2646 x 1024, maximum 8192 x 8192
LVDS1 connected 1366x768+1280+256 (normal left inverted right x axis y axis) 293mm x 165mm
   1366x768       60.0*+
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 340mm x 270mm
   1280x1024      75.0*+   60.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
TV1 unknown connection (normal left inverted right x axis y axis)
   848x480        30.0 +
   640x480        30.0 +
   1024x768       30.0  
   800x600        30.0  

Now I pull out the VGA cable:
~$ xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
   1366x768       60.0*+
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
TV1 disconnected (normal left inverted right x axis y axis)

:-)

And yes, the behavior is consistent: without the extra monitor, libreOffice Build ID: 93acae3-090bcba-45cf606 starts.

So a rather unusual situation here..
Comment 7 Cor Nouws 2011-12-05 04:35:07 UTC
I have no build with symbols, but could give that a try if it may add for this situation
Comment 8 Cor Nouws 2011-12-07 01:56:56 UTC
did run it with gdb.
pasted output here: http://pastebin.com/reqfRyEF
(think only for one day - but have it local too, for just in case that)
Comment 9 Cor Nouws 2011-12-07 02:30:00 UTC
oops, forget previous comment please. I started the wrong office-installation ;-)
Comment 10 Cor Nouws 2011-12-07 02:36:08 UTC
new output http://pastebin.com/0yruh0iN
(no idea if it makes much difference)
BTW: I did only a remake with symbols of vcl
Comment 11 Caolán McNamara 2011-12-07 03:19:42 UTC
symbols are still missing, best to use attachments anyway rather than temporary pastebins
Comment 12 Cor Nouws 2011-12-08 02:19:43 UTC
full rebuild with symbols

Here Thread 1 (out of 6, I expect the others are not that useful)

Thread 1 (Thread 0xb3f7d6d0 (LWP 2482)):
#0  0xb1d9b8e6 in g_logv () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb1d9bf62 in g_log () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb1d9c18d in g_return_if_fail_warning () from
/lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2083175 in gdk_display_get_screen () from /usr/lib/libgdk-x11-2.0.so.0
#4  0xb25154d3 in GtkSalDisplay::GetScreenSize (this=0x80ff2e0, nScreen=1)
    at /home/cono/src/git/libo_core/vcl/unx/gtk/window/gtkframe.cxx:4163
#5  0xb250ea2d in GtkSalFrame::calcDefaultSize (this=0x854ee20)
    at /home/cono/src/git/libo_core/vcl/unx/gtk/window/gtkframe.cxx:1322
#6  0xb250cb80 in GtkSalFrame::InitCommon (this=0x854ee20) at
/home/cono/src/git/libo_core/vcl/unx/gtk/window/gtkframe.cxx:679
#7  0xb250d634 in GtkSalFrame::Init (this=0x854ee20, pParent=0x0,
nStyle=2147483648)
    at /home/cono/src/git/libo_core/vcl/unx/gtk/window/gtkframe.cxx:940
#8  0xb250bb3e in GtkSalFrame::GtkSalFrame (this=0x854ee20, pParent=0x0,
nStyle=2147483648)
    at /home/cono/src/git/libo_core/vcl/unx/gtk/window/gtkframe.cxx:463
#9  0xb24f4188 in GtkInstance::CreateFrame (this=0x8088328, pParent=0x0,
nStyle=2147483648)
---Type <return> to continue, or q <return> to quit---
    at /home/cono/src/git/libo_core/vcl/unx/gtk/app/gtkinst.cxx:325
#10 0xb61cf1ba in Window::ImplInit (this=0x854ebb0, pParent=0x0,
nStyle=8589934592, pSystemParentData=0x0)
    at /home/cono/src/git/libo_core/vcl/source/window/window.cxx:851
#11 0xb612f5d1 in ImplBorderWindow::ImplInit (this=0x854ebb0, pParent=0x0,
nStyle=8589934592, nTypeStyle=8, pSystemParentData=0x0)
    at /home/cono/src/git/libo_core/vcl/source/window/brdwin.cxx:1910
#12 0xb612f755 in ImplBorderWindow::ImplBorderWindow (this=0x854ebb0,
pParent=0x0, pSystemParentData=0x0, nStyle=8589934592, 
    nTypeStyle=8) at
/home/cono/src/git/libo_core/vcl/source/window/brdwin.cxx:1945
#13 0xb61f6e38 in WorkWindow::ImplInit (this=0xb3749724, pParent=0x0,
nStyle=8589934592, pSystemParentData=0x0)
    at /home/cono/src/git/libo_core/vcl/source/window/wrkwin.cxx:72
#14 0xb6150f06 in IntroWindow::IntroWindow (this=0xb3749724) at
/home/cono/src/git/libo_core/vcl/source/window/introwin.cxx:56
#15 0xb06c5ed0 in desktop::SplashScreen::SplashScreen (this=0xb3749708,
rSMgr=...)
    at /home/cono/src/git/libo_core/desktop/source/splash/splash.cxx:80
#16 0xb06c875c in desktop::SplashScreen::getInstance (rSMgr=...)
    at /home/cono/src/git/libo_core/desktop/source/splash/splash.cxx:559
#17 0xb78f538b in cppu::OSingleFactoryHelper::createInstanceEveryTime
(this=0xb06f2f2c, xContext=...)
    at /home/cono/src/git/libo_core/cppuhelper/source/factory.cxx:181
#18 0xb78f554d in cppu::OSingleFactoryHelper::createInstanceWithContext
(this=0xb06f2f2c, xContext=...)
    at /home/cono/src/git/libo_core/cppuhelper/source/factory.cxx:213
#19 0xb78f5ecd in cppu::OFactoryComponentHelper::createInstanceWithContext
(this=0xb06f2ef8, xContext=...)
    at /home/cono/src/git/libo_core/cppuhelper/source/factory.cxx:489
#20 0xb78f5598 in
cppu::OSingleFactoryHelper::createInstanceWithArgumentsAndContext
(this=0xb06f2f2c, rArguments=..., xContext=...)
    at /home/cono/src/git/libo_core/cppuhelper/source/factory.cxx:221
#21 0xb78f600d in
cppu::OFactoryComponentHelper::createInstanceWithArgumentsAndContext
(this=0xb06f2ef8, rArguments=..., 
    xContext=...) at
/home/cono/src/git/libo_core/cppuhelper/source/factory.cxx:508
#22 0xb78f6ecc in
cppu::ORegistryFactoryHelper::createInstanceWithArgumentsAndContext
(this=0xb06e73f0, rArguments=..., 
    xContext=...) at
/home/cono/src/git/libo_core/cppuhelper/source/factory.cxx:811
#23 0xb346a349 in
stoc_smgr::OServiceManager::createInstanceWithArgumentsAndContext
(this=0xb3748108, rServiceSpecifier=..., 
    rArguments=..., xContext=...) at
/home/cono/src/git/libo_core/stoc/source/servicemanager/servicemanager.cxx:1255
#24 0xb346a652 in stoc_smgr::OServiceManager::createInstanceWithArguments
(this=0xb3748108, rServiceSpecifier=..., rArguments=...)
    at
/home/cono/src/git/libo_core/stoc/source/servicemanager/servicemanager.cxx:1311
#25 0xb7ee26ca in desktop::Desktop::OpenSplashScreen (this=0xbffff200)
    at /home/cono/src/git/libo_core/desktop/source/app/app.cxx:3055
#26 0xb7ed9c2f in desktop::Desktop::Main (this=0xbffff200) at
/home/cono/src/git/libo_core/desktop/source/app/app.cxx:1549
#27 0xb5e79da8 in ImplSVMain () at
/home/cono/src/git/libo_core/vcl/source/app/svmain.cxx:178
#28 0xb5e79ee0 in SVMain () at
/home/cono/src/git/libo_core/vcl/source/app/svmain.cxx:215
#29 0xb7f08da4 in soffice_main () at
/home/cono/src/git/libo_core/desktop/source/app/sofficemain.cxx:67
#30 0x080485ec in sal_main () at
/home/cono/src/git/libo_core/desktop/source/app/main.c:34
#31 0x080485c0 in main (argc=1, argv=0xbffff344) at
/home/cono/src/git/libo_core/desktop/source/app/main.c:33
Comment 13 Cor Nouws 2011-12-13 12:52:50 UTC
Hi *,

Is the most recent info I gave useful?

Looking at the error message
   "... `ScreenCount (GDK_DISPLAY_X11 (display)->xdisplay) > screen_num' failed "
and indeed the ourput of xrandr for me, showing three devises ( :-) ) there seems to be a trace to follow.

And of course, something in the code has changed that it crashes me nwo and did not before...

Anything I can do to help?
Comment 14 Michael Meeks 2011-12-16 08:00:32 UTC
Pushed what (I hope) is a fix; at least it shouldn't crash anymore:

commit 9bdfd1fa4dde2f4901900f7447b588c2640ff3f4
Author: Michael Meeks <michael.meeks@suse.com>
Date:   Fri Dec 16 15:56:23 2011 +0000

    teach old-style method about the new form of screen numbering fdo#43458
    
    We number now with a flat set of indicees across Xinerama
    and more standard multi-screen setups.

I'll pick that back into 3.5.0 - should be in B2.
Comment 15 Cor Nouws 2011-12-16 08:09:09 UTC
(In reply to comment #14)
> Pushed what (I hope) is a fix; at least it shouldn't crash anymore:

Thanks!
I had a local build from iirc November 30 with the same bug. So I could try to apply your patch and see if it solves the problem?
Comment 16 Michael Meeks 2011-12-17 01:38:45 UTC
sounds fine; the bug has been there for a while :-)
Comment 17 Cor Nouws 2011-12-17 11:23:15 UTC
(was able to bike past the office to test ..)

I paste all output that I've got, since that might give a pointer as to why it still gives an error.


- changed the code according to the patch
- did partial rebuild:

$ cd /vcl
/vcl$ make -sr
/home/cono/src/git/libo_core/vcl/StaticLibrary_vclmain.mk:49: 
[ WARN   ] !!!
[ WARN   ] !!! vcl/source/salmain/salmain is linked in by Library/libvcllo.so StaticLibrary/libvclmain.a
[ WARN   ] !!!
[ build CXX ] vcl/unx/gtk/window/gtkframe
[ build DEP ] LNK:Library/libvclplug_gtklo.so
/home/cono/src/git/libo_core/vcl/StaticLibrary_vclmain.mk:49: 
[ WARN   ] !!!
[ WARN   ] !!! vcl/source/salmain/salmain is linked in by Library/libvcllo.so StaticLibrary/libvclmain.a
[ WARN   ] !!!
[ build LNK ] Library/libvclplug_gtklo.so
[ build MOD ] vcl
[ build ALL ] top level modules: vcl
[ build ALL ] loaded modules: vcl

[ build CHK ] loaded modules: vcl

- did separate install
  $ $ solenv/bin/ooinstall <path>

- running first time without the extra monitor
./program/soffice
create vcl plugin instance with gtk version 2 24 4
warn:configmgr:4423:1:/home/cono/src/git/libo_core/configmgr/source/xcuparser.cxx:764: unknown property "HelpFile" in "file:///home/cono/.config/libreoffice/3/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luyt7gbc.tmp/SunPresentationMinimizer.xcu"
warn:configmgr:4423:1:/home/cono/src/git/libo_core/configmgr/source/xcuparser.cxx:764: unknown property "STR_HELP" in "file:///home/cono/.config/libreoffice/3/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luyt7gbc.tmp/SunPresentationMinimizer.xcu"

** (soffice:4423): WARNING **: Internal - un-mapped error

** (soffice:4423): WARNING **: Internal - un-mapped error

** (soffice:4423): WARNING **: Internal - un-mapped error

** (soffice:4423): WARNING **: Internal - un-mapped error

** (soffice:4423): WARNING **: Internal - un-mapped error

** (soffice:4423): WARNING **: Internal - un-mapped error
Exited with code '0'

  > so it runs fine


- running the second time with the trouble causing monitor:
$ ./program/soffice
create vcl plugin instance with gtk version 2 24 4
warn:configmgr:5705:1:/home/cono/src/git/libo_core/configmgr/source/xcuparser.cxx:764: unknown property "HelpFile" in "file:///home/cono/.config/libreoffice/3/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luyt7gbc.tmp/SunPresentationMinimizer.xcu"
warn:configmgr:5705:1:/home/cono/src/git/libo_core/configmgr/source/xcuparser.cxx:764: unknown property "STR_HELP" in "file:///home/cono/.config/libreoffice/3/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luyt7gbc.tmp/SunPresentationMinimizer.xcu"
Exited with code '139'
cono@cono-tm-new:~/LibreOffice/35master111130A$ ./program/soffice
create vcl plugin instance with gtk version 2 24 4
warn:configmgr:5726:1:/home/cono/src/git/libo_core/configmgr/source/xcuparser.cxx:764: unknown property "HelpFile" in "file:///home/cono/.config/libreoffice/3/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luyt7gbc.tmp/SunPresentationMinimizer.xcu"
warn:configmgr:5726:1:/home/cono/src/git/libo_core/configmgr/source/xcuparser.cxx:764: unknown property "STR_HELP" in "file:///home/cono/.config/libreoffice/3/user/extensions/bundled/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/luyt7gbc.tmp/SunPresentationMinimizer.xcu"
Exited with code '139'

 >> does not start
Comment 18 Caolán McNamara 2011-12-19 03:01:01 UTC
which suggests an additional problem with no proven link to the first one.
Comment 19 Michael Meeks 2011-12-19 03:23:29 UTC
Gosh - what fun :-) So - finding these 'exited with error 12345' type errors is a bit of a pain. You need to:

gdb ./soffice.bin
b _exit
b exit
r

and then when it exits, a 't a a bt' would be great.

Thanks for persisting Cor ! - much appreciated. Are you sure that the problem is specific to connecting the 2nd monitor ?

I'm also rather interested in your hardware: how did you get this odd TV output goodness ? :-)
Comment 20 Cor Nouws 2011-12-19 13:22:33 UTC
(In reply to comment #18)
> which suggests an additional problem with no proven link to the first one.

might well be. I'm known for strange problems ;-)

(In reply to comment #19)
> Gosh - what fun :-) So - finding these 'exited with error 12345' type errors is
> a bit of a pain. You need to:

I realised later - but was running for a train ...
Will be at the office tomorrow and create better output
Comment 21 Cor Nouws 2011-12-20 01:43:20 UTC
Created attachment 54594 [details]
gdb output

so attached the output with gdb running. Hope it is helpful.
Comment 22 Michael Meeks 2011-12-20 06:26:14 UTC
Easy to fix the crasher you point to, -but- since I can't reproduce it - and it is only a symptom not the real bug - life is a bit tough ...
Can you give more information on your hardware ? what is this monitor you connect - that looks like a TV1 as well - what is your graphics card (lspci might tell you) etc.
Comment 23 Michael Meeks 2011-12-20 06:40:31 UTC
Really frustrating; I simply can't reproduce this the most exotic combinations of xrandr settings simply don't do it for me. What I really need is ssh access to your machine & some interactive help debugging - is that going to be possible ?
Comment 24 Cor Nouws 2011-12-21 02:12:11 UTC
Hi Michael,

Monitor: Iiyama AS4314UT - must be an old one

$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
01:00.0 Network controller: Intel Corporation WiFi Link 5100
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

ssh: lets talk on ICR, maybe tomorrow? mostly en route today.
Comment 25 Michael Meeks 2012-01-13 09:31:29 UTC
The root cause is a mismatch between gtk+'s new idea of screen indicees, and gtk3's new munged Xinerama screen vs. xrandr monitor magic that I tried to flatten. And therein lies the problem.

Thanks Cor for debugging help !
Comment 26 Michael Meeks 2012-01-13 10:11:25 UTC
It all comes down from non-default primary monitor setting:

xrandr --output VGA1 --primary

on my machine re-creates the problem; once

(gdb) p gdk_screen_get_primary_monitor(<default screen>)

returns 1 not 0 - the fun starts ... nice; should be reasonably possible to debug now.
Comment 27 Michael Meeks 2012-01-14 17:32:06 UTC
I pushed a fix for the crash in master, but that still creates a messed up multi-display / presenter view issue. I have another fix for that - really a one-liner to gtkframe.cxx:

-        maGeometry.nY = aNewMonitor.x;
+        maGeometry.nY = aNewMonitor.y;

But I also have a big slew of API cleanups and consistency improvements to the display code, a very large mechanical change that should make this more robust in future, but would make diffing between 3.5 and master particularly horrific if we don't get it into both.

I'll push that as well on Monday if the tinderboxes look happy.
Comment 28 Christopher M. Penalver 2012-01-16 07:51:51 UTC
As per downstream bug: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/916357

Version -> LibO 3.5.0 Beta2
Platform -> All Linux (All)
Comment 29 Michael Meeks 2012-01-16 08:59:19 UTC
fixed pushed to master and libreoffice-3-5 - will be in 3.5.0RC1.

Thanks all :-)
Comment 30 Cor Nouws 2012-01-17 01:30:24 UTC
pulled from master yesterday and build - does start normally now- thanks :-)