Bug 43465 - Crash when FILEOPEN document with Thai text contents
Summary: Crash when FILEOPEN document with Thai text contents
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-12-02 04:18 UTC by Anton
Modified: 2013-11-27 14:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample Thai file (19.47 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-03-20 20:56 UTC, panyazone
Details
Sample spreasheet (16.41 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-03-21 00:08 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton 2011-12-02 04:18:20 UTC
Open attached file will crash office after 1-2 seconds after showing 1-st page.
in versions 3.4.3, 3.4.4
Comment 1 Anton 2011-12-02 04:28:15 UTC
Example file is more than 3 Mb,  so I post a link
http://dl.dropbox.com/u/1889899/4/ooo/%D0%AD%D0%BA%D1%81%D0%BF%D0%BB%D1%83%D0%B0%D1%82%D0%B0%D1%86%D0%B8%D1%8F%20%D0%A1%D0%9E%D0%9B_2011-10-05.odt
This file was created in OOo 3.3
Comment 2 Roman Eisele 2011-12-02 06:29:14 UTC
I can't reproduce this problem, neither with LibreOffice 3.4.4 with German langpack, running on MacOS X 10.6.8, nor with LibO-dev 3.5.0, Build ID: 549f928-b211287-090bcba-45cf606, build on 2011-12-01. For me, no crash happens, I can scroll and edit the document.

Therefore, maybe a Windows-only bug?
Comment 3 tester8 2012-01-12 06:18:03 UTC
Rainer, please have a look.
Comment 4 panyazone 2012-03-20 20:56:12 UTC
Created attachment 58790 [details]
Sample Thai file

I cannot reproduce this bug with the reporter's file, but I got a similar problem with my attached sample file. I am trying to use existing bug report before opening a new bug report.

I am using LibreOffice 3.5.1.2 Build ID:
dc9775d-05ecbee-0851ad3-1586698-727bf66 under Windows 7 Professional.

I open the Sample Thai file and do nothing for a while, nothing happens. When I start to scroll the page up and down repeatedly using either the center mouse wheel or the vertical scroll bar, LibreOffice crashes. If I test again after the crash, with or without recovering the file, the problem persists. If I continue to test the third time, LibreOffice crashes while trying to show file recovery confirmation screen.
Comment 5 Rainer Bielefeld Retired 2012-03-20 23:51:50 UTC
[Reproducible] with "ทส 0000-2555-ลบข้อมูลใน Drive Network.docx" and parallel installation of "LOdev 3.5.2rc0+  [Build ID: ec752de-73cb0b8-f269e46] Win-x86@6-fast pull time 2012-03-19 11:08:23 – WIN7 Home Premium (64bit).

Document name does not matter, same with renamed "file.docx".
I am not sure what exactly causes the crash, but stepping through document with arrowright generally will cause a crash, and selecting all contents and replacing font by "Arial" also will cause a crash or at least hang.

No crash with  "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]", so regression.

I can not reproduce the problem with Anton's linked sample file (Cyrillic?)
So let's limit the problem to Thai for now

@András:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 6 Rainer Bielefeld Retired 2012-03-21 00:08:22 UTC
Created attachment 58792 [details]
Sample spreasheet

I also see the crash with attached spreadsheet I created with LibO 3.3.0 and copy/paste complete contents of "ทส 0000-2555-ลบข้อมูลใน Drive Network.docx" into a new spreadsheet.

So this one might be DUP of or related to "Bug 46923 - CRASH EDITING Thai text"?
Comment 7 Roman Eisele 2012-03-21 00:39:48 UTC
In order to see if the Thai text problem is platform-dependent, I tested both sample files (the DOCX by panyazone@gmail.com and the new spreadsheet by Rainer Bielefeld) with LibreOffice 3.5.1.2 (Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66) on MacOS X 10.6.8.

Result: NO crashes occur, neither when I scroll through the documents wildly (with mouse wheel, with cursor keys ..) nor when I select all contents and change the font.

Therefore: really a Windows-only bug?!
Could please someone try on some Linux variant(s)?
This could be of some help for finding the exact reason of these crashes ...
Comment 8 Roman Eisele 2012-03-21 00:44:34 UTC
> So this one might be DUP of or related to "Bug 46923 - CRASH EDITING Thai
> text"?

Interesting enough, Bug 46923 is now marked as duplicate of Bug 46750 - "PDF export crash on ODT document", and the latter one should (!) be fixed (see comment #15 there) -- but when this fix will appear is not clear ...

Could someone please test our bug here (Bug 43465) with a recent Master build on Windows, just to see if the situation has changed?
Comment 9 Anton 2012-03-21 01:45:41 UTC
My .odt example file contains big embedded objects (Drawings from .odg files).
I delete first image ("рис. 1") from it (in OOo 3.3), save, and open in LibreOffice when. NO crash now.
Comment 10 Anton 2012-03-21 02:09:12 UTC
Now I again embedd drawing_1 using LibreOffice, save, open in OOo 3.3, save as with other name, reopen new file in LO. No crash ))
Comment 11 Anton 2012-03-21 04:06:01 UTC
And no crash in version 3.5.1 with this document
Comment 12 panyazone 2012-04-12 03:09:06 UTC
I have just tested the new version 3.5.2.2 with the Thai file 58790, and confirm that the problem is solved. Thanks to all who lend his hands to solve this problem.
Comment 13 Rainer Bielefeld Retired 2012-04-12 06:20:04 UTC
Modified Version due to <http://wiki.documentfoundation.org/BugReport_Details#Version>, Summary due to <http://wiki.documentfoundation.org/BugReport_Details#Spreadsheet>, Resolution due to <http://wiki.documentfoundation.org/QA-FAQ#How_to_terminate_a_Bug_if_it_can.27t_be_reproduced_any_longer>  (DUP situation still unclear)

@panyazone@gmail.com:
Please do not modify selectors, only contribute information