Bug 43498 - gtk3 VCL plugin is badly broken (copy/paste fails, graphical corruption on scrolling)
Summary: gtk3 VCL plugin is badly broken (copy/paste fails, graphical corruption on sc...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.0 Beta0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-03 16:20 UTC by Alexandre Rostovtsev
Modified: 2014-06-01 20:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of graphical corruption with gtk3 VCL plugin (180.64 KB, image/png)
2011-12-03 16:20 UTC, Alexandre Rostovtsev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Rostovtsev 2011-12-03 16:20:34 UTC
Created attachment 54096 [details]
screenshot of graphical corruption with gtk3 VCL plugin

The gtk3 VCL plugin in libreoffice-3.5.0.0 has severe problems making it basically unusable. If libreoffice is built with --enable-gtk3 and launched with SAL_USE_VCLPLUGIN=gtk3, then:

1. (as reported in https://bugs.gentoo.org/show_bug.cgi?id=392939) copy/paste to all non-libreoffice applications fails. In other words: text selected in libreoffice-3.5.0.0 writer will not middle-click-paste in any other application (but will middle-click-paste in libreoffice itself). Text selected in any other application will middle-click-paste in any application except for libreoffice. Text copied using Ctrl-C or Edit→Copy in libreoffice-3.5.0.0 writer will not paste using Ctrl-V or Edit→Paste in any other application (but will paste in libreoffice itself). Text copied using Ctrl-C or Edit→Copy in any other application will paste in any application except for libreoffice.

2. (as reported in https://bugs.gentoo.org/show_bug.cgi?id=392943) 3.5.0.0 writer suffers from severe graphical corruption when using the scroll bar to scroll up or down. Blocks of text become garbled, random black lines occasionally appear, and even UI elements (such as the scroll bar itself) sometimes become corrupted. Sample screenshot is attached.

I am seeing these bugs on two different amd64 Gentoo systems running gnome-3.2 with gtk+-3.2.2; one with binary nvidia drivers, the other with open-source intel graphics.
Comment 1 Alexandre Rostovtsev 2011-12-03 16:22:04 UTC
Note: these problems do not occur if libreoffice is launched with SAL_USE_VCLPLUGIN=gtk
Comment 2 Rainer Bielefeld Retired 2011-12-04 10:59:46 UTC
I know these problems with WIN when soft scrolling is activated, is that really new with 3.5 Beta or with what Version did you observe that problem the first time?
Comment 3 Alexandre Rostovtsev 2011-12-04 11:24:53 UTC
(In reply to comment #2)
> I know these problems with WIN when soft scrolling is activated, is that really
> new with 3.5 Beta or with what Version did you observe that problem the first
> time?

The copy/paste problem:
* 3.4.1-3.4.4, gtk vcl plugin: did not occur.
* 3.5 beta, gtk vcl pluguin: does not occur.
* 3.5 beta, gtk3 vcl plugin: occurs 100% of the time.

Scrolling graphical corruption problem:
* 3.4.1-3.4.4, gtk vcl plugin: occurred rarely, affected the document text only.
* 3.5 beta, gtk vcl plugin: does not occur.
* 3.5 beta, gtk3 vcl plugin: occurs 100% of the time, affects both document text and UI elements like scroll bars.
Comment 4 retired 2013-09-01 11:48:48 UTC
Is this bug still valid / reproducible with the latest LO release from http://www.libreoffice.org/download/ ?

Could you please attach the document in question? That would help speed up the process of confirming and successively fixing this bug a lot. Thanks :)
Comment 5 QA Administrators 2014-05-17 00:33:50 UTC
Dear Bug Submitter,

Please read the entire message before proceeding.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 6 QA Administrators 2014-06-01 20:29:48 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO